Enable ECG(BP Featur) On Non-Samsung Phones for Galaxy Watch 3, Active 2 Step-By-Step

athosII

Member
May 10, 2012
9
0
21
Hi
I'm stuck on step 9. I click on scan Devices. As you can see it founds a device with name 'new ' ( is that correct or it should recgnize the watch name ? ). I click on connection but nothing happens.
View attachment 5230489

Both watch and PC are in the same wifi network, bluetooth and gps off.

Other thing, the SHM says no compatible watch found, but i have the watch paired .

Any ideas ?
Thanks in advance.
On your picture is a device connected.
 

p_martins

New member
Jul 4, 2009
3
0
21
On your picture is a device connected.
Yes, but for some reason when i clicked connect it doesn't pass for the previous screen. I don't know how, but it sudently worked. Thanks.
My only problem now, is that SHM doesn't recognize the watch. It recognize it one time, i made a ecg test, but then disconected and now i can't find it anymore.
Anyone with the same problem?
 

Henry

Member
Feb 16, 2018
11
1
3
Melbourne
Hi. Can you tell me if its possible to get the ECG annd BP on GW3, even though it hasnt been approved in my region (Australia)? How would I do that? Thanks in advance.
 

ruszok

Member
Jan 5, 2010
39
3
28
For everyone who have preinstalled BP and can't sideload modded BP - there is solution:
:fingers-crossed:

Ok, so anybody who need: current working BP.tpk you can download here https://drive.google.com/file/d/1TDvDCkruVFWE-h2Ysr4Hc_CXIhkop7dq/view
Upon new updates for BP app here is instruction how to fix it:

1) Unpack content of tpk(regular zip archive) to some folder.
2) Go to this folder and find all files in which include bundle id: com.samsung.health.samd.bp... (I used AstroGrep to find all occurrences). Not only xml, but also binary files (bin folder)!
3) Replace all occurrences you found with some different id by changing of 1 character(etc to com.samsung.health.samd.bb).
4) Go bin folder and rename correspondently to your renaming name of the files.
For example:
health-samd-bp-home -> health-samd-bb-home,
health-samd-bp-service->health-samd-bb-service,
health-samd-bp-widget->health-samd-bb-widget
5) Go to root folder again and find all occurrences of health-samd-bp... inside of all files. Replace it with health-samd-bb....
6) Pack all modified files back
7) Sign and install.
 
Feb 24, 2021
8
1
3
Hi
I'm stuck on step 9. I click on scan Devices. As you can see it founds a device with name 'new ' ( is that correct or it should recgnize the watch name ? ). I click on connection but nothing happens.
View attachment 5230489

Both watch and PC are in the same wifi network, bluetooth and gps off.

Other thing, the SHM says no compatible watch found, but i have the watch paired .

Any ideas ?
Thanks in advance.

Hi, I have the same problem, it appears to me as connected and when I close the window it does not appear in the Device Manager window. I go back to the remote device manager and it's off. Sometimes it gives this error:

error: failed to connect to remote target "IP number"

You may get this message for following reasons:
This remote device is already connected by another one
This remote device is running on a non-standard port
There is no IP adress, please check the physical connection

How did you solve your problem?

Ps: I already had the bluetooth off and only the wifi on.
 

SirPhilippF

Senior Member
Aug 14, 2017
50
4
8
Düsseldorf
Hi, I have the same problem, it appears to me as connected and when I close the window it does not appear in the Device Manager window. I go back to the remote device manager and it's off. Sometimes it gives this error:

error: failed to connect to remote target "IP number"

You may get this message for following reasons:
This remote device is already connected by another one
This remote device is running on a non-standard port
There is no IP adress, please check the physical connection

How did you solve your problem?

Ps: I already had the bluetooth off and only the wifi on.
You have too try it several times. I had the same issue. It will help to restart the watch and connect again to the Wifi (bluetooth must be of and Wif should be always on)
 

p_martins

New member
Jul 4, 2009
3
0
21
Hi, I have the same problem, it appears to me as connected and when I close the window it does not appear in the Device Manager window. I go back to the remote device manager and it's off. Sometimes it gives this error:

error: failed to connect to remote target "IP number"

You may get this message for following reasons:
This remote device is already connected by another one
This remote device is running on a non-standard port
There is no IP adress, please check the physical connection

How did you solve your problem?

Ps: I already had the bluetooth off and only the wifi on.
Look your watch.
After many tries, i notice that my watch was asking for some permission ( after connection switch to on ) . After i acepted it , the watch appear in the device manager.
I don't remember if I did anything different this time, compared to the others.
See if it helps.
 
Feb 24, 2021
8
1
3
Look your watch.
After many tries, i notice that my watch was asking for some permission ( after connection switch to on ) . After i acepted it , the watch appear in the device manager.
I don't remember if I did anything different this time, compared to the others.
See if it helps.
Mine hasn't asked for anything yet, the only thing that is different is "Developer options" in the settings as it is supposed to and says connected. I'm going to hang up and do the procedure again on the smartwatch, thanks
 
Feb 24, 2021
8
1
3
Mine hasn't asked for anything yet, the only thing that is different is "Developer options" in the settings as it is supposed to and says connected. I'm going to hang up and do the procedure again on the smartwatch, thanks
I tried now several times, the error does not appear, but when I connect to the remote device manager I close the window and nothing appears in the device manager, I go back there and I close it and continue ... just not doing anything, I already went to the smartwatch see all permissions I have everything active, gps and bluetooth off and wifi always on, I think there is nothing more to do :/
Thanks
 

SirPhilippF

Senior Member
Aug 14, 2017
50
4
8
Düsseldorf
I tried now several times, the error does not appear, but when I connect to the remote device manager I close the window and nothing appears in the device manager, I go back there and I close it and continue ... just not doing anything, I already went to the smartwatch see all permissions I have everything active, gps and bluetooth off and wifi always on, I think there is nothing more to do :/
Thanks
You definitely have to allow permissions in the watch when you want to connect with the device manager. There will popup a request in the watch!