• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Enable EIS (Electronic image Stabilization) [Root]

Search This thread

zurih

Senior Member
Jun 17, 2011
208
106
There is a way to enable EIS on Nexus 5X just as it's enabled in Nexus 6P. It was posted originally on Reddit here.

1. Edit build.prop
2. Add this line: persist.camera.eis.enable=1
3. Reboot
4. Go to Camera settings --> Resolution & Quality
5. Check "Enable video stabilization"

7avuzuy.png
 
Last edited:

peltus

Senior Member
Apr 14, 2015
429
182
Bennekom
I did the following:
Copy build.prop to SD and edit using es file Explorer.
Copy backup build.prop to different folder.
Boot recovery.
I mounted system read write in twrp.
Used twrp file browser to copy modified build.prop back to system.

Reboot resulted in bootloop.
Bootloop fixed by setting chmod 755 permissions to build.prop in twrp.

Succesfully implemented setting!
 

mikeyinid

Senior Member
Sep 4, 2010
8,875
4,000
Boise
So, what does this line do?
Code:
persist.camera.is_type=4

I'm looking at the 6P build.prop, and they're together:
Code:
persist.camera.eis.enable=1
persist.camera.is_type=4
 
  • Like
Reactions: kimikim0

mikeyinid

Senior Member
Sep 4, 2010
8,875
4,000
Boise
Got my type A to type C cable tonight. Eis definitely works making this change but I can tell you it doesn't work well. I have a V10 which has ois and that actually works well. Still better than nothing I suppose.
 

iPwn_

Senior Member
Aug 3, 2011
500
165
So, what does this line do?
Code:
persist.camera.is_type=4

I'm looking at the 6P build.prop, and they're together:
Code:
persist.camera.eis.enable=1
persist.camera.is_type=4

I enabled both. Seems to work fine.

Only thing is, with EIS enabled, the viewfinder seems to lag half a second behind the actual motion of the device. So if I turn around, the viewfinder shows me turning around after I actually start doing so.

With EIS off, I don't see this.
 
Last edited:

Top Liked Posts