Enable Google Lens in Google Photos [MAGISK] [7.x.x/8.x.x]

Status
Not open for further replies.

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
4,339
8,194
263
30
Ambala
Introduction
Hello everyone! Having just now read this XDA article, I decided to try out the flashable zip linked in it. Needless to say, it worked like a charm! Hence, I decided to create a Magisk module for this so that those who don't want to mess with their system partitions can use the module to enable Google Lens in Google Photos. Have fun!

Compatibility
Device(s)
  • OnePlus 5
ROM(s)
  • All ROMs
Android Version(s)
  • Android Nougat 7.x.x
  • Android Oreo 8.x.x

Installation Instructions
  • Copy the correct module as per your Magisk version to your phone's internal memory
  • Open Magisk Manager
  • Go to the Modules section
  • Click on the "+" Floating Button and select the module zip
  • Reboot

Recovery
  • Open Magisk Manager
  • Go to the Modules section
  • Disable/uninstall the module
  • Reboot

Thanks To
  • @ZeevoX, for creating the original Google Lens Enabler flashable zip
  • @topjohnwu, for Magisk and all the work he's ever done for the community
  • All of you guys for viewing this thread

Changelog
GoogleLensEnabler-Magisk15.0
  • v1.0 - Initial release
  • v2.0 - Update for Magisk v15.0

OP Update Information
Created: October 25, 2017
Last Updated: December 28, 2017
 
Last edited:

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
4,339
8,194
263
30
Ambala
Did you clear data ?? And photos version you are using is ?

Didnt work in my 1+5
There wasn't any need to clear data for me. Loaded the module, restarted the phone, opened Google Photos and force-closed/killed it, reopened Google Photos and Google Lens was there. :)

The issue is most definitely at your end since the module has been working fine for me, my testers and all the people who've posted in this thread.
 
  • Like
Reactions: addicted1900

surajloharia

Senior Member
Oct 28, 2012
237
66
48
There wasn't any need to clear data for me. Loaded the module, restarted the phone, opened Google Photos and force-closed/killed it, reopened Google Photos and Google Lens was there. :)

The issue is most definitely at your end since the module has been working fine for me, my testers and all the people who've posted in this thread.
One thing i forget ... When i restarted after flashing module got bootloop and restarted by long pressing and phone rebooted


May be thats the reason i will try again

Fresh install
 

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
4,339
8,194
263
30
Ambala
One thing i forget ... When i restarted after flashing module got bootloop and restarted by long pressing and phone rebooted

May be thats the reason i will try again

Fresh install
Please make sure that you're using the correct module zip for your Magisk version. If you use the wrong module zip for your Magisk version, it might end up in a bootloop, so.
 

surajloharia

Senior Member
Oct 28, 2012
237
66
48
Please make sure that you're using the correct module zip for your Magisk version. If you use the wrong module zip for your Magisk version, it might end up in a bootloop, so.
Using 14 downloaded 14

---------- Post added at 11:13 AM ---------- Previous post was at 10:55 AM ----------

Please make sure that you're using the correct module zip for your Magisk version. If you use the wrong module zip for your Magisk version, it might end up in a bootloop, so.
Hey buddy reflashed zip but still no go

Does xposed interefere with this ??

Or one thing i can do is remove overlays from photos and google app

Will report soon

Edit: removed overlay and it workd

And still works after installing overlay again


Thankx for the module
 
Last edited:

gonsa

Senior Member
Aug 4, 2010
651
228
0
Lisbon
This is supposed to work only after we take a picture, right? It doesn't work if we open the camera and let google lens do it's work?
 

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
4,339
8,194
263
30
Ambala
This is supposed to work only after we take a picture, right? It doesn't work if we open the camera and let google lens do it's work?
Camera? Where did that come from? :p It works in Google Photos. Google Camera has got nothing to do with Google Lens. :) Basically, take a picture (from any Camera app), it'll get saved and will appear in Google Photos. Open that picture there and you will see a Lens button at the bottom.

I am currently running Magisk 14.3 and i flashed v14.3 of google lens, but whenever i am opening google photos it's Force-closing every time.
Make sure you don't have any substratum theme overlays applied to Google Photos. If you don't have a theme/it still doesn't work after removing the theme and restarting, you can try clearing the data and cache of Google Photos from the settings and restarting your phone before launching Google Photos again. Good luck! :good:
 

gonsa

Senior Member
Aug 4, 2010
651
228
0
Lisbon
Camera? Where did that come from? :p It works in Google Photos. Google Camera has got nothing to do with Google Lens. :) Basically, take a picture (from any Camera app), it'll get saved and will appear in Google Photos. Open that picture there and you will see a Lens button at the bottom.
Well, actually Google Lens has everything to do with the Camera.
Check this out: https://youtu.be/Y2VF8tmLFHw?t=669
 
Status
Not open for further replies.