Enable hotspot for legacy dataplans

Search This thread

Ewto16

Member
Oct 21, 2015
45
1
28
Is there a way to enable the hotspot feature on the 4a for those of us with legacy unlimited data plans? I used to be able to use something and write to the boot.ini, but that doesn't work on my OG Pixel XL anymore. I'm currently using Magisk and a tethering plugin. Would this same setup work on the 4a?

Thanks!
 

tweaked

Senior Member
Sep 12, 2008
1,262
701
143
Your Moms house
I am using magisk, newest version canary and I have installed the mod; tethering enabler 11.0.0 by stangri and fox8091 as the mod I was using on the p2xl with magisk was no longer working. Tether is working.
 

chrispayne

Senior Member
Apr 14, 2010
52
11
28
I am on 11 and using it.

Hmm, not working for me on 11. The warning turning on hotspot (or USB tethering) is gone, but any connected devices do not have internet access.

There must be another property or setting to allow the traffic, maybe like ip_forward in Linux? Anyone have any ideas?
 

crackerjack1957

Senior Member
Nov 1, 2012
532
201
63
Hmm, not working for me on 11. The warning turning on hotspot (or USB tethering) is gone, but any connected devices do not have internet access.

There must be another property or setting to allow the traffic, maybe like ip_forward in Linux? Anyone have any ideas?

Termux app or working emulator
su
enter
global tether_dun_required 0
enter
exit
reboot

or ADB shell
 
Last edited:

chrispayne

Senior Member
Apr 14, 2010
52
11
28
Termux app or working emulator
or ADB shell
global tether_dun_required 0

Yeah, I have both of these set (although I had to use a slightly different syntax). I have tried using the Magisk module from here, and also manually (below), with required reboots:
Code:
The current value for
net.tethering.noprovisioning is:

true
(Set by this module.)

Enter a new value or select
from the options below.

s - Prop boot stage (system.prop)
d - Delay
r - Reset prop
b - Go back
e - Exit

Enter your desired option: e

MagiskHide Props Config v5.3.6
by Didgeridoohan @ XDA Developers

=====================================
 Bye bye.
=====================================

sunfish:/ # settings get global tether_dun_required                                                                                                                                                                  
0
sunfish:/ #
I see some iptables rules related to tethering, which I also tried removing, and changing to ACCEPT, but still no traffic passes:
Code:
sunfish:/ # iptables -nL tetherctrl_FORWARD --line-numbers                                                                                                                                                           
Chain tetherctrl_FORWARD (1 references)
num  target     prot opt source               destination         
1    DROP       all  --  0.0.0.0/0            0.0.0.0/0           
sunfish:/ # iptables -D tetherctrl_FORWARD 1                                                                                                                                                                         
sunfish:/ # iptables -I tetherctrl_FORWARD 1 -s 0.0.0.0/0 -j ACCEPT                                                                                                                                                  
sunfish:/ # iptables -nL tetherctrl_FORWARD --line-numbers                                                                                                                                                           
Chain tetherctrl_FORWARD (1 references)
num  target     prot opt source               destination         
1    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
sunfish:/ #
I will take a closer look at the iptables rules, ip rules, and routes. Something else is going on, at least for me.

Thanks for the response.
 

crackerjack1957

Senior Member
Nov 1, 2012
532
201
63
Yeah, I have both of these set (although I had to use a slightly different syntax). I have tried using the Magisk module from here, and also manually (below), with required reboots:
Code:
The current value for
net.tethering.noprovisioning is:

true
(Set by this module.)

Enter a new value or select
from the options below.

s - Prop boot stage (system.prop)
d - Delay
r - Reset prop
b - Go back
e - Exit

Enter your desired option: e

MagiskHide Props Config v5.3.6
by Didgeridoohan @ XDA Developers

=====================================
 Bye bye.
=====================================

sunfish:/ # settings get global tether_dun_required                                                                                                                                                                  
0
sunfish:/ #
I see some iptables rules related to tethering, which I also tried removing, and changing to ACCEPT, but still no traffic passes:
Code:
sunfish:/ # iptables -nL tetherctrl_FORWARD --line-numbers                                                                                                                                                           
Chain tetherctrl_FORWARD (1 references)
num  target     prot opt source               destination         
1    DROP       all  --  0.0.0.0/0            0.0.0.0/0           
sunfish:/ # iptables -D tetherctrl_FORWARD 1                                                                                                                                                                         
sunfish:/ # iptables -I tetherctrl_FORWARD 1 -s 0.0.0.0/0 -j ACCEPT                                                                                                                                                  
sunfish:/ # iptables -nL tetherctrl_FORWARD --line-numbers                                                                                                                                                           
Chain tetherctrl_FORWARD (1 references)
num  target     prot opt source               destination         
1    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
sunfish:/ #
I will take a closer look at the iptables rules, ip rules, and routes. Something else is going on, at least for me.

Thanks for the response.

Forgot to mention I am on Android 10 thru Verizon legacy unlimited plan.
I see someone else mentioned it was working with Android 11 but I cannot confirm........stayed on 10 for the audio mods & OS slow down of 11.
 
Last edited:

mpannen

Member
Jun 5, 2008
27
8
23
I used plain jane Magisk with no additional hacks to get me root.

Then, I use this program to turn on the tethering (wifi, ethernet, or USB):


This is the only way I've found to work with Android 11 for me.
 

Ewto16

Member
Oct 21, 2015
45
1
28
I just updated to the Feb release of Android 11. I followed the steps below to get tethering working. Seems to work just fine.

adb shell
su
props

Once the props load, do the following:
Enter 5, Add/edit custom props
Enter n, New custom prop
Enter net.tethering.noprovisioning
Enter true
Enter 2, post-fs-data
Enter y
Enter y to reboot
 

tweaked

Senior Member
Sep 12, 2008
1,262
701
143
Your Moms house
You all are odd. I just got my phone back from ubreakifix - fully wiped it. rooted it Magisk and downloaded and installed that zip again. Im using my laptop hotspotted to my phone to post now.....Android 11 feb.... Newest magisk. lol