Enable Soli for any contries through Magisk module

DinarQ8

Senior Member
Nov 23, 2010
555
107
73
Kuwait City
I download the file and flashed by Magsik i got failed " This zip in not a Magsik Module
I am new in root+Magsik game :)

Pixel4XL - Oct
 
Last edited:

dengxm

New member
Nov 6, 2019
1
2
0
I download the file and flashed by Magsik i got failed " This zip in not a Magsik Module
I am new in root+Magsik game :)

Pixel4XL - Oct
If the error states that it's not a Magisk zip, or invalid zip in TWRP, the zip is not packaged correctly. Open up the zip and you'll likely see a folder (probably named something like <nameofmodule>-master or similar, or something completely different). Take all the contents of that folder and repack it to the root of the zip and try flashing it again.
 
  • Like
Reactions: sotong and DinarQ8

DinarQ8

Senior Member
Nov 23, 2010
555
107
73
Kuwait City
If the error states that it's not a Magisk zip, or invalid zip in TWRP, the zip is not packaged correctly. Open up the zip and you'll likely see a folder (probably named something like <nameofmodule>-master or similar, or something completely different). Take all the contents of that folder and repack it to the root of the zip and try flashing it again.
Thank you so much work great [emoji1360]

Sent from my Pixel 4 XL using Tapatalk
 

DinarQ8

Senior Member
Nov 23, 2010
555
107
73
Kuwait City
i download the release file and flush it, no issue occured. Did you download this file from release page?
Just now i see i downloaded wrong file something name clone file this file not flashing. After edit the file i see there a original file on the site flashing without any issues [emoji4]Screenshot_20191106-190109.jpg

Sent from my Pixel 4 XL using Tapatalk
 

sotong

Senior Member
Sep 9, 2008
103
17
0
Works great! I had to repackage the zip contents into a new zip folder but after that, no problem with the Magisk flashing. Thanks for the effort :)
 

salamdiab

Member
Nov 8, 2019
29
6
0
i try to enable by this models
but nothing
i had edxpose models and disabled it and try to insall the magisk models and after flashing and reboot didnt work
do i need to uinstall the xdpose app and models and riru core and riru edxpsosed
thanks
or maby i clone wrong the files
 

yousefteh

New member
Jan 3, 2020
2
0
0
hello, i repackaged the zip file but it is still saying that it is not a magisk module. Is there a specific program for repackaging or am i missing something?
 

dotcink

New member
May 6, 2017
4
1
0
Not working for me.

It's installed with no problem, but when I reboot, the Motion Sense is still disabled.

By the way, the following command still works.
Code:
setprop pixel.oslo.allowed_override true
setprop persist.pixel.oslo.allowed_override true
setprop ctl.restart zygote
 

lapapunk

Senior Member
Aug 22, 2014
402
156
0
Odessa
Not working for me.

It's installed with no problem, but when I reboot, the Motion Sense is still disabled.

By the way, the following command still works.
Code:
setprop pixel.oslo.allowed_override true
setprop persist.pixel.oslo.allowed_override true
setprop ctl.restart zygote
U can do this with magisk Hide props conf.
U should install this module, then install terminal, type :
Su
Props
Add new props (u should choose it from the list)
Add only this: pixel.oslo.allowed_override true

Reboot / profit
 
Last edited:

ozikat12

Member
Aug 19, 2011
17
1
0
U can do this with magisk Hide props conf.
U should install this module, then install terminal, type :
Su
Props
Add new props (u should choose it from the list)
Add only this: pixel.oslo.allowed_override true

Reboot / profit
This works perfectly fine and it's clean cut. Thanks.