Enable Soli for any contries through Magisk module

Search This thread

lhenriquezc

Member
Nov 2, 2010
18
3
works if it is set to 1 instead of true. tested in my pixel 4 xl.

Set it to one, Can you posted, please

You mean this

setprop pixel.oslo.allowed_override true
setprop persist.pixel.oslo.allowed_override true
setprop ctl.restart zygote

Change true to 1

setprop pixel.oslo.allowed_override 1
setprop persist.pixel.oslo.allowed_override 1
setprop ctl.restart zygote
 
  • Like
Reactions: peikojose

caballero221

Senior Member
Apr 16, 2014
64
7
Guadalajara
Google Pixel 4
EDIT:
It´s works!!

I installed the last version of the module
and in terminal emulator I wrote:
setprop pixel.oslo.allowed_override 1
setprop persist.pixel.oslo.allowed_override 1
setprop ctl.restart zygote

And voilá (I don't know why termux not work, but terminal emulator do it)

*******
I don't know why but in my pixel don't work any method, I try ADB, build.prop, magisk module and xposed.

how you do work?
 
Last edited:
EDIT:
It´s works!!

I installed the last version of the module
and in terminal emulator I wrote:
setprop pixel.oslo.allowed_override 1
setprop persist.pixel.oslo.allowed_override 1
setprop ctl.restart zygote

And voilá (I don't know why termux not work, but terminal emulator do it)

*******
I don't know why but in my pixel don't work any method, I try ADB, build.prop, magisk module and xposed.

how you do work?

Sorry, I'm at march update, usind the 1.2 update of the magisk module, how you did it to get it work on May update? using the 1.2 ? or other ?
thanks!!!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    The last post i write a EdXposed module to enable Soli.
    Now I'm write a Magisk module to enable Soli without restart zygote,and reboot the device will keep Soli to enabled.
    Please go to github and download this module ,the url is https://github.com/demj1206170/EnableSoli
    and feedback if there have any issues.
    3
    Not working for me.

    It's installed with no problem, but when I reboot, the Motion Sense is still disabled.

    By the way, the following command still works.
    Code:
    setprop pixel.oslo.allowed_override true
    setprop persist.pixel.oslo.allowed_override true
    setprop ctl.restart zygote

    U can do this with magisk Hide props conf.
    U should install this module, then install terminal, type :
    Su
    Props
    Add new props (u should choose it from the list)
    Add only this: pixel.oslo.allowed_override true

    Reboot / profit
    2
    I download the file and flashed by Magsik i got failed " This zip in not a Magsik Module
    I am new in root+Magsik game :)

    Pixel4XL - Oct

    If the error states that it's not a Magisk zip, or invalid zip in TWRP, the zip is not packaged correctly. Open up the zip and you'll likely see a folder (probably named something like <nameofmodule>-master or similar, or something completely different). Take all the contents of that folder and repack it to the root of the zip and try flashing it again.
    2
    Yep. Sadly it doesn't.
    works if it is set to 1 instead of true. tested in my pixel 4 xl.
    1
    I download the file and flashed by Magsik i got failed " This zip in not a Magsik Module
    I am new in root+Magsik game :)

    Pixel4XL - Oct

    i download the release file and flush it, no issue occured. Did you download this file from release page?