Endless safe-mode loop after water damage

Search This thread

DarkShadowMX

Senior Member
Dec 19, 2010
53
6
Hi all!

My phone got water damaged (a little bit, the back cover wasn't properly put) and the phone now turns on only in safe-mode, even if I reboot, pull the battery or do a factory reset. My volume-down key doesn't work now, if that could be the problem.

Does anyone know what I could do? :(

Thank you
 

LoSt180

Senior Member
Dec 21, 2011
206
87
Mine was doing the exact same thing, except my volume-down key acted as if it was being pressed down constantly. I spilled water on it while on a cruise and it wasn't the same. My phone would constantly mute and the volume overlay was constantly visible on the screen. I had the safe-mode on reboot several times, I'm assuming holding the volume-down during boot is what activates it.

My fix was pretty brutal, I popped the volume button off with a thumb tack, then uses tweezers to rip the volume ribbon cable out of the phone. I now have to go into the settings menu to adjust volume, but at least the phone is usable. My hunch is that water damaged the ribbon cable via the volume button.

The actual fix would be to replace the frame/back housing bezel for the phone. It's only about $8 on Amazon (http://amzn.com/B00K458DUK), however it requires removing the screen. My phone has been dropped a few times so I'm worried the screen won't survive a transplant. A replacement screen is $150, so I've just been dealing with no volume control for now.
 

DarkShadowMX

Senior Member
Dec 19, 2010
53
6
I see... thanks for your input! I'm guessing mine is having the same problem. I'm not comfortable doing the brutal fix myself, but I don't know where I could take it around here to get it fixed.