[EOL][11.0][OFFICIAL] LineageOS 18.1 for Oneplus 5 & 5T

Search This thread

mgmeulen

Member
Jul 27, 2015
6
2
just a query: will LDAC work ? all the bluetooth options on my 5T running latest lineage 18.1 are greyed out in developer options by default, but i recognise some become available when paired... but i don't have any LDAC devices (yet! which is the reason for my enquiry)

can anyone confirm success ?
Yes LDAC works for me on OP5 using Sony WF-1000XM4.
 

tobby88

Senior Member
Jul 4, 2012
236
63
Hanover
OnePlus 5

Attachments

  • Tobby_8.2_v1.7_27.02.2022.xml
    76.2 KB · Views: 14

4PDAXDA

Member
Dec 3, 2020
7
0
Google Pixel 3


It lags crazy for me for some reason. is that normal?
Do I need root for magisk? how do I install that?

also, where do I put the XML file?

thanks much, I appreciate
 

4PDAXDA

Member
Dec 3, 2020
7
0
Google Pixel 3
Yes, that issue is a known one:

The first one got closed, but the issue persists since about a year. Really annoying :-/ But since a few hours there seems to be an ugly fix for it? https://gitlab.com/divested-mobile/divestos-build/-/commit/927b9bfbc584e373a77358025d21fae183025c87
It says it's tested on cheeseburger (OP5). Maybe @T1mb3 can include it in the LineageOS builds?

Yes, that issue is a known one:

The first one got closed, but the issue persists since about a year. Really annoying :-/ But since a few hours there seems to be an ugly fix for it? https://gitlab.com/divested-mobile/divestos-build/-/commit/927b9bfbc584e373a77358025d21fae183025c87
It says it's tested on cheeseburger (OP5). Maybe @T1mb3 can include it in the LineageOS builds?
so what do I need to do to implement this fix?
 

tobby88

Senior Member
Jul 4, 2012
236
63
Hanover
OnePlus 5
It lags crazy for me for some reason. is that normal?
No, that's not normal. No lags here.

Do I need root for magisk? how do I install that?
You don't need root for Magisk - Magisk gives you root. But you don't need Magisk. There's an alternative without Magisk, flashable via recovery (TWRP). Look at that link again.

If you don't have root, you may also try this XML: https://www.celsoazevedo.com/files/android/p/f/2021/07/Nik-8.1-non-root.xml
But try the other ones before.

also, where do I put the XML file?

so what do I need to do to implement this fix?
Recompile Lineage yourself, do your own inofficial build, include this fix.
 

Regina Rainbow

Senior Member
Nov 1, 2015
74
96
so what do I need to do to implement this fix?

You can try my home builds of LineageOS 18.1 for Dumpling. They are vanilla LineageOS 18.1 (for microG), I only added the fix for these soft reboots. I'm using my own microG build for a few weeks now and the reboots have vanished:

LineageOS 18.1 (vanilla + patch): https://androidfilehost.com/?fid=14655340768118472482
LineageOS 18.1 for microG (+patch): https://androidfilehost.com/?fid=14655340768118472469

One advice, though. Coming from the official build of 18.1 you might

either do a clean install

or first flash migration ZIP by @codeworkx in recovery and afterwards dirty flash my unofficial build over the official one.

... or else bad things might happen! ;-)
 
Last edited:

Listerine

Senior Member
Aug 11, 2011
60
2
It lags crazy for me for some reason. is that normal?
Do I need root for magisk? how do I install that?

also, where do I put the XML file?

thanks much, I appreciate
Actually it's totally normal for Gcam to lag like crazy. Also if you examine the photos closely you'll see a bunch of dots like in a grid pattern. The issue I think is specific to the OnePlus 5/5T.

There is a solution however. If you use Magisk and download the "OnePlus 5/5T Dotfix" module it fixes the issue. After doing that photos look great. One problem I still run into, is that with video using Gcam, the volume is super quiet.
 

danikXD

New member
Apr 15, 2019
1
0
Anybody encountered an issue in 18.1-20220418-nightly where the alarm doesn't show on the screen? The alarm sound plays, but to stop it I need to go into the app itself and remove it
 

4PDAXDA

Member
Dec 3, 2020
7
0
Google Pixel 3
Actually it's totally normal for Gcam to lag like crazy. Also if you examine the photos closely you'll see a bunch of dots like in a grid pattern. The issue I think is specific to the OnePlus 5/5T.

There is a solution however. If you use Magisk and download the "OnePlus 5/5T Dotfix" module it fixes the issue. After doing that photos look great. One problem I still run into, is that with video using Gcam, the volume is super quiet.
be cool if there was another way, cause mine is sucking at the moment and I need a one stop solution hahaha, would love to have it work like on the Pixel
 

DaniRainbow

Member
Nov 10, 2015
17
1
Hello,

After updating to the latest nightly release, Magisk, and getting SafetyNet to work again I lost RCS support in Google Messages. Anyone else experience this and know how to fix it? Thanks
 

Top Liked Posts