Development [EOL][ROM][11.0][Beta] DerpFest R for Mi 11 [OFFICIAL][VENUS]

Search This thread
Mar 1, 2021
38
22
I really like the rom, its beautiful with custumisations.

But actually since start, the phone gets hot often. Not miui-like hot. I also get batt drain during this. When i flash los back, the phone stays normal and does not have this issue.

Im on latest version. Have no magisk mods installed. Just some ui customs through derpfest menu. I dont see anything weird at batt menu. It also gets hot in my pocket. Had flashed miui stable before this and as i said, los didnt had this issue.

Some others with the same issue? :) i still stick with the rom because i like the looks and speed of it tho
 

franpr

Member
Jul 24, 2018
10
1
Anyone know why I get an error when flashing magisk? "

Couldn’t Find meta-inf/com/google/android/update-binary​

"
 

VortexHD

Senior Member
New Update 06-11-2021

Download:- Sourceforge (do not flash GApps. They are prebuilt)

Changelog:
*Downgraded the kernel
*Set screen density to 515
*Enabled GBoard rounded corners
*Updated to latest CN build fingerprint
*Removed FM Radio
*Official DerpFest build

Instructions:- See first post

Note:-
[MAGISK] Flash Magisk after first boot. Supported magisk Magisk v22.x
 

Pho3nX

Senior Member
Jun 13, 2013
2,647
1,895
New Update 06-11-2021

Download:- Sourceforge (do not flash GApps. They are prebuilt)

Changelog:
*Downgraded the kernel
*Set screen density to 515
*Enabled GBoard rounded corners
*Updated to latest CN build fingerprint
*Removed FM Radio
*Official DerpFest build

Instructions:- See first post

Note:-
[MAGISK] Flash Magisk after first boot. Supported magisk Magisk v22.x

Congrat for the good job & official builder !
 

franpr

Member
Jul 24, 2018
10
1
New Update 06-11-2021

Download:- Sourceforge (do not flash GApps. They are prebuilt)

Changelog:
*Downgraded the kernel
*Set screen density to 515
*Enabled GBoard rounded corners
*Updated to latest CN build fingerprint
*Removed FM Radio
*Official DerpFest build

Instructions:- See first post

Note:-
[MAGISK] Flash Magisk after first boot. Supported magisk Magisk v22.x
Issue with mic? everything I record is heard very low(srry for my english)
 

samfetish98

Senior Member
May 26, 2016
123
14
Xiaomi Mi 11
Hi, i'm on 06/11 build with magisk (busybox and hideprops modules), i noticed that fingerprint unlock animation doesn't work. Thanks for your amazing work with this rom
 

nate911

Member
Nov 21, 2010
23
1
@VortexHD - I noticed that you got Santander to work using Riru-momo, did you manage to get it to work with the Mi11 and the latest build of Derp?
I followed the instructions and it doesn't seem to work for me - Thanks for the great rom.
 
Apr 28, 2016
13
2
Xiaomi Mi 11
After few days of use, i just want to say thanks to dev and the team for this amazing rom, the phone is to much faster, the 120HZ are so smooth and the overall funcionality is amazing. Thanks!(y)
 
Nov 13, 2021
4
6
Hi, first timer here.

I successfully installed everything (including Magisk) and it all worked fine... for an hour or so.

Then I realised that I couldn't install Netflix and also couldn't use contactless payments since my bank app won't allow rooted devices. I then discovered that SafetyNet showed a failed certification for both basicIntegrity and ctsProfile.

After searching for a bit I found out that I could install SafetyNet Fix in order sort it out, still didn't work. Then I discovered that there was a Canary channel for Magisk and installed since it was supposed to fix the issue. I uninstalled the stable Magisk App and installed the Canary edition.

After installing said edition, both basicIntegrity and ctsProfile were enabled so I thought It was all solved.

Boy was I wrong... All my root privileges are gone, and also Magisk isn't installed at all. Only the app is installed (I reverted to the stable edition again, still no luck).

So I tried to flash Magisk again using the sideload method but it just won't fix the issue. The process itself doesn't show any errors, it just doesn't give root access to my device anymore after rebooting.

Any ideas on what can my mistake be?

EDIT: By the way, forgot to mention that everything else works flawlessly, huge thank you and congratulations to the developers for allowing me to escape MIUI ;)

EDIT 2: Forget it, nuking absolutely everything and starting from the bottom solved everything.
 
Last edited:
  • Like
Reactions: VortexHD

aygul12345

Senior Member
Jan 14, 2011
783
50
Hi,


Does this also works for the Mi 11 Pro?
Because its available for the Mi 11 (Non-Pro)

I have the Mi 11 Pro, so I could be testing.
 
Last edited:

NexusPenguin

Senior Member
Sep 21, 2013
1,206
703
Xiaomi Mi 11
Hi,

So far, I have been using MIUI with all my successive Xiaomi devices.
But on the last versions of MIUI, Xiaomi introduced a superbly stupid limitation in their quest to mimic Apple.
And that is : it is impossible to use gestures with a launcher other than their own MIUI Launcher (which I really do not like).
There was a workaround for that but that does not seem to work anymore.

So I went searching for a ROM not based on MIUI and found this.
After several tries, I was able to get this to boot (probably not working because I had not installed MIUI Stable).

I have been so used to MIUI lately that I did not remember what a custom ROM looks like.
Man, is that a change.

Of course I miss some of Xiaomi features like the themes or the ability to customize AOD to your liking.
But for the rest ? Nothing to regret...

There's one question i have though. It concerns the camera. I noticed in camera settings that resolution can be set to 27MPix max when the hardware is capable of 108MPix.
It's not something I will use on a daily basis (and even then not sure I'd notice the difference between 108 and 27) but would like to know if that is normal or if I did/understand something wrong.

Regards.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    BuIx4Um.jpg



    This is a small project based on AOSP. We try to be a platform for beginners and support the Custom ROM community with our own unique contributions as well. This ROM exists thanks to inspiration of AOSiP, Thank you! #StayDerped

    Code:
    /* Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    Features

    GApps included!

    - Signed with release keys like stock
    - Google network stack
    - Google PSU support
    - Google APN's and CarrierConfig
    - Accent color, font, icon shape, icon pack customizations from Bootleggers
    - Statusbar icons tuner
    - App lock
    - Face unlock
    - Expandable volume panel
    - Omni weather
    - Gvisual Mod
    - Advanced gesture navigation options
    - FOD icon picker and wallpaper based color option
    - FOD Animations
    - Custom logo customizations
    - Custom Carrier Label & Carrier Label Placement
    - AOD Schedule options
    - 3 finger swipe to screenshot
    - Cycle through ringer modes
    - Adaptive playback
    - Long press power button to toggle flashlight
    - Long press volume button to skip track
    - Advanced reboot options
    - Additional lockscreen sclocks
    - QS tile styles
    - Switch styles
    - Custom QS headers
    - Edge light options
    - Battery light toggle
    - Scrolling screenshot (Asus stitchimage)
    - Battery icon styles (circle/bar/hidden)
    - QS quick pulldown
    - Bunch of useful QS tiles in addition to AOSP ones:
    - AOD
    - Caffeine
    - Data Switch
    - Location modes
    - HeadsUp (peek notifications)
    - Kill app
    - Weather
    - USB tethering
    - Screenshot (partial/full)
    - Sound (ringer modes)
    - Sound search
    - Reboot (system/recovery)
    - Mono/Stereo
    - Notifications clear all button
    - OOS-inspired QS tiles layout
    - Data usage under QS
    - Small oreo-like data type icon
    - Traffic indicator for wifi and mobile data
    - OOS-inspired Network speed indicator
    - VoLTE/VoWiFi multi-sim icon
    - Lockscreen media art and blur level controls
    - Improved statusbar pulldown blur
    - Added blur to power menu
    - Double tap to sleep on statusbar, launcher, lockscreen
    - Finer control over font size
    - Mini panels for wifi, bluetooth, NFC
    - Per-app network restrictions
    - Allow hotspot/tethering to use VPN (toggleable)
    - Additional charging info on lockscreen
    - Statusbar bluetooth battery level
    - NFC tile for devices with nfc
    - Multi SIM ringtone setting
    - Screen recorder stop dot and low quality options
    - Bring back 2 button navigation from pie
    - Delete button for screenshots
    - Show 3 QS columns when media player is inactive
    - Faster fingerprint wakeup
    - Pixel offline charging animation (for supported devices)
    - Enabled iorap and zygote preforking (for faster app launch)
    - One click to add/remove QS tiles
    - Hacks to bypass safetynet and root detection
    - Few pixel features like assist disclosure, live captions, adaptive connectivity
    - Optimizations and fixes from AOSPA, ProtonAOSP & upstream AOSP master

    - CAF functionality improvements/enhancements:
    - Bluetooth A2DP hardware offload
    - Audio policy extensions
    - Camera extensions
    - Telephony framework
    - Individual sim toggle (for some dualsim devices)
    - WiFi display/miracast
    - Hardware accelerated screen recording
    - NQ NFC support (for nfc supported devices)
    - Power off alarm in inbuilt clock app
    - Touch response optimizations
    - Performance improvements & fixes throughout the system


    What's broken?
    You tell me!

    IYoyzLd.png


    ROM: https://sourceforge.net/projects/derpfest-mi-11/files/Venus/
    Lineage Recovery: https://drive.google.com/file/d/1txohdIU1jG7n-tuyqr9SMBc6bdjvuAKi/view?usp=sharing
    Magisk: https://github.com/topjohnwu/Magisk/releases


    INSTRUCTIONS
    Flash Lineage recovery using "fastboot flash boot_ab boot.img".
    Enter Lineage recovery using "fastboot reboot recovery".
    In Lineage recovery go to "Factory reset" then "Format data/factory reset" using volume and power butttons and format data.
    Navigate back to "Apply update" then "Apply from ADB" using volume and power butttons.
    Flash the rom using ADB: "adb sideload path/to/rom.zip".
    (optional) To flash magisk you first need to boot into derpfest, then reboot to recovery and using ADB on you pc type: "adb sideload path/to/magisk.zip".
    Reboot and voila!

    If you get "Unsuccessful boot read error at 47%", don't worry, YOUR ROM FLASHED JUST FINE.

    Upgrading to a Newer Build
    Reboot to fastboot and set the active boot slot to "A" using "fastboot --set-active=a"
    Boot into Lineage recovery using "fastboot reboot recovery"
    Navigate to "Apply update" then "Apply from ADB" using volume and power butttons.
    Flash the update using ADB: "adb sideload path/to/rom.zip".
    (optional) Flash magisk using ADB: "adb sideload path/to/magisk.zip".
    Reboot and voila!

    Follow us on Telegram


    Credit/Thanks:



    Google for Android and AOSP

    LineageOS

    AOSiP

    AICP

    ABC ROM

    AquariOS

    BootleggersROM

    PixelExperience

    OmniROM

    Cory Collins

    ---------

    Any others we may have forgotten to credit

    And last but not the least, all our testers, who have helped us to squash many bugs so that we can try to release builds that as are flawless as possible




    XDA:DevDB Information

    DerpFest, ROM for the Xiaomi Mi 11



    Contributors @NurKeinNeid

    ROM source: https://github.com/DerpFest-11/
    Device sources: SM8350-Common, Venus
    Kernel source: https://github.com/Demon000/kernel_xiaomi_sm8350



    ROM OS Version: 11

    ROM Kernel: Demon000's Kernel

    ROM Firmware Required: Stable MIUI

    Based On: AOSP



    Version Information

    Status: Beta



    Created 13/09/2021

    Last Updated 06/11/2021
    5
    Hey, so I'm loving DerpFest and there are practically zero bugs, but one big issue I found is that people have told me that they can hear themselves in regular calls, VoIP calls, and social media app (e.g. Telegram, WhatsApp, etc.) calls, especially on speaker mode (less noticeable on handset mode). I did some research and found out that this is a common issue with AOSP ROMs and Xiaomi dual mic phones, since the AOSP ROM does not correctly use the two mics for noise cancelling. Has anyone else experienced this on LOS, SSOS, DFOS, or any other AOSP ROMs on the Mi 11? I looked into editing /vendor/etc/sound_trigger_mixer_paths.xml as suggested in the Poco F1 echo fix XDA thread, but I don't think DEC7 and DEC8 are the correct dual mic IDs for this device. If any devs can figure this out, I'd be happy to buy you a 🍺 for your help in making AOSP truly perfect on this device with this one important fix.
    4
    Moderator Notice - Thread Cleaned

    Some posts were deleted and the thread has been cleaned. Everyone is requested not to indulge in off-topic chit-chat or make personal comments on other users. If you have an issue with the post, it's best to use the report feature and let the moderation team deal with the post instead.

    Thank you for your understanding,

    Funk Wizard
    Forum Moderator
    2
    I'm facing some issues with the Google Assistant, as it shows 'This feature is currently unavailable for this language" whenever I try to enable 'Hey Google and Voice match'.

    My current device language is English (UK) altough I'm facing the same issue with Spanish (Spain). Any ideas?

    Also, as other users have mentioned, I believe that the microphone volume is quite low (eg. Whatsapp voice notes)

    Everything else works pretty good. It's a daily for me.
    2
    Hi guys! Finally I've managed to flash DerpFestOS. I used TWRP to change the slot and flash the ROM. Thanks for all the advices and help.