[EOL][ROM][3&3T][AROMA] FreedomOS 3.3 [8.0][OOS][5.0.1][STABLE][SAFETYNET ✓]

Should i create a new post for the CE version ?


  • Total voters
    1,240
Search This thread

Jonog

Senior Member
Aug 4, 2014
62
3
Is it possible for me to jump from freedom OS 2.5 to this without messing everything up? Thanks
 

ElDonTheo

Member
Sep 16, 2016
44
12
Hello,
As every mirror link is down, and the files downloaded from GitHub seem too light (200Mo Vs 1.5 Go), is there any way to get FOS 2.12 and FOS 3.3 somewhere ?
Appart from that, is there any alternative which has an AppLocker, Scheduled on/off, Viper, AdAway and every basic function working (tethering...) ? I thought about The3OS for all that, provided that Havoc won't have AppLocker.

Thanks !
 

Hemantgits

Senior Member
Dec 31, 2013
100
27
Surat
OnePlus 3T
OnePlus 6
a very very thank you for the link mate. ... actually Freedom os was the Last good rom for our device all the others and the latest have this issue or thast issue and we who work from 10 to 9 cant afford to loose our time fiddling with one issue or another so want to give this old horse a one more try before moving on to another device.....
 

mnsiw

Senior Member
Oct 2, 2009
1,199
384
Redmi Note 10 Pro
a very very thank you for the link mate. ... actually Freedom os was the Last good rom for our device all the others and the latest have this issue or thast issue and we who work from 10 to 9 cant afford to loose our time fiddling with one issue or another so want to give this old horse a one more try before moving on to another device.....

Thanks for response. I'm on OOS 9.0.6, it is working perfect for me but I my usage is kind of basic, few calls, text, YouTube and some social apps. I tried LOS 14.1 by Sultan (now Denser) and amazed with it's smoothness and performance. I heard lot of good about about this ROM but never tried it, actually it is not in development anymore while LOS 14.1 still has latest security patches.
 
  • Like
Reactions: meetlicious

munichien

Member
Sep 6, 2010
5
0
Hello guys!

I have a strange problem using the latest version of FreedomOS. (It appeared using version 2.5 though)
Sometimes the phone loses the ability to play any media. Video and sound playback is not functioning in none of the apps.
Spotify shows, it's playing, the timer is ticking, but if i click pause, it goes back to start, not pauses. It works fine on PC.
Youtube says "There was a problem while playing" and giving me the Playback ID for each video.
Instangram and Facebook does not play any sort if video, but it looks like it's trying.
I also cannot make any calls either using Messenger, or the Phone Dialer itself.
Camera only works while using the stock Camera app what comes with this ROM. Any other app shows that it's already in use, and i have to close those apps.

Doesn't matter which profile i'm using, Ring, Do Not Disturb or Silent, the problem stays the same.
I thought that it will go away after installing the new version. It was fine for a day, after that it appeared again. I reinstalled it, maybe i missed some option in the Aroma Installer, but i didn't.
I downloaded the newest separate Firmware and Modem zip, flashed it, didn't help.

Sometimes rebooting the phone solves the issue, but in the 80% of tries it will not solve it.

Here's the list of installed apps:
  • 9GAG
  • AccuWeather
  • Amazon Shopping
  • Google Auth
  • BitTorrent Pro
  • Calculator
  • Google Calendar
  • CatLog
  • Camera
  • Chrome
  • Stock Clock
  • Contacts
  • Downloads
  • Google Drive
  • eBay
  • EX Kernel Manager
  • Facebook
  • Gallery
  • Gmail
  • Google Search
  • Instagram
  • Google Keep
  • Instagram Layout
  • Magisk Manager
  • Maps
  • Facebook Messenger
  • My O2
  • Netflix
  • PayPal
  • Phone
  • Google Photos
  • Play Store
  • Quik
  • Samsung Gear
  • Samsung Health
  • Settings
  • Shazam
  • SMS Backup & Restore
  • Snapseed
  • Solid Explorer
  • Spotify
  • SuperSU
  • Telekom
  • Terminal Emulator
  • Google Translate
  • TripAdvisor
  • TSB
  • Twitch
  • Voice Search
  • Google Wallpapers
  • Youtube

I downloaded CatLog to maybe figure something out by myself.
I see a few constantly repeating lines of
Android Runtime: Unable to create service se.dirac.acs.AudioControllerEliteException: se.dirac.controller.qem.ControllerEliteException: Failed to communicate with Qualcomm HAL
Then AudioDaemon shows this:
Opening sound card state: /proc/asound/card---/state
but it's failing, saying no such file or directory.
After that it sleeps for 100ms, then restarting the whole thing again.

Another interesting thing is:
AudioDaemon: No audio device events detected
AudioDaemon: Sound Card is empty!!!


Any thoughts?

Edit:
In the meantime, I installed crDroid ROM, LineageOS, and the Stock OOS as well, all of them has the same problem which makes me think that this is a hardware fault and not software related.
So i guess no other way than sending my phone to service for now.

Did you find a solution?
 

ab4nk

Senior Member
Jul 2, 2008
140
13
OnePlus 5
OnePlus 5T
Return from Pie custom rom

Hello Guys...
I came from pie custom rom - havoc rom, when i re flash the freedoom oos ver 2.6 (OP3), i got stuck on booting page.
Is there any step that i have to flash before downgrade from pie to nougat ?
Sorry for noob question :D

Rgds
 

Top Liked Posts

  • There are no posts matching your filters.
  • 459
    1498743705-op3-big-banner-nougat.png


    FreedomOS allows you to debloat your ROM smartly.
    Everything is customisable, you can install the most minimalistic rom, like a fully modded rom.
    So basically, it install the untouched stock rom and install and remove all the functionality you have selected in the aroma.

    Features :

    Install/Uninstall Google apps:

    - Android Pay
    - Calculator Google
    - Calendar Google
    - CallSync
    - Camera Google
    - Cloud Print
    - Contatcs Google
    - DialerFramework
    - Dialer Google
    - DMAgent
    - Google Drive
    - Exchange Google
    - FaceDetect
    - FaceUnlock
    - GCS
    - Gmail
    - GoogleTTS
    - Hangouts
    - Hotword
    - Keyboard Google
    - Messenger
    - Package Installer Google
    - Pixel Icons
    - Pixel Launcher
    - Photos
    - Play Games
    - Print Service Google
    - Search
    - Speech
    - Storage Manager Google
    - Tag Google
    - Talkback
    - Wallpapers
    - YouTube
    All the others apps have been removed

    Install/Uninstall system apps :

    - AntHal
    - Android Pay
    - Basic Dream
    - Bluetooth Midi Service
    - Bluetooth Test Mode
    - Desk Clock
    - Document (File Manager)
    - Download
    - EngineeringMode
    - EngSpecialTest
    - Facelock
    - Galaxy
    - Holospiral
    - Animated wallpaper
    - LogKitSdService
    - Music
    - Noise Feild
    - OemAutoTestServer
    - OEMLogKit
    - OnePlus Camera
    - OnePlus Gallery
    - OnePlus OTA
    - OnePlus Setup Wizard
    - Phase Beam
    - Protips
    - SensorTestTool
    - SwiftKey
    - Tags
    - WifiRfTestApk
    - Dive Icons
    - Rifon icons


    - Enforcing kernel (security first)
    - Permissive kernel if wanted
    - APT-X & APT-XHD support
    - SafetyNet pass
    - Magic 11.1 with Magisk Manager
    - SuperSU | systemless 2.79 STABLE
    - Xposed Installer Material | Flash the Xposed zip after the AROMA installation
    - Adaway
    - Android Debugging Bridge
    - Substratum Theme Engine Legacy
    - Google DNS
    - EmojiOne
    - MultiWindows
    - Patched Stock Kernel, disable force encryption and some tweaks.
    - ARISE Sound System with Enforcing support
    - Sony Music Player
    - Google Assistant
    - Wideband wifi support over 2.4GHz
    - Center Clock
    - No traffic indicator


    Instructions :
    You need an unlocked bootloader with latest official TWRP.

    - Make sure you are using the correct TWRP, read FAQ
    - Download and copy the zip file in your OP3
    - Reboot to TWRP
    - Make a nandroid backup (optionnal)
    - Clean flash Wipe data/system/dalvik/cache | Dirty Flash: Wipe System/Cache/Dalvik
    - Install > Select FreedomOS zip file
    - Enjoy aroma installer
    - Done



    download-button.png


    If you have ROM issues please post the issue along with a LOG in this thread or in GitLab issue tracker.
    Posts will be removed by moderators without warning if they do not belong or are not accompanied by a LOG

    FreedomOS Mirror 1 [FR] - Mirror 1
    @genesixx Mirror [FR/CA/SG]- Mirror 2
    @xByt3z Mirror [NL]- Mirror 3
    @casual_kikoo Mirror [NL]- Mirror 4 Down for the moment

    Make sure to be updated to the latest version of TWRP, link in the FAQ.
    Don't forget to put md5 file in the same directory of the the rom zip.

    Changelogs

    GitLab | Github (Mirror)

    Enjoy what I do? Want to show your appreciation? You can donate HERE.​

    Special thanks to :
    People who have donated to support ongoing development,
    to all contributors ,
    and of course all the beta testers.

    Credits :
    OnePlus for everything.
    @kickoff for the aroma theme,
    @Chainfire for SuperSU.
    @amarullz for aroma project and the themes!
    @topjohnwu for magisk
    @rovo89, @DVD android for Xposed Installer.
    @xpirt for the python script.
    @A.R.I.S.E. Sound Systems,
    @xpirt for the python script.
    The Open GApps Project,
    Maybe more people, tell me!


    XDA:DevDB Information
    FreedomOS 3.3 for OnePlus 3/3T, ROM for the OnePlus 3

    Contributors
    NevaX1, casual_kikoo
    Source Code: https://gitlab.com/Nevax/FreedomOS

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.x
    ROM Firmware Required: Included
    Based On: OxygenOS 5.0.1

    Version Information
    Status: Stable
    Current Stable Version: 3.3
    Stable Release Date: 2018-01-13

    Created 2017-04-09
    Last Updated 2018-03-22
    130
    F.A.Q

    How to pass SafetyNet?
    - Follow the aroma installer, after that make sure to enable "Magisk Hide" in Magisk settings.

    Magisk or SuperSU
    Both are good to go, but depends of your need.
    I have made a small comparaison, of course it does not contains all the criteria (different point of views are welcomed).
    SuperSU:
    A standard, compatible with almost all "rooted apps"
    Break SafetyNet
    Can increase battery drain

    Magisk :
    Include modules support (FOS include patched module for arise)
    100% Systemless, do not break safetynet

    Young project, some apps are not compatible

    Which recovery should i use?
    Use the latest official TWRP available here.

    Want to report an issue, a problem?
    Please report it HERE, it much more handy compared to the forum.
    Provide as much information as possible, the installation logs or logcat are important.
    You can also suggest your ideas :)

    What does mean CE?
    - CE stand for Community Edition, it's based on the beta branch of OnePlus, the non-CE builds are based on stable branch, and ready for daily use.

    I'm getting an signal 11 Error at the end of the aroma installer
    You have ticked to rebvoot your device at the end of the installer, and it just fail.
    This is not a problem, just reboot it into twrp.

    How to downgrade to non-CE?
    - All you have to do is to perform a clean flash that means (wipe: data, system, dalvik, cache).

    Can i dirty flash this rom ?
    - You can dirty flash if u're using my previous version, but if anything wrong, a clean flash before reporting is a must.

    I got a bootloop caused by a incompatible/bad layer.
    Boot into TWRP.
    Go to Mount.
    Select System.
    Return to Home.
    Go to Advanced.
    Go to file manager.
    Go to /system/vendor/overlay/ and remove the bad overlay apk.

    My installation is stuck at XX%.
    - Wait one or two minutes and touch two times at the bottom right of your screen, if you got nothing reflash the rom.

    I have unselected/selected a setting in the aroma and now i (don't) want it.
    - Reflash the rom

    Tips :
    For reducing the battery usage, i recommend to disable Viper4Android for the phone speaker for everyday usage.
    The economy will minimal but we don't need an audio treatment for a simple *ding* notification.
    68
    New update!


    Happy flashing ;)


    Code:
        REMOVE: Arise (until fixed with oreo builds)
        UPDATE: Google Apps for Oreo
        UPDATE: OxygenOS 5.0
        System:
            Update to Android O (8.0)
            Added Parallel Apps
            Added Picture in Picture
            Added Auto-fill
            Added Smart text selection
            New Quick Settings design
            Updated security patch to September
        Launcher:
            Added notification dots
            New app folder design
            Now able to upload photos directly to Shot on OnePlus
    63
    New update
    2.8
    Code:
    UPDATE: OxygenOS 4.1.3
        UPDATE: Increased system stability
        FIX: General bug fixes
        UPDATE: Magisk manager
        FIX: Comeback to old Google Assistant activation
        FIX: Missing WebViewGoogle when exclude is selected
        UPDATE: ARISE Deuteromony 3.31 SwanSong
        UPDATE: Sony Music Player (Cleaning app cache is recommanded)
        And much more, check Gitlab...

    NOTE: Unable to pass SetupWizard or Google Play are also fixed.
    63
    Hi guys,

    Actually, it's becoming more and more difficult to find free times to work on FreedomOS.

    During these few days, i was mainly busy with my studies and also a lot of new stuff has happened in my life, so I'm currently not working on this project as I would like.
    But you may ask, did you plan to stop working on FreeedomOS?
    Of course not! And I can say some improvements are already in active development for a few weeks.

    New update available!

    Happy flashing guys :)


    2.12
    Code:
    ADD: Lift up display
        ADD: Gaming Do Not Disturb
        ADD: Low priority notification
        ADD: Network speed in status bar
        ADD: Scheduled night mode
        ADD: OnePlus Slate font
        UPDATE: Redesigned Dash Charge animation
        UPDATE: System stability and battery improvements
        ADD: Shot on OnePlus wallpaper
        UPDATE: Redesigned calling UI
        ADD: Shot on OnePlus watermark
        UPDATE: Redesigned photo editor in Gallery
        ADD: Secure box