• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[EOL][ROM][7.1.2_r36][UNOFFICIAL]LineageOS 14.1 [08 Sep 2019]

Search This thread

peelie

Senior Member
Nov 8, 2010
126
38
Is very good to see a Nougat ROM active for this device -

Have looked around (probably missed) so will just ask -

Can anyone verify if VoLTE works on US GSM carriers using this ROM?

Sincere thanks in advance - have not bought device yet, first need to see if I can get VoLTE working before I go ebaying :cowboy:
VW
I believe you need to not only check if Android 7 Nougat allows VoLTE (apparently it does) but also if carrier has enabled it for Moto G4?
 
  • Like
Reactions: virginwidow

virginwidow

Senior Member
Mar 6, 2013
162
15
Knoxvegas TN
Moto X Pure
LG V20
Thank You for response

The carrier has it enabled here in US (all of them require it now)

I've not gotten my "Clark" device yet - it's unclear to me whether a 'gapps' has to be installed for the VoLTE drivers to work ... Or if 'gapps' required for the camera? Etc?
 

peelie

Senior Member
Nov 8, 2010
126
38
LineageOS 14.1 May 2021 security patches with microG & Fdroid & Aurora store & Bromite webview for Moto G4 Athene

///Attention I am only building this version from here on, if you have been using my previous ROMS you will need to do full wipe as the different versions of Fdroid will make that app unstable.
Apologies in advance if doing a full wipe will be painful! I myself only use this version and doing 3 versions (including the 15.1 Oreo) is a pain!

I will leave my previous ROMs up for a week.

There is all you need to reproduce what I do here https://nextcloud.englishup.me/sites/rombuilder/. Good luck!////

Download new ROM - https://sourceforge.net/projects/mo...CIAL-athene-mG-fD-Aurora-bromite.zip/download

Sources:
LineageOS/android_device_motorola_athene
LineageOS/android_kernel_motorola_msm8952
LineageOS/android_external_bson
LineageOS/android_external_stlport
LineageOS/android_packages_resources_devicesettings
TheMuppets/proprietary_vendor_motorola



thanks to @Eric_Lev for sources and @MSe1969 for advice and sources
 
Last edited:

Br0kenTree

New member
Jun 13, 2021
1
0
My WiFi doesn't work with any 14.1 ROM, and I really want to use Nougat

Even installed old builds, it doesn't work

Right now I have LOS 15.1 and WiFi works, but with 14.1, it doesn't connect to any WiFi, please help
 

Top Liked Posts

  • There are no posts matching your filters.
  • 147
    2okPze5.png


    Note: LineageOS 14.1 is no longer maintained. A final build was released on 8 Sep 2019, please read the post here. #2987


    LineageOS 14.1 is a free, community built, aftermarket firmware distribution of Android 7 (Nougat), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][UNOFFICIAL][athene][7.1.2] LineageOS 14.1, ROM for the Moto G4/Plus

    Contributors
    LineageOS Team of course!

    Team athene:
    rajatgupta1998
    Nikit
    lcrd512
    golden-guy
    Jleeblanch

    My paypal: https://www.paypal.me/rajatgupta1998
    Patreon: https://www.patreon.com/rajatgupta1998


    Our former developers:
    vache, rahulsnair, SileshNair, Shreps, regalstreak, ashwin007

    Other developers: Alberto97, squid2, flar2, oadam11 and all other contributors whom I might have missed.


    Source Code:
    LineageOS ROM Source

    Device specific sources:
    Device tree: https://github.com/rajatgupta1998/android_device_motorola_athene
    Kernel source: https://github.com/rajatgupta1998/android_kernel_motorola_msm8952
    Vendor blobs: https://github.com/rajatgupta1998/android_vendor_motorola_athene

    ROM OS Version: Android 7.1.2 Nougat

    Version Information
    Status:Stable
    59
    #ril is here. #lineage15.0 #Oreo
    Build coming soon..
    49
    We are happy to announce that we just got till bootanimation in Lineage-15.0 after a week effort from nothingness. We can hope a bootable build in near future. Stay safe... Peace out.
    Update : We have a home screen and reboots :p
    44
    And Volte works too. What more can you ask :p . I will stop teasing now. @Dreamstar will be posting beta build soon. And dont flood the thread with i am excited .. looking forward.. posts ;) Stay safe..
    43
    First LineageOS-15.0 ( Oreo ) build is up

    What's working
    • Audio
    • RIL (Dual-Sim, Calls, SMS, Data)
    • Volte
    • Fingerprint Sensor ( Enrolment issue )
    • Wifi
    • Bluetooth
    • Video Playback
    What's not working
    • Camera
    • Permissive SELinux
    • Lineage-15.0 is new so there will be Lineage specific bugs.
    Screenshots
    TcBLEnY.png
    6iy1l7M.png
    sYxtfJe.png
    jpYMb4i.png
    oKUsKYv.png
    f4YUD1G.png
    KAEg67k.png
    vvlRYpP.png


    Download Link Updated in OP
    Cheers