• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[EOL][SODP][ROM][AOSP][XZ2, XZ2C, XZ3] SonyAOSP 9.0.0_r46 [Stable]

Should I continue this project?

  • Yes, for the XZ2.

    Votes: 95 35.7%
  • Yes, for the XZ2C.

    Votes: 115 43.2%
  • Yes, for the XZ3.

    Votes: 78 29.3%
  • No.

    Votes: 2 0.8%

  • Total voters
    266
Search This thread

MartinX3

Recognized Contributor
Sep 14, 2014
5,852
2,912
Mars
martinx3.github.io
Booting up directly worked.
Trying to boot up twrp caused the problem again.
It appears that the problem is booting up in twrp on aosp.

Sent from my MI 5 using Tapatalk
Please follow the twrp instructions carefully.
Of works here.
A correctly installed twrp doesn't interfere with or overwrite anything of the stock firmware.
It lives in its own ramdisk as a independent operating system.
 

ASMstudent

Senior Member
Aug 28, 2015
330
87
Has anyone tried the xz2 sound system port on xda on this rom.
Does it work ? Does it improve speaker quality or remove the noise?
I would have loved to try, but I've been bricking- unbricking my phone for the past two days tens of times and I've had enough for a week.
Here is the link if someone have the time to give it a try


https://forum.xda-developers.com/cr...t-sony-xperia-xz2-sound-enhancements-t3772758

Sent from my Xperia XZ2 (AOSP) using Tapatalk
 

MartinX3

Recognized Contributor
Sep 14, 2014
5,852
2,912
Mars
martinx3.github.io
Has anyone tried the xz2 sound system port on xda on this rom.
Does it work ? Does it improve speaker quality or remove the noise?
I would have loved to try, but I've been bricking- unbricking my phone for the past two days tens of times and I've had enough for a week.
Here is the link if someone have the time to give it a try


https://forum.xda-developers.com/cr...t-sony-xperia-xz2-sound-enhancements-t3772758

Sent from my Xperia XZ2 (AOSP) using Tapatalk

What I can say is that further improvements are going into the 10.0 ROM with the 4.14 kernel which requires the new OEM drivers.
 

ASMstudent

Senior Member
Aug 28, 2015
330
87
Any chance of improving fingerprint latency and device wake up?
I find myself waking up the phone with power button almost 50% of the times for the fingerprint to work.

Sent from my Xperia XZ2 (AOSP) using Tapatalk
 

wee2000

Senior Member
Aug 30, 2008
149
6
i had successfully flash following the instructions, but when my device boots, it stucks on Sony logo. I'm using a H8216 with unlocked bootloader. I tried to revery to stock rom, flashed via flashtool successful, but still stucked at Sony logo. What shall i do now? IS it something to do with the unlocked bootloader? I did read a few pages, but didn't saw any posts similar to my issue..
 
  • Like
Reactions: MartinX3

MartinX3

Recognized Contributor
Sep 14, 2014
5,852
2,912
Mars
martinx3.github.io
i had successfully flash following the instructions, but when my device boots, it stucks on Sony logo. I'm using a H8216 with unlocked bootloader. I tried to revery to stock rom, flashed via flashtool successful, but still stucked at Sony logo. What shall i do now? IS it something to do with the unlocked bootloader? I did read a few pages, but didn't saw any posts similar to my issue..
You made a full wipe and used the newest 9.0 stock ROM before?
And you didn't do modifications?
 

wee2000

Senior Member
Aug 30, 2008
149
6
latest update - i used latest flashtool & my phone was alive again, ill post Q's on another thread regarding AOSP 10.
 
Last edited:

MartinX3

Recognized Contributor
Sep 14, 2014
5,852
2,912
Mars
martinx3.github.io
latest update - i used latest flashtool & my phone was alive again, with an unlocked bootloader. So for me to use a rom without sony apps, just plain google apps, how shall i proceed? do i go with aosp or sodp or lineage? I could go with any rom, as long as its plain & fast.



Sorry for so much noob questions, i had been separated from the world of custom rom for 2 years.. last time, we must use twrp to flash any custom roms, but it seems so different now.

---------- Post added at 10:27 AM ---------- Previous post was at 10:21 AM ----------

im running stock ROM 9.0(52.0.A.8.131) now. Bootloader unlocked.
Just follow the omnirom or sonyaosp instructions and directly after you flashed them , install twrp and the gapps (and maybe magisk for root).

And please update & boot the newest stock firmware first.
 

wee2000

Senior Member
Aug 30, 2008
149
6
Somehow, my device not see any playstore after installing microG. do i just install microG in twrp? is there any other files i missed out?
 
Last edited:

wee2000

Senior Member
Aug 30, 2008
149
6
i did these, now device booted to system, with twrp

1- flashed full stock ftf
2- then flashed aosp without flashing userdata.
3- I booted up aosp once then shut down the device
4- plug type c cable while holding volume up
5- in fastboot I typed fastboot reboot bootloader
6- after reboot I flashed userdata img I'm aosp
7- without rebooting the device, I typed fastboot boot twrp.img
8- after it booted up I flashed TWRP permanently through TWRP.
9- rebooted to recovery from TWRP and it booted up
10- reboot to system
 

dhacke

Senior Member
Nov 4, 2018
737
310
Somehow, my device not see any playstore after installing microG. do i just install microG in twrp? is there any other files i missed out?

Do you installed microG from the microG Website? Then It's logically that there is no Play Store.
microG itself is only a implementation of the play service which doesn't include the Play Store or any other Gapps.

Better install Nanodroid over twrp. It includes microG, Play Store and other goodies and you can highly customize what you want to install.
Plus it takes care about the correct rights because microG and Play Store need to be installed as system apps to work probably.
If you try Nanodroid make sure that you run the Nanodroid Patcher with a success notification in twrp before flash the Nanodroid package with microG etc.
The rom needs to have signature spoofing support for a working microG Installation.





Take a look into the linked Nanodroid thread:
https://forum.xda-developers.com/apps/magisk/module-nanomod-5-0-20170405-microg-t3584928
 
Last edited:

dhacke

Senior Member
Nov 4, 2018
737
310
Thx for the input, am looking at the page right away.
in the download website https://downloads.nanolx.org/NanoDroid/Stable/, i saw patcher & few nanodroid packages. some bigger filesize without microG in its filename.

Do i use NanoDroid-microG-22.5.1.20200102.zip or NanoDroid-22.5.1.20200102.zip?


Doesn't really matter. microG and Play Store is included in both packages. With the full package you don't need to download the patcher seperately; it is included there.


I always used the package with microG in the name because i only needed microG and not more. I'm not completly sure whether the Play Store will be installed by default. It could be that you need to edit the setup file.
 
Last edited:

wee2000

Senior Member
Aug 30, 2008
149
6
hi, device bricked again(keeps restart at Sony) after installing patcher for NanoDroid-22.5.1.20200102.zip. it has error message 'patcher only works for de-odexed'. Befor this, i did tried to install Gapps in TWRP, but after install, when i reboot into system, there were no gapps seen. I'm starting to flash back to stock & try all over again. Really don't know when is the right time to install those gapps/microG.
 

Top Liked Posts