• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[EOL][SODP][ROM][AOSP][XZ2, XZ2C, XZ3] SonyAOSP 9.0.0_r46 [Stable]

Should I continue this project?

  • Yes, for the XZ2.

    Votes: 95 35.7%
  • Yes, for the XZ2C.

    Votes: 115 43.2%
  • Yes, for the XZ3.

    Votes: 78 29.3%
  • No.

    Votes: 2 0.8%

  • Total voters
    266
Search This thread

wee2000

Senior Member
Aug 30, 2008
149
6
i tried to use google gapps instead, thinking it would be more compatible, but still cant install it. may i know what have i done wrong?

1- flashed full stock ftf
2- then flashed aosp without flashing userdata.
3- I booted up aosp once, then adb reboot bootloader
4- after reboot I flashed userdata img
5- without rebooting the device, I typed fastboot boot twrp.img
6- after it booted up I flashed TWRP permanently through TWRP.
7- rebooted to recovery from TWRP and it booted up
8-flashed open_gapps-arm64-9.0-nano-20200103, then i wipe dalvik
8- reboot to system

phone rebooted into system, but no gapps found
 

dhacke

Senior Member
Nov 4, 2018
737
310
hi, device bricked again(keeps restart at Sony) after installing patcher for NanoDroid-22.5.1.20200102.zip. it has error message 'patcher only works for de-odexed'.


You could try to deodex the rom manually using the tool TOAD.
Then the patcher could work.

Or you change to MartinX3's Omnirom. It has Signature Spoofing Support out of the box so you can install Nanodroid directly.
 
  • Like
Reactions: wee2000

wee2000

Senior Member
Aug 30, 2008
149
6
1-dloaded omnirom
2- then flashed omnirom without flashing userdata.
3- I booted up to system once then adb reboot bootloader
4- after reboot I flashed userdata.img
5- without rebooting the device, I typed fastboot boot twrp.img
6- after it booted up I flashed TWRP permanently through TWRP.
7- rebooted to recovery from TWRP and it booted up
8- flashed NanoDroid-microG-22.5.1.20200102, reboot to system
9- phone keeps rebooting into twrp

It wont boot to system.
 
Last edited:

dhacke

Senior Member
Nov 4, 2018
737
310
1-dloaded omnirom
2- then flashed omnirom without flashing userdata.
3- I booted up aosp once then adb reboot bootloader
4- after reboot I flashed userdata.img
5- without rebooting the device, I typed fastboot boot twrp.img
6- after it booted up I flashed TWRP permanently through TWRP.
7- rebooted to recovery from TWRP and it booted up
8- flashed NanoDroid-microG-22.5.1.20200102, reboot to system
9- phone keeps rebooting into twrp

It wont boot to system.

Did you flash OmniRom directly over SonyAOSP? If yes it could be the problem.
To be honest your flashing procedure regarding userdata.img sounds a little bit strange to me. Give me some time. I will test the newest Nanodroid on my XZ2 Dual and post the steps in the OmniROM thread when it works.
 

wee2000

Senior Member
Aug 30, 2008
149
6
i did flashed omnirom directly over AOSP, now i'm trying to start all over again from scratch, from stock rom.
 

Top Liked Posts