Eonon GA7151W Android - Wifi connected but no internet?

Search This thread

hogiela

Member
Nov 12, 2017
6
0
I have Eonon GA7151W headunit - Android 6.0

Suddenly my wifi says "Connected" but 'No Internet' .... it doesn't matter whether I tether to my phone or use my home wifi, for some reason the wifi says 'No internet'.

I tried a few things and ended up resorting to a factory reset ... unfortunately it's still not working after the factory reset! Exactly the same symptoms ...

Any ideas?
 

kshowtaco

New member
Apr 26, 2020
1
1
I have Eonon GA7151W headunit - Android 6.0

Suddenly my wifi says "Connected" but 'No Internet' .... it doesn't matter whether I tether to my phone or use my home wifi, for some reason the wifi says 'No internet'.

I tried a few things and ended up resorting to a factory reset ... unfortunately it's still not working after the factory reset! Exactly the same symptoms ...

Any ideas?

I have the same issue that has me stumped. any luck fixing it?
 
  • Like
Reactions: Pablosky.cl

Srmproductions

New member
Nov 28, 2010
2
1
Did anyone find a solution for this? Same thing is happening to me. I don't use the internet much on my head unit but I need it. It seems this is a widespread issue.
 

Dukenukemx

Senior Member
Jul 24, 2008
1,124
51
Jersey
I'm having the same problem with my radio and after Google'ing I found that you need to run this command to fix it. I don't have root on my radio yet, which is why I'm not sure if this will work.

Code:
su
settings put global captive_portal_server google.com

"Each time your Android device connects to a Wi-Fi network, the system performs a Captive Portal Check. Android aims to ensure that your device has not only received an IP address from the access point, but can actually reach targets on the Internet. This is necessary, for example, for the detection of portal pages of WLAN hotspots (e.g. in hotels). Android sends a request to the address "connectivitycheck.gstatic.com" for verification. If the request is successful or is answered with HTTP Response Code 204, the Internet is accessible. With this request, the system transmits information about the IP address of the connection, the time of Internet access and which browser is currently used to Google.If you block this request to Google via AFWall+ or anywhere else in your network, a small cross will appear on the Wi-Fi icon in the Android menu bar. Depending on the Android version, a message will also appear that no Internet is available. However, privacy-conscious users in particular do not want to send a "ping" to Google every time they go online. There is now a solution that works on rooted and non-rooted devices."
 

Dukenukemx

Senior Member
Jul 24, 2008
1,124
51
Jersey
Here's a method that may work without root. Only problem is it seems to be for German devices. Also my device is Android 6.

Android Nougat (7.x)

Connects the device to your computer via USB cable and activates ADB for the process. You then place the following commands via a terminal on the computer:

adb shell 'settings put global captive_portal_http_url "http://captiveportal.kuketz.de"'
adb shell 'settings put global captive_portal_https_url "https://captiveportal.kuketz.de"'

Android Oreo (8.x) | Pie (9.x)

Connects the device to your computer via USB cable and activates ADB for the process. You then place the following commands via a terminal on the computer:

adb shell 'settings put global captive_portal_http_url "http://captiveportal.kuketz.de"'
adb shell 'settings put global captive_portal_https_url "https://captiveportal.kuketz.de"'
adb shell 'settings put global captive_portal_fallback_url "http://captiveportal.kuketz.de"'
adb shell 'settings put global captive_portal_other_fallback_urls "http://captiveportal.kuketz.de"'

You can check whether the URLs have been adjusted as desired with the following command:

adb shell 'settings get global captive_portal_https_url'
 

Dukenukemx

Senior Member
Jul 24, 2008
1,124
51
Jersey
I think I've broken it down to one command that needs to be run at terminal or adb.
Code:
settings put global captive_portal_detection_enabled 0
Again, I don't have root yet on my device and spent the whole day trying to root it, but you guys can try it out for yourselves. You can use this command to see if you disabled it.
Code:
settings get global captive_portal_detection_enabled
 

Rpscavaleiro

New member
Mar 4, 2008
3
1
Don't know if all of you solved this issue or swapped unit... But the same happened to me this week after a crash that made me reboot the unit.
Since then, no internet at all, besides the wifi was running like supposed to.
Also tried the factory default, a pain for nothing.

This is how I fixed the issue:
Go to date time of the unit on settings, change it to manual, get it right and adjust the time fuse to the correct one for you, then, switch off then on the wifi and should be running like a charm.

I'm my case, the internet came back in most of apps, but in google store don't, needed to reboot the unit. (I have the by eonon and the code to my radio it's 126, so I can reboot it going to eonon settings)
 

Dukenukemx

Senior Member
Jul 24, 2008
1,124
51
Jersey
Don't know if all of you solved this issue or swapped unit... But the same happened to me this week after a crash that made me reboot the unit.
Since then, no internet at all, besides the wifi was running like supposed to.
Also tried the factory default, a pain for nothing.

This is how I fixed the issue:
Go to date time of the unit on settings, change it to manual, get it right and adjust the time fuse to the correct one for you, then, switch off then on the wifi and should be running like a charm.

I'm my case, the internet came back in most of apps, but in google store don't, needed to reboot the unit. (I have the by eonon and the code to my radio it's 126, so I can reboot it going to eonon settings)
I'm gonna try this. Would be silly that messing with the clock fixes it. I haven't been able to do anything about it since I need to root the stereo to run those commands.
 

Rpscavaleiro

New member
Mar 4, 2008
3
1
I truly rocomemd you to do it!
I won't lie that first I get it running, I came to this post and when I saw you guys answer, I was already thinking in take the stereo off, but my mazda 6 it's a pain to get it off, because I have to unscrew the dash.

After some dig, found that solution for issues with access with hotspots.

I also didn't believe that the proceed would work but... the important thing is that my Eonon came back to internet life! 👌

Let me know if also worked with you.
 
  • Like
Reactions: Dukenukemx

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I have Eonon GA7151W headunit - Android 6.0

    Suddenly my wifi says "Connected" but 'No Internet' .... it doesn't matter whether I tether to my phone or use my home wifi, for some reason the wifi says 'No internet'.

    I tried a few things and ended up resorting to a factory reset ... unfortunately it's still not working after the factory reset! Exactly the same symptoms ...

    Any ideas?

    I have the same issue that has me stumped. any luck fixing it?
    1
    I truly rocomemd you to do it!
    I won't lie that first I get it running, I came to this post and when I saw you guys answer, I was already thinking in take the stereo off, but my mazda 6 it's a pain to get it off, because I have to unscrew the dash.

    After some dig, found that solution for issues with access with hotspots.

    I also didn't believe that the proceed would work but... the important thing is that my Eonon came back to internet life! 👌

    Let me know if also worked with you.