• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Error "can't activate SIM" "uplink_sms_limitation"

Search This thread

skanskan

Senior Member
Oct 16, 2013
230
23
Hello.

I'm using MIUI 10 beta on my Xiaomi Mi8 phone.
And I'm getting this error message:
"find device can't activate SIM"
uplink_sms_limitation


When I tap on it I get this message:
"Can't activate SIM card"
uplink_sms_limitation

But strangely I can use my phone to make and receive calls.

What's the problem?
How can I solve it?
 
  • Like
Reactions: otura

otura

Senior Member
Nov 17, 2010
82
20
Exactly same situation here with my SIM2. I guess is something related to Mi Message app.

Is your SIM in roaming?

Mine is and my best bet is that the message is due to the system relying on some sort of free activation SMS which are not available on roaming.

My SIM1 is not on roaming and it works perfectly.

By the 22/SEP I will be traveling to my SIM1 country and will be able to confirm if that is the issue.

Enviado desde mi MI 8 mediante Tapatalk

---------- Post added at 03:19 PM ---------- Previous post was at 03:17 PM ----------

BTW same behaviour with any combination of MIUI version (9, 9.5,10), global or Chinese, beta, stable or xiaomi.eu that I've tried.

Enviado desde mi MI 8 mediante Tapatalk
 

skanskan

Senior Member
Oct 16, 2013
230
23
I've read I have to disable the "find my device service" and "Mi Cloud", maybe other Xiaomi services too. I'm just trying.
That can have some drawbacks though.
I'll flash Xiaomi.eu when I can unlock the bootloader. I hope it won't have this problems.
 

Agimax

Senior Member
Nov 17, 2009
1,211
1,252
Indianapolis
I have the same problem, mine is a Chinese version. I just long-hold the notification and choose to ignore it (it won't show again). I assume it's trying to activate it somewhere in the Chinese system.
 
  • Like
Reactions: IAm_Kill3r

JBB303

Member
Nov 4, 2018
7
28
Denver
I have the Redmi K20 Pro and was able to fix this error. Go to Settings >> SIM cards & mobile networks >> Data roaming and set Overseas data roaming to "Always" (don't worry, this will only be for a few minutes). Let the activation services run again (you may have to repeat the activation attempt a few times), and your device should be able to activate the SIM and verify the phone number. When it's completed, you can turn the Overseas data roaming back to "Never."
 

zemix

Senior Member
Nov 17, 2011
108
43
32
Kyiv
twitter.com
I have the Redmi K20 Pro and was able to fix this error. Go to Settings >> SIM cards & mobile networks >> Data roaming and set Overseas data roaming to "Always" (don't worry, this will only be for a few minutes). Let the activation services run again (you may have to repeat the activation attempt a few times), and your device should be able to activate the SIM and verify the phone number. When it's completed, you can turn the Overseas data roaming back to "Never."
man, you gennius!
I recently bought new phone Redmi 8 for my granny.
What I just have not tried it (language change, the exit from Mi account, restart, wait 10 minutes until the pass "activation" and so on...) - nothing helps! This evil notificatio has written off the money for a SMS - but the activation fails, you can imagine my despair hehe!?))

Then I googled this problem and accidentally find your comment - and it all solved instantly!I did steps as you wrote
Go to Settings >> SIM cards & mobile networks >> Data roaming and set Overseas data roaming to "Always"
...then reboot my phone - in the status bar once again see the activation request
bla bla bla ... Can't activate ...
REACH DOWNLINK SMS LIMITATION"

- click there and voila! Activation was instantly quick like a charm! Then - "Overseas data roaming" option back to "Never."

PS: for the statistics, I'm from Ukraine, Lifecell my operator - and your method can be confirmed as a universal and instant solution!
 
  • Like
Reactions: robertobribeiro

otura

Senior Member
Nov 17, 2010
82
20
Didn't work to me.

man, you gennius!
I recently bought new phone Redmi 8 for my granny.
What I just have not tried it (language change, the exit from Mi account, restart, wait 10 minutes until the pass "activation" and so on...) - nothing helps! This evil notificatio has written off the money for a SMS - but the activation fails, you can imagine my despair hehe!?))

Then I googled this problem and accidentally find your comment - and it all solved instantly!I did steps as you wrote

...then reboot my phone - in the status bar once again see the activation request
bla bla bla ... Can't activate ...
REACH DOWNLINK SMS LIMITATION"

- click there and voila! Activation was instantly quick like a charm! Then - "Overseas data roaming" option back to "Never."

PS: for the statistics, I'm from Ukraine, Lifecell my operator - and your method can be confirmed as a universal and instant solution!
 

Belbol

Senior Member
Oct 24, 2012
458
51
Mersin
I have the Redmi K20 Pro and was able to fix this error. Go to Settings >> SIM cards & mobile networks >> Data roaming and set Overseas data roaming to "Always" (don't worry, this will only be for a few minutes). Let the activation services run again (you may have to repeat the activation attempt a few times), and your device should be able to activate the SIM and verify the phone number. When it's completed, you can turn the Overseas data roaming back to "Never."

I tried your way but didn't solve my problem, so i tried something else and it worked! so i wanted to add it here so viewers can try it tho:

go to apps manager and search for the app that has Blue Mi Logo, it's called "Xiaomi Service" or something like that.

press on the app go to the app permissions

here i have enabled SMS, Contacts, Phone and Storage and they i tried to activate the SIM Card and it worked directly.
 
Last edited:
  • Like
Reactions: robertobribeiro

arana1

Senior Member
Oct 27, 2011
231
36
I have redmi 8a and no OVERSEAS option under roaming, just plain roaming->always,never and for exceptions only, if I set it to always, problem persists, tried giving full permissions to xiaomi sim activation service and it didn't work either, :S , I am starting to regret getting this phone , until I can root it :/
 
Last edited:

jaytheguru

Senior Member
Mar 18, 2007
230
2
Step 1: Go to settings, SIM card and mobile networks and make sure there are no spaces between your phone number. Sometimes when we copy paste a number it leaves spaces in between the numbers for example 07784 263465, make sure there is no spaces I.e. your number should be 07784263465 (P.S. I used a fake phone number to show as an example)
Step 2: enable the Data roaming service under settings to always. Settings, SIM cards and mobile networks, Data Roaming, Settings, Data Roaming to Always.
Step 3: Go to settings, Apps, Manage apps, search for and click Xiaomi SIM Activation service, click Clear cache then click App permissions, Enable all options. You can turn options off after the process is completed.
Step 4: restart your phone (you might want to do this although online I didn’t need to, I only clicked on the notification and it activated my second sim.) I didn’t have to go through this procedure for my first sim,it was activated straight away.
I also didn’t have to switch off my find my device option at first but reading here, I did switch it off and on again.

Hope this helps
Kind regards
Jay
 

sdstc

Senior Member
Jul 11, 2015
96
7
Denizli
hi there, i have changed my celluar service on sim card 2. error was;
"find device cant activate
reach downlink sms limitation"

mimessage was disabled on sim2 i have activated it, than fixed :)
 

Ggattonero

New member
Apr 6, 2020
2
0
hi there, i have changed my celluar service on sim card 2. error was;
"find device cant activate
reach downlink sms limitation"

mimessage was disabled on sim2 i have activated it, than fixed :)

Hey hi guys,

I tried anything you guys suggested but still cant make this thing working. After the upgrade ti android 10 mobile data arent working anymore. When i gave full permission to the Xiaomi service app the message REACH DOWNLINK SMS LIMITATION didnt appear anymore but now It says i dont have enough credit even though i have 15 €.

Do you have any other suggestions? Thank yoi very much
 

tsongming

Senior Member
Aug 19, 2016
3,346
3,411
51
Hey hi guys,

I tried anything you guys suggested but still cant make this thing working. After the upgrade ti android 10 mobile data arent working anymore. When i gave full permission to the Xiaomi service app the message REACH DOWNLINK SMS LIMITATION didnt appear anymore but now It says i dont have enough credit even though i have 15 €.

Do you have any other suggestions? Thank yoi very much


its possible that you carrier does not allow overseas texting? It could also be an issue with your APN, manually add it if you need to.
 

afbg

New member
Feb 27, 2013
3
0
Neu-Isenburg
I have the Redmi K20 Pro and was able to fix this error. Go to Settings >> SIM cards & mobile networks >> Data roaming and set Overseas data roaming to "Always" (don't worry, this will only be for a few minutes). Let the activation services run again (you may have to repeat the activation attempt a few times), and your device should be able to activate the SIM and verify the phone number. When it's completed, you can turn the Overseas data roaming back to "Never."
Great! IT works:good:
 

tsongming

Senior Member
Aug 19, 2016
3,346
3,411
51
Thanks for your help, i tried and call Vodafone customer service but still not working. How can i add the APN manually? I mean what should i write?

Thank you

Google the recommended APN settings for your carrier and make a note of them, I use the program by Google called Keep.

I google Vodafone and found this page

  1. Select Settings.
  2. Select SIM cards & mobile networks.
  3. Select Your carrier under Sim card settings
  4. Select Access Point Names.
  5. Select New APN
  6. Manually Add your carriers suggest APN settings.
  7. Click save
  8. Select newly created APN and test, You should be good to go.

Finally make sure that Data is enabled if testing Data.

I use Network Cell Info Lite - Mobile & WiFi Signal (Beta) for testing my network and optimizing my settings. get it here
 
  • Like
Reactions: robertobribeiro

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    I have the Redmi K20 Pro and was able to fix this error. Go to Settings >> SIM cards & mobile networks >> Data roaming and set Overseas data roaming to "Always" (don't worry, this will only be for a few minutes). Let the activation services run again (you may have to repeat the activation attempt a few times), and your device should be able to activate the SIM and verify the phone number. When it's completed, you can turn the Overseas data roaming back to "Never."
    2
    Step 1: Go to settings, SIM card and mobile networks and make sure there are no spaces between your phone number. Sometimes when we copy paste a number it leaves spaces in between the numbers for example 07784 263465, make sure there is no spaces I.e. your number should be 07784263465 (P.S. I used a fake phone number to show as an example)
    Step 2: enable the Data roaming service under settings to always. Settings, SIM cards and mobile networks, Data Roaming, Settings, Data Roaming to Always.
    Step 3: Go to settings, Apps, Manage apps, search for and click Xiaomi SIM Activation service, click Clear cache then click App permissions, Enable all options. You can turn options off after the process is completed.
    Step 4: restart your phone (you might want to do this although online I didn’t need to, I only clicked on the notification and it activated my second sim.) I didn’t have to go through this procedure for my first sim,it was activated straight away.
    I also didn’t have to switch off my find my device option at first but reading here, I did switch it off and on again.

    Hope this helps
    Kind regards
    Jay
    1
    Hello.

    I'm using MIUI 10 beta on my Xiaomi Mi8 phone.
    And I'm getting this error message:
    "find device can't activate SIM"
    uplink_sms_limitation


    When I tap on it I get this message:
    "Can't activate SIM card"
    uplink_sms_limitation

    But strangely I can use my phone to make and receive calls.

    What's the problem?
    How can I solve it?
    1
    I have the same problem, mine is a Chinese version. I just long-hold the notification and choose to ignore it (it won't show again). I assume it's trying to activate it somewhere in the Chinese system.
    1
    Thanks for your help, i tried and call Vodafone customer service but still not working. How can i add the APN manually? I mean what should i write?

    Thank you

    Google the recommended APN settings for your carrier and make a note of them, I use the program by Google called Keep.

    I google Vodafone and found this page

    1. Select Settings.
    2. Select SIM cards & mobile networks.
    3. Select Your carrier under Sim card settings
    4. Select Access Point Names.
    5. Select New APN
    6. Manually Add your carriers suggest APN settings.
    7. Click save
    8. Select newly created APN and test, You should be good to go.

    Finally make sure that Data is enabled if testing Data.

    I use Network Cell Info Lite - Mobile & WiFi Signal (Beta) for testing my network and optimizing my settings. get it here