[EXPERIMENTAL][OMS-Substratum][G2][7.0_r6][16.9.16]AOSP 7.0

xdahero1

Senior Member
May 18, 2016
412
1,809
0
yairworkshop.com


The Android Open Source Project Nougat
Brought to you by YairPatch

Code:
#include <std_disclaimer.h>

/*
 * Your warranty is now void.
 *
 * We're not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you.
 *
 */


What is AOSP?
AOSP is Android as Google publish without other modifications. More or less AOSP is the Nexus devices stock rom without gapps. Anyway to get a working system I' ve added some changes from CyanogenMod and Codeaurora.
Please do not ask for features to be added because we're not going to add more


NEW BUILD 16.9.16

First time or clean install:
  1. Download the ROM from the link above
  2. Download GApps package for Nougat 7.0
  3. Download ThemeReady GApps package for N arm
  4. Put the zip files on your SDCard
  5. Reboot in Recovery
  6. Wipe Data / Factory Reset
  7. Optional: convert to F2FS
  8. Select "Install zip from SDCard"
  9. Choose AOSP ROM zip file
  10. Choose GApps zip file
  11. Choose TBO GApps zip file (needed for complete theming of some Gapps with OMS overlays)
  12. Flash
  13. Reboot system

kernel sources - https://github.com/CyanogenMod/android_kernel_lge_msm8974/tree/cm-14.0
device tree - https://github.com/yairpatch/android_device_lge_g2-common
 
Last edited:

metteduch

Senior Member
Jun 7, 2012
480
397
0
Since most G2 users have the D802 variant I'll leave a clear warning: ONLY D800 BUILD AVAILABLE.

Scratch that, D802 is in testing mode.
 
Last edited:

xdahero1

Senior Member
May 18, 2016
412
1,809
0
yairworkshop.com
  • Like
Reactions: adydac

Pacer_456

Senior Member
Dec 7, 2015
414
736
0
London
Tried installing but got E:unknown command [log] in twrp and when I tried to flash Gapps it said that the rom was 4.4.4 and counldn’t install, and when trying to reboot after flashing the boot.img it said no os installed. Any ideas @xdahero1 ?
 

Pacer_456

Senior Member
Dec 7, 2015
414
736
0
London
For Gapps error, try to reboot to recovery and flash again. Had to do that on Nexus 4 after flashing 7.0.
That worked, thanks

ignore them and reboot
Thanks, done that and it booted. Only bugs I am having are the ones you listed and also a Google Play services force closing bug, tried with banks gapps and open gapps and got the same error. Luckily Android N comes with an option to silence those notifications so I can ignore them, google apps still work fine even though google play services force close. Apart from that it's great!
 

xdahero1

Senior Member
May 18, 2016
412
1,809
0
yairworkshop.com
That worked, thanks


Thanks, done that and it booted. Only bugs I am having are the ones you listed and also a Google Play services force closing bug, tried with banks gapps and open gapps and got the same error. Luckily Android N comes with an option to silence those notifications so I can ignore them, google apps still work fine even though google play services force close. Apart from that it's great!
go to apps/permission / give it permission
 
  • Like
Reactions: Pacer_456