• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Exposed framework

Search This thread

arthios

Senior Member
May 2, 2014
142
42
Sydney
Does anybody use an exposed framework on P7-L10?

I don't think it matters which variant of the P7 you have. I recently tried a custom ROM by Lishuo which is based on B124 for the L07. Even Xposed 2.5 wouldn't install. I have no problem with my current ROM although I can't upgrade Xposed beyond V2.5. I suspect the earlier builds of the P7 stock ROMs are compatible (up to a point) with Xposed, but the later builds are not.
 
  • Like
Reactions: kriticar

PrimuSSaintS

Senior Member
Jul 28, 2014
91
4
Bruxelles
Stock B126 with Exposed 2.6.1
But using only for XPrivacy.

The problem is not the version of Xposed, the thing is you could be using the latest 2.7 version but it doesn't work on our devices for any "theming" thing. I guess it would work for XPrivacy but not if you want to use, lets say, GravityBox to theme the navbar.
 

sarcastical

Member
Apr 21, 2014
26
5
Đija
I've had Xposed for some time, used it for Snapchat modules, and it worked fine. I installed GravityBox [KK] today and for some reason whenever I try to open it I get "GravityBox system framework not responding. Exiting."

Is it because I don't have theme engine disabled or is it something else?
 

PrimuSSaintS

Senior Member
Jul 28, 2014
91
4
Bruxelles
I've had Xposed for some time, used it for Snapchat modules, and it worked fine. I installed GravityBox [KK] today and for some reason whenever I try to open it I get "GravityBox system framework not responding. Exiting."

Is it because I don't have theme engine disabled or is it something else?

I had it when I was using Xposed 2.6 or higher or when I didn't reboot my phone after instaling it (which is dumb ... I just forgot xD)
I'm now on 2.5.1 and I didn't touch disable nor enabled theme engine, I left it as it was when I installed Xposed 2.5.1
 

Ziolek67

Senior Member
Sep 21, 2014
281
162
Moon
I just rooted my P7 and try instaling latest xposed. I have this error and framework is not instaling.

Should I install custom recovery too ?

Huawei Ascend P7-10 by Tapatalk2
 

Attachments

  • uploadfromtaptalk1413303766249.jpg
    uploadfromtaptalk1413303766249.jpg
    51.8 KB · Views: 151

PrimuSSaintS

Senior Member
Jul 28, 2014
91
4
Bruxelles
  • Like
Reactions: Ziolek67

Ziolek67

Senior Member
Sep 21, 2014
281
162
Moon
...be aware that by instaling the latest Xposed version you might not use all the tweaks availables :)
Hi,
Which version of Xposed do You recommend to reduce this limitations ?

EDIT:
I tested Xposed versions: 2.6 and 2.4.1 and 2.5

In ver. 2.6 You have to check on "Disable resources hook" option in settings. Another way Xposed don't start and inform about incompatibility with our devices . But with this option many module are blocking and dont work.
In ver. 2.4.1 and 2.5 There isn't this this restriction and Xposed starting normally and some module (blocked in ver 2.6) work properly but many also don't work.
In addition, this version changes the icons in the home screen theme. :thumbdown:

In any way on rom (B135) I can't use GravityBox module (irrelevant Xposed version). GravityBox interface don't even launch :(

And last problem. So, I didn't make backup set_immutable.list file :)o) . Somebody can help me and upload this file ?
 
Last edited:

PrimuSSaintS

Senior Member
Jul 28, 2014
91
4
Bruxelles
In any way on rom (B135) I can't use GravityBox module (irrelevant Xposed version). GravityBox interface don't even launch :(

And last problem. So, I didn't make backup set_immutable.list file :)o) . Somebody can help me and upload this file ?


I can only speak about the B121-126 which were the two version I used. On both, gravitybox was working perfectly with Xposed 2.5.1 (when I say perfectly, I mean about 85% of the tweaks were working)
 

Ziolek67

Senior Member
Sep 21, 2014
281
162
Moon
Hey, I still have a problem with GravityBox (KK).

I am trying to use this module in the second ROM (B135 and now B136) but always have the same issue when trying to launch (see screenshot).

Any suggestions ? Did someone similar problem ?

Xposed ver 2.5.1

50dc28cffb71762b81ce78e42c57326c.jpg


Sent from my HUAWEI P7-L10
 
Last edited:

Top Liked Posts