Question F721BXXU1AVIF Google Pay: Your phone isn't certified or doesn't meet security requirements

Search This thread

ChoSmile

Senior Member
Feb 9, 2011
110
89
Sofia
Do not update to F721BXXU1AVIF fw
Google Pay stops working. "Your phone isn't certified or doesn't meet security requirements"
Waiting for new firmware.
 

ChoSmile

Senior Member
Feb 9, 2011
110
89
Sofia
VIF is in F721B International model, at the moment only for INS CSC.
VIA on your model F721U1 - US Unlocked model.
 

RikoF1

Member
Feb 26, 2010
20
4
I don't think it has nothing to do with the new firmware update. It has to do with Google Pay last update. I had this problem two weeks ago, but was fixed quickly in a later update See if there is an update to your Google Wallet app.