failed to mount /data /cache bootloop huawei

Search This thread


New member
Feb 10, 2019
heyo, i'm new here, i don't even know if i'm in the right place but welp..
the thing is that i need help

i have a huawei p6 ascend, the screen was failing and one day it just died and revived few days ago
but it's a bootloop, so i was going to factory reset and then boom, failed to mount /cache /data (invalid argument), so wipe data and cache show a big FAIL, and can't install a rom, still fails

i know this problem is common and probably here in the forum but i really need help, things that i tried didn't work

i tried some things, like adb to try to install TWRP (it seems that it could help) but usb debugging is disabled so adb won't detect my device, tried to install rom through "dload" pressing volume + and volume - but nothing, it takes me to the recovery menu soo... :/ and then i tried the huawei miracle box, but ehm, my main pc detected virus and then i used a "disposable" pc but it didn't open

any suggestions? thanks