[FAQ] HBOOT 0.83 / 0.92 / SLCD - rooting and recovery

Search This thread

teppic74

Retired Recognized Developer
Aug 5, 2010
1,148
240
London
Note: This is an old thread and the information in here may not be up to date.

This thread is intended mainly for people who have phones with SLCD displays. Please take a minute to read it before attempting to run any updates, downgrades, or applying any RUUs.

There have been lots of posts and confusion about HBOOT 0.83, 0.92 and SLCD over the last few weeks. These newer versions of the bootloader are installed by certain official updates, and come pre-installed on most new phones. To get straight to the point: HBOOT 0.83 is not a problem. Quite a few people have ended up breaking their displays by trying to downgrade, when it isn't necessary.

Q. I applied an RUU/downgraded to HBOOT 0.80 and now my screen doesn't work.
A. You can recover by upgrading to stock froyo. Just insert your goldcard and run this generic RUU: http://shipped-roms.com/shipped/Bra...3.00.32U_5.09.00.20_release_140022_signed.exe

Q. Which RUUs are safe to use with an SLCD screen?
A. All froyo RUUs are safe (release beginning 2.x). Otherwise do not attempt to use any other RUU that isn't listed in this post.

Q. How do I upgrade to stock unbranded froyo (without root)?
A. Use the RUU for froyo in question 1.

Q. I have upgraded to froyo, but want to downgrade/root.
A. Don't try using old methods as they will break SLCD screens. You can use a tool I have developed. Read the thread here: http://forum.xda-developers.com/showthread.php?t=768256

Q. How do I know if my screen is SLCD or AMOLED?
A. A black background in low light, at certain angles, will have a slight grey sheen to it if your screen is SLCD. On an AMOLED screen it will remain the same black. If you got your phone before July 2010 it is AMOLED.

Q. Does HBOOT 0.83 mean I have an SLCD screen?
A. No.

Q. Can I root my phone on HBOOT 0.83 and use custom recovery?
A. Yes! Use unrevoked3. http://unrevoked.com/recovery/

Q. My screen goes blank when I use custom recovery with unrevoked3.
A. You are using an old version of unrevoked3. Please try again with the latest version.

Q. Can I use AmonRA custom recovery instead?
A. Yes, it has now been updated to support SLCD. Install via unrevoked3 with this image: http://amonra-mod.googlecode.com/files/recovery-RA-desire-v1.7.0.1-R5.1.img

Q. What is the difference between HBOOT 0.83 and 0.92?
A. 0.92 is installed currently only if you apply the official froyo update or if you buy an unbranded phone with froyo. You cannot directly root running froyo yet, but this will soon be available. In the meantime you must downgrade to Android 2.1.

Q. How do I downgrade to HBOOT 0.80 from 0.83?
A. Don't - there is absolutely no reason to. If you want to root or use a custom ROM or debrand you should not try to downgrade.

Q. Can I debrand my phone with HBOOT 0.83?
A. Yes. What's important is your software release, not your bootloader version. If your software version is 1.21.405.2 or lower (for example, branded O2 phones), you can simply use this generic RUU with a goldcard to debrand and install stock 1.21.405.2. You can then root or upgrade to froyo if you wish to. This RUU will also flash your HBOOT to 0.83. http://shipped-roms.com/shipped/Bra...1.00.32U_4.08.00.09_release_137222_signed.exe

Q. My software version is higher than 1.21.405.2 (e.g. I applied the Vodafone branding update). Can I debrand?
A. If you want Android 2.1 you need to use the downgrade tool. If you want froyo, just apply the froyo RUU as described in the first question.

Q. I have an SLCD screen. Can I run custom ROMs?
A. The latest ones will work. The pre-rooted version of official froyo works fine including all custom ROMs based on it (kernel 2.6.32.15).

Q. Can I rebrand my rooted/debranded SLCD phone?
A. You will need a branded froyo RUU. Currently available: O2 2.14.207.1
 
Last edited:

bloodmeg

New member
Aug 8, 2010
4
0
Actually, I have just managed to downgrade and debrand my SLED Desire from Vodafone's hboot 0.83 & 1.24 firmware to HTC stock 0.80 and 1.21.405.2 (without wrecking my screen in the process). I'll post a detailed description after I'm done doing the victory dance.
 

bloodmeg

New member
Aug 8, 2010
4
0
Ah, you're right, I got a bit carried away there. I did not downgrade the HBOOT, just the firmware to 1.21 (with 1.21.405.2_T2_Radio_32.41.00.32U_4.08.00.09 which was reported to work with SLCD).

Thanks for correcting me.
 

teppic74

Retired Recognized Developer
Aug 5, 2010
1,148
240
London
The RUU flash process usually checks the installed software version and refuses to work if it's higher than what you're trying to install. This is why the froyo downgrade reports itself with a fake version.

edit: Although thinking about it, it would be possible to root the phone, put in a fake version into the misc partition (e.g. 1.21.405.2), and then that should trick the RUU checker into thinking you have that version installed.
 
Last edited:

brickinthewall

New member
Nov 20, 2008
3
0
Thank you

Thanks. Finally got my phone debranded. It was bought 2 days ago, branded to O2 Ireland. Don`t have it rooted, but now I'm downloading froyo on my phone. Don't have to wait for the O2 to release it.
 

teppic74

Retired Recognized Developer
Aug 5, 2010
1,148
240
London
I've realised to downgrade from Vodafone branding (or any software version higher than 1.21.xx) you just need to run the update.zip fix rather than mess around with the misc partition yourself. It sets your software version to 1.15.405.3, so any RUU with later software will work. Obviously with an SLCD screen you still have to flash the correct RUU.
 

debully

Senior Member
Dec 8, 2005
583
36
Worcester
This is a good informative FAQ and I wish I had found it last week before OTA'ing my SLCD. This IMO should be sticky, have an additional question for determining AMOLED or SLCD, have a question for determining HBOOT and be renamed slightly so as not to alienate 0.92 HBOOT users.

Of course, you're welcome to just ignore me, whadda I know?

Many thanks for your work,

debully.
 

teppic74

Retired Recognized Developer
Aug 5, 2010
1,148
240
London
I've added a couple of bits. The thing about HBOOT 0.92 is that you only get it at the moment if you upgrade to froyo yourself - I don't think phones are being shipped with froyo yet. As for being sticky, I don't know who decides those things.
 

zebidee

Member
Oct 30, 2008
16
0
Hello Teppic


Thanks for the write up in post 1, Im thinking of unrooting my desire and downloading OTA Froyo, can you give me a link to a "generic RUU" in order to do this.

Many Thanks
 

teppic74

Retired Recognized Developer
Aug 5, 2010
1,148
240
London
As it states:

Q. Which RUUs are safe to use with an SLCD screen?
A. The two mentioned here. All other currently available RUUs will stop the screen from working.
 

tncitu

Member
Aug 5, 2010
23
0
my software number is

1.30.415.3

and Hboot is

0.83....

i rooted my phone (i see Super Permission app. on the menu) when i want to recovery update.zip, i get status 7 error?

what can i do? can anybody help?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Note: This is an old thread and the information in here may not be up to date.

    This thread is intended mainly for people who have phones with SLCD displays. Please take a minute to read it before attempting to run any updates, downgrades, or applying any RUUs.

    There have been lots of posts and confusion about HBOOT 0.83, 0.92 and SLCD over the last few weeks. These newer versions of the bootloader are installed by certain official updates, and come pre-installed on most new phones. To get straight to the point: HBOOT 0.83 is not a problem. Quite a few people have ended up breaking their displays by trying to downgrade, when it isn't necessary.

    Q. I applied an RUU/downgraded to HBOOT 0.80 and now my screen doesn't work.
    A. You can recover by upgrading to stock froyo. Just insert your goldcard and run this generic RUU: http://shipped-roms.com/shipped/Bra...3.00.32U_5.09.00.20_release_140022_signed.exe

    Q. Which RUUs are safe to use with an SLCD screen?
    A. All froyo RUUs are safe (release beginning 2.x). Otherwise do not attempt to use any other RUU that isn't listed in this post.

    Q. How do I upgrade to stock unbranded froyo (without root)?
    A. Use the RUU for froyo in question 1.

    Q. I have upgraded to froyo, but want to downgrade/root.
    A. Don't try using old methods as they will break SLCD screens. You can use a tool I have developed. Read the thread here: http://forum.xda-developers.com/showthread.php?t=768256

    Q. How do I know if my screen is SLCD or AMOLED?
    A. A black background in low light, at certain angles, will have a slight grey sheen to it if your screen is SLCD. On an AMOLED screen it will remain the same black. If you got your phone before July 2010 it is AMOLED.

    Q. Does HBOOT 0.83 mean I have an SLCD screen?
    A. No.

    Q. Can I root my phone on HBOOT 0.83 and use custom recovery?
    A. Yes! Use unrevoked3. http://unrevoked.com/recovery/

    Q. My screen goes blank when I use custom recovery with unrevoked3.
    A. You are using an old version of unrevoked3. Please try again with the latest version.

    Q. Can I use AmonRA custom recovery instead?
    A. Yes, it has now been updated to support SLCD. Install via unrevoked3 with this image: http://amonra-mod.googlecode.com/files/recovery-RA-desire-v1.7.0.1-R5.1.img

    Q. What is the difference between HBOOT 0.83 and 0.92?
    A. 0.92 is installed currently only if you apply the official froyo update or if you buy an unbranded phone with froyo. You cannot directly root running froyo yet, but this will soon be available. In the meantime you must downgrade to Android 2.1.

    Q. How do I downgrade to HBOOT 0.80 from 0.83?
    A. Don't - there is absolutely no reason to. If you want to root or use a custom ROM or debrand you should not try to downgrade.

    Q. Can I debrand my phone with HBOOT 0.83?
    A. Yes. What's important is your software release, not your bootloader version. If your software version is 1.21.405.2 or lower (for example, branded O2 phones), you can simply use this generic RUU with a goldcard to debrand and install stock 1.21.405.2. You can then root or upgrade to froyo if you wish to. This RUU will also flash your HBOOT to 0.83. http://shipped-roms.com/shipped/Bra...1.00.32U_4.08.00.09_release_137222_signed.exe

    Q. My software version is higher than 1.21.405.2 (e.g. I applied the Vodafone branding update). Can I debrand?
    A. If you want Android 2.1 you need to use the downgrade tool. If you want froyo, just apply the froyo RUU as described in the first question.

    Q. I have an SLCD screen. Can I run custom ROMs?
    A. The latest ones will work. The pre-rooted version of official froyo works fine including all custom ROMs based on it (kernel 2.6.32.15).

    Q. Can I rebrand my rooted/debranded SLCD phone?
    A. You will need a branded froyo RUU. Currently available: O2 2.14.207.1
    1
    That RUU is for o2 UK customers to rebrand their device, no gold card needed as it's the original CID of the phone. If it doesn't work you'll first need to downgrade (using a gold card) and then flash the o2 RUU