[[FAQ][HELP THREAD][GUIDES LIST] Ask Any Question for S6

Search This thread

katiebrayspop

Member
Sep 2, 2018
5
0
Gg

---------- Post added at 09:08 AM ---------- Previous post was at 08:58 AM ----------

Hello,

Apologies for the late reply, have had a busy week irl. Was hoping to do this myself but as there is very little information I can find on my own I have been considering ponying up the cash if someone is able to do this unlock for me, if not just for the sake of upgrading from this cheapo Alcatel thing that can hardly run its own browser without crashing. If you are able to recommend someone reputable and cheap that would be excellent and I'd really appreciate it. Thanks for taking the time to reply.

What country are you in and what service is it again? Also, have you tried calling the carrier and just TRYING to get it unlocked, because there is there possibility they will do it and do it for free. It's definitely worth a shot, the worst they can do is say no right?
 
Last edited:

ozroot

Member
Dec 20, 2018
16
1
Port Macquarie NSW
Totally noob question regarding stock firmwares for S6 SM-G920I (Australian version).

Should I only use firmwares downloaded from SamMobile? Is this the legit place to get them?

When I go there, there are a bunch of Australian options for firmware. Should I just use the XSA version? Is that the unlocked one?

I've currently got a custom rom installed, but am thinking of putting this back to stock and selling it. I don't know what the previous stock rom version was, but I bought the phone outright with no plan attached, so it should be unlocked.

I've got Odin and am sure I can manage flashing the rom (custom was installed by someone else). Just want to make sure I use the right one.

Please advise, it's getting confusing. And thanks for any help in advance.
 

zGalaxify

New member
Dec 22, 2018
1
0
This might be a noobish question

I have a g920f but can't turn on oem unlock. I have developer options but it's not appearing. The phone has been factory reset once
 

modernRecluse

New member
Jan 16, 2019
1
0
Should I Be Concerned?

SM-G920V
Everything is completely stock, not rooted.

I was browsing Reddit in the app, rebooted phone because of wi-fi network issues.
Phone got extremely hot, made a random hissing noise, battery life dropped from 60%ish to about 4%, and then shut off. Plugging it in displays the typical charging screen, but when I turn it on, it'll bootloop a random amount of times before loading into Android.
 

AHM-ED

New member
Jan 4, 2015
1
0
Firmware confusion

Hey I just bought a second hand galaxy s6
The PDA & CSC says it's a G920F model but baseband & bootloader says it's a G920P model
Right now it's running stock modified kernel by Aurora rom (android 6)
I want to update it to android 7.0 but I'm confused should I flash G920f or G920p firmware using odin. Plis help me in this.
And phone is rooted
 

trngw

Member
Oct 3, 2015
5
0
Hi

Thank you for this thread!

Here's my problem description:

My S6, SM-G920F, was working. It was deliberately turned off and put aside. A few fays later it was turned on again, but did not seem to turn on, nothing happened, no display, no LEDs, no buzzer.

The phone is/was in "original" state, no rooting, only apps from app-store installed.

I tried all forms of reset-startup etc pressing various buttons simultaneously for long times. No difference.

I have opened it up and replaced the battery for a new one. No difference.

I did some measurements on the power electronics and also had a look with an IR-camera to look for hot components/shortages. Everything seems ok, VCC is there and no hot components found.

When the battery is attached, the phone is off. When the power button is depressed, the phone does turn on in some aspect because I noticed that the CPU gets warm. In a couple of minutes it reached about 50C. This seems a bit high for just turning the phone on, but still within "normal" operating temperature for the processor under some load.

I tried connecting the phone to a PC via USB, but the PC does not detect the phone at all.

I have tried with and without SIM-card. No Difference.

So, I wonder.

Is the CPU getting to 50C in a couple of minutes normal, or an indication the CPU is burned/shortened?
Any ideas where I can find information to help me in my troubleshooting?
Is there anywhere I can find schematics and PCB layout?

Thank you,

Thomas Nilsson, Gothenburg, Sweden
 

viva-yo

Senior Member
Aug 20, 2010
65
2
Hi
Can I flash ROMs of the " GALAXY S6 ORIGINAL ANDROID DEVELOPMENT" forum in my G920F?
Thx
 
Apr 10, 2019
3
3
Android Version: 7.0 / SDK 24 (Nougat)
No Root
Firmware Status: Official
Latest Firmware: Yes
Firmware Build: G920IDVU4FRD3 (was an Optus phone in Australia but I don't care for calling people the phone has no sim I just use it for games idk if that helps my problem)

Please help sir or ad some clarification to what I need to do to downgrade,

I've got a SM-G920I trying to downgrade to Marshmellow 6.0.1 but preferably Lollipop 5.1.1 or 5.0.2 I don't care, which the phone originally came out with. I've downloaded multiple Marshmellow 6.0.1 Firmware files and all fail.I've also downloaded multiple Lollipop Firmware files from 5.0.2 to 5.1.1 (only those two versions for Lollipop). Once I put my phone into Odin mode and open up Odin, put all the files in their correct places and press start, Odin then says this:

<ID:0/005> Odin engine v(ID:3.1203)..
<ID:0/005> File analysis..
<ID:0/005> SetupConnection..
<ID:0/005> Initialzation..
<ID:0/005> Set PIT file..
<ID:0/005> DO NOT TURN OFF TARGET!!
<ID:0/005> Get PIT for mapping..
<ID:0/005> Firmware update start..
<ID:0/005> SingleDownload.
<ID:0/005> sboot.bin
<ID:0/005> FAIL!
<ID:0/005>
<ID:0/005> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
A big red label then says "SW REV. CHECK FAIL. DEVICE: 4. BINARY: 3." on my screen

How can I downgrade? I'm on the LATEST firmware for this phone. This Firmware is **** I just want it gone, please. I've also tried flashing an original ROM with TWRP multiple times, wiped my phone, tried again and still fails just because it hangs on the Samsung logo for multiple hours. I've been at it for 2 days currently and can't find a solution.
 
  • Like
Reactions: [email protected]

HappyMr

New member
Aug 22, 2015
2
1
Galaxy S6 system-ui failure: how to flash without losing data

Hi,

Device: Galaxy S6 (don't know the code)
ROM name: don't know
ROM version and base: don't know
Build number: don't know
kernel version and its settings: don't know
Not Rooted

What is wrong:
- When starting the phone I get the "system ui has stopped working" error. Can't see any menu's, I just have a black screen with this message appearing every time.

What I want:
- To retrieve photo's and videos of which I have no backup

What I tried (but which failed):
- Wipe cache
- Start in safe mode

Possible solution:
- Flash with Odin, BUT, how do I do this without knowing what the latest android version was that was installed on the phone and is there a step-by-step guide somewhere (couldn't find it) explaining how to use Odin for the galaxy S6 when you DO NOT want to delete user data?
 
  • Like
Reactions: [email protected]
Jul 23, 2018
5
0
Hello my name is Jean and I have a Galaxy g920a AT&T phone looking for cf-auto-root to root my AT&T phone or is there anyway I can change firmware to achieve this. Also I have downloaded the S8 port firmware will this work on my Galaxy S6 AT&T phone
 

unikum

Senior Member
Apr 27, 2010
186
21
9 years old daughter clicked on an ad in a game and installed super applock. Now everything is locked even the settings. How do i reset the whole phone?
 

dl021994

New member
Jul 4, 2019
1
0
Can anyone please help me I have a Samsung Galaxy S6 I am in a security pass level from June 1st 2017 I have a device from TracFone the bootloader supposedly is unlocked I have SuperSU on my device but it is not in the binary which I cannot figure out how to do I have been all through the terminal commands and nothing seems to work to game Su access and I will post pictures of my devices information I do not have a computer I know that sucks but please can anyone help me can I remove the SuperSU or TWRP into a certain file that will make it work or do I have to flash is there no way to install from internal SD card


ro.product.model=SM-S907VL
ro.product.brand=samsung
ro.product.name=zerofltetfnmmn
ro.product.device=zerofitetfnvzw
ro.product.board=universal7420
ro.product.cpu.abi=arm64-v8Ba
ro.product.cpu.abilist=arm64-v8a,armeabi
v7a,armeabi
ro.product.cpu.abilist32=armeabi-v7a,armeabi
ro.product.cpu.abilist64=arm64-v8a
ro.build.id=MMB29K
ro.build.display.id=MMB29K.S907VLUDU2AQG3
ro.build.version.sdk=23
ro.build.version.release=6.0.1
ro.product.locale=en-US
 

NKBghost

New member
Sep 17, 2019
1
0
SM-G920P
Android Version 6.0.1
Secuirty Patch dated December 1, 2016
Software Version G920PVPU4CPL3
Baseband Version G920PVPU4CPL3
Kernel 3.10.61-9935814
[email protected] #1
Mon Dec 12 2016
Knox 2.6

Originally a Sprint phone. Attempting to use on Verizon Network. Phone is unlocked. Switched SIMs out and I am constantly in roaming and cannot receive MMS.
Can I root this phone or flash custom firmware or Verizon firmware to get it to work correctly? Will I need to use CDMA workshop? Never installed custom
firmware or rooted phone. Thanks for any help
 

eg789123

Senior Member
Dec 29, 2014
180
14
JHB
Samsung Galaxy S4 Mini
LG G3
Device: SM-G920F
ROM name: Back to stock, trying G920FXXS6ETJ1_G920FOJV6ESB1
ROM version and base: Back to stock Samsung firmware
Build number: going back to stock standard

flashing phone with odin 3.14, succeeds, but stays on samsung logo and pulsing cyan/blue light and goes nowhere,
can get back into download mode but not sure what to do from here on out,
had it previously with TWRP and Rooting with pixel experience latest for the s6,

just loaded odin with AP and the latest firmware from sammobile, but just hangs going nowhere,
 

zzamankhasru32

New member
Apr 1, 2021
3
0
Hi,
Recently I have upgraded my S6 from android 6 to 7 and after the flashing was complete, I got an error message with DRK. So I looked into Youtube for some solutions and at last I could fix that with flashing a Root file (https://shell.boxwares.com/Download.aspx?L=5772). It worked but ran into this SIM Card problem. It cannot detect the SIM and always says EMERGENCY CALLS ONLY. I did no back up for EFS. but my phone shows the IMIE and dialing *#0011# in the first steak IMIE says NG. Baseband is G920FXXU6ERF6 (Current). Before I was flashing the device the binary version was 5. So I tried binary 5 but did not work. So, I had to Flash binary 6. I have tried Android 6 with binary 6 by Odin. But couldn't complete. It fails.
What would be the solution for this? Please Help....
 

sd_dracula

Senior Member
Feb 8, 2013
230
3
I have a plain Galaxy S6 (not edge) with the basic Samsung ROM on android 7.0 and I am looking for the lightest ROM out there that maximizes the battery.
I want to be using the phone as a 4G wifi hotspot and nothing else so the ROM should be completely free of bloatware or any apps other than what it is needed to the run the hotspot service.
Doesn't really matter what android version it is.
What do you guys suggest?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    Hello Everyone.

    Good News for everyone. I have decided to maintain a help thread at Samsung S6 community in order to keep the threads for development/general section more clean and better organised. I have been noticing for a long time that whenever new users join, they still are not sure about the rules and thus mistakenly post in the wrong sections too often. If any senior member points it out to them, mostly it is either ignored or taken personally. Thus I have decided a combined help section would be very helpful to the community and the questions which are sometimes left unanswered and lost in question answer forums, that would not happen again for all of you.

    I would be trying my best to personally answer all your questions and shall refer you to someone in case I feel someone else would be able to answer the same question in a more detailed way. Other users can feel free to answer as well if you think you can tackle the situation well and make sure while answering any question, you provide enough information to the users as well. You can easily link the users to posts if you think a question has been already answered.

    REASONS I AM MAKING THIS
    Lots of repetitive questions.
    Same things told again and again
    Threads remain clean
    A simple reference to every important thread that you should visit in case you have a problem


    WHAT YOU HAVE TO DO
    Read the rules here XDA RULES BEFORE YOU POST
    Idea of this thread is to help and to be helped. So ask any question you have in mind related to S6, Android, or anything at all as long as it is related to your device directly or indirectly.
    Make sure you are precise with your information
    Be Detailed
    Do not repeat the same thing again and again
    Use search button to find if your question has been asked before. Do not repeat your question if it is answered before.

    WHAT INFORMATION YOU MUST PROVIDE
    1.Your bootloader status if applicable
    2. Rom name with complete baseband/date/version
    3. Kernel name
    4. Any Mods you are using
    5.If you are using Custom Rom, your flashing style i.e dirty/clean or you wiped anything else in specific
    6. If you used any guide, link to the guide
    7. Root status
    8. Your exact problem
    9. Any method you tried that failed
    10.Any other detail you think would be necessary

    Make sure you provide as much details as possible. Things like my phone won't turn on please help would not be of any help to you or to the person answering. So please make sure you provide as much detail so we know exactly what is your problem and thus guide you in the right direction.

    A sample would be something like this
    Device: SM-G920
    ROM name: CM 12 dated 10th May
    ROM version and base: 3.99-RC2
    Build number: CM_SM-G920-userdebug 4.3 JLS36G
    kernel version and its settings: 3.4.0-myspecial.kernel.plus [email protected] #193
    Rooted
    Sabertooth Mod
    I can not use my WIFI. Although i tried flashing Wifi modules but it does not work.
    I flashed CM over Stock firmware version X.X.X.X.Y.Z
    ETC

    Please remember "Give respect to others, others will respect you back!" in simple words, No abuse towards newbies/noobs will be tolerated here! So anyone found doing that would be reported.

    Another important thing is MAKE SURE YOU THANK THE PERSON who helps you. This is to show your appreciation to someone who personally took his time to answer your question. He had been nice enough to do it for FREE and nothing else. A simple thank you to his post will go a long way. The questions would be answered more and the one who is answering would be happy to answer more questions. So it is a gain gain situation for all of you. Read my signature because most people take help for granted here. So be kind to others and HIT THANKS BUTTON A LOT.
    5
    Some Requests to Users

    Although every effort would be made to answer all your questions
    but if you think your question has not been answered for more than 24 hours.

    Please mention anyone from our team in your post by editing it.


    Do NOT ask again. We will make sure that we personally answer your question.

    Do NOT mention all three of us, but if someone of us is busy, you can mention another user in next 24 hours. Please do not spam the threads or complain

    if your question is not answered. Try to keep this thread as clean as possible because the more clean it is , it be more easier for you to find your answers by using the search button

    Please use the search button often.



    Contributions
    @idler1984
    @techfanatic9
    @heahmad
    @rootSU
    @Lucas Eugene
    @Faspaiso
    @poczynek
    @madscientistdam
    @blackout720
    @owenbeals
    @androidizen
    @borimol
    @Mr.W0lf
    @HDxDaniel
    @TacticalMissions
    @me2352
    @JoeFCaputo113
    @meboy
    @Mc0815
    @MrKhozam
    4
    my device is the 920f and the the only firmware that worked for me after the all process is this one (G920FXXU3COL1_G920FVDS3COL2_G920FXXU3CPA1_HOME.tar) and i dont think that this is the only problem because as i said ive also tried to root with cf-root and not only twrp.

    but if you could please tell me step by step what to do in order to get twrp once again and to flash a rom again i will be forever greatful (superSU, twrp, root etc)






    Hi,

    Sorry for taking too long, I was a bit busy, but now I can reply.

    So, first things first, due to Knox bootloader it's not recommended to flash an older version of software than the one you are currently in. That may lead to some incompatibility that will lead to bootloops or laggy systems. So, let's begin the rooting process by flashing you a custom recovery.

    Download it from this link -- https://twrp.me/devices/samsunggalaxys6.html -- I believe you have Odin installed, open Odin, boot your phone in download mode and flash the file. Further instructions on this on the link I've sent you. I suggest ticking off auto reboot from Odin, after you are done, turn off the phone and boot in recovery. To boot in recovery hold the volume up button, home button and power button at the same time, when the text "Recovery is booting... Recovery is not SEAndroid Enforcing" appears I stop holding the power button, as you may shut it down.

    Now you should be at TWRP, if you aren't, that is you're in stock recovery, flash it again, also try downloading the file again, as you might have downloaded a corrupted file. If it just shuts itself down, try to download again and flash again. Also beware what I mentioned, sometimes you shut the phone down while holding the key combination for too long.

    Now on TWRP, plug your phone in your computer and download this file then copy it to your phone, you can also do it before booting in recovery. Now click install and open the zip you just downloaded, flash it and reboot. Personally I like to clear cache before rebooting, there's an option there.

    Everything should be fine now, if you didn't flash anything different or mess up any part up there it should be working fine. If it bootloops, please send a logcat, so I can try checking if there's any conflict.

    Give a huge thanks to this guy and this guy. Good luck!

    Hi, i wanted to downgrade to 5.1.1 before the FW that we can Optimize all the apps . just to test it.
    I already made all the tests for the battery and make part of the beta program test 6.0 and 6.0.1.
    And the best battery was a few months ago.
    Since that i never had that SoT.
    I test few FW's and now have latest XEF for now its stable. But not like it was before.
    I now battery could die a little bit with time,and s6 has a small battery.
    Stock no root..

    All the best.[/QUOTE

    Hi,

    I don't know if you are able to actually downgrade the S6 firmware due to Knox Bootloader. However you can try downloading the firmware from SamMobile and flashing it through Odin.

    i know its too late but i have to say this ive created and index using the new format

    [INDEX] Samsung Galaxy S6 Resources Compilation Roll-Up

    Hi,

    And an even more belated thank you! Keep the thread alive :).

    Couple of questions:

    I have a SM-G9208 (Chinese model Galaxy S6). It seems like it will be a while before any official Marshmallow firmware is released for it, so my question is: is it possible to install the firmware for a different model Galaxy S6 on this Galaxy S6? For instance, could I install one of the stock 6.0.1 ROMs on it?

    My next question is: Is it possible to flash a ROM without wiping my apps and user data? What's the best way to do this?

    Thanks a lot!

    Hi,

    First question is one that I ask myself as well, since my phone is my daily driver I didn't test yet, unfortunately. But I wouldn't risk flashing the bootloader of 920f (the one with stock marshmallow) on your 9208 device.

    As for the second question, I don't think so, most, if not all, ROMs require a clean install to guarantee stability. So please, make a TitaniumBackup or something of the kind and happy flashing :).

    Hi,
    Before posting I'd try my best to search for the right answer, but there are just too many views.

    I wont be able to provide details because my phone is locked because of the fingerprint issue. Worst is my data and WiFi are off, so can't even unlock via Google. I am using g s6 g920i, the one officially available in india.

    As far as I knw, factory rest is the only option in this case. But I just wanted to extract my pictures and videos before I do that. Since it's a 10 day old phone, I have not enabled USB debugging.

    What I wanted to know is how can I install twrp recovery and pull my data out us inch adb. My only concern is pictures and videos. I know Ill loose on warranty.
    Looking forward to a positive solution.

    Thanks

    Hi,

    I've posted an answer to a similar problem some time ago, let me give you a link -- http://forum.xda-developers.com/showpost.php?p=63236926&postcount=324.

    Thanks. All of your cons except slippery are not serious to me as they are the same existing things on iPhone. The camera lens is protruded so is it necessary to have a case?

    Hi,

    The phone felt slippery at first, then it was okay after getting used to it to me. Same for the protruding camera, I got used to a slightly inclined position it stays while I'm using it on a table. If you want a minimalist case I am using a Samsung Clear Case, has been working fine, but I usually only put it on when I'm going out of my house, else I keep it "naked", I like the way it feels haha.

    But yeah, if you feel like it's too slippery or that you are worried of the protruded camera, get yourself a case, better than having it slipping from your hands or scratching the camera lens (which even though I don't rely too much on my case still didn't happen to me).

    All the best,
    ~Lord
    4
    Thanks for the answer
    Unfortunately she didn't set anything up! No Samsung account, no Google! And the only she needs now is her pictures so if ADB Pull helps wih that I'd be glad if you help me :)

    Hi,

    First, I suggest next time after Factory Reset she configures Samsung Account, Google Account, maybe an OneDrive or Dropbox account to keep pictures backed up and note down her Backup Password hehe ;).

    Now, for the ADB Pull, first thing you'll need to do is flash a custom recovery, so you have access to the files inside the device (unless she encrypted it, then we're out of options). To flash a custom recovery download Odin 3.10 and a custom recovery of your preference. I suggest TWRP - http://forum.xda-developers.com/galaxy-s6/orig-development/twrp-t3080940 (thank this post) - you can download from this link. To install follow the link instruction.

    Now, download the adb package that was provided earlier to you and place them all under a folder. Power off your device and boot in recovery using Power Button + Volume Up + Home Button all at the same time. In recovery you'll go to Mount menu, and mount everything. Now plug your device and open a CMD (if you are on Linux tell me and I'll update the instructions) on the folder that adb files are located.

    The adb pull command word like this:

    Code:
    adb pull "folder to be backed up" "folder destination in your computer"

    Now with CMD open, you'll need to type the following:
    Code:
    adb devices

    If there your device appeared on the list, then you are ready to perform the backup, else you'll need to check if all your drivers are properly installed. With the device ready, type:

    Code:
    adb pull /sdcard/DCIM PhotosBackup

    It takes a while to complete. You can replace PhotosBackup with any other folder name you want. If you want you can backup all the files in internal memory using this:

    Code:
    adb pull /sdcard Backup

    Now just factory reset the device and you're good to go! I hope it helps!

    All the best,
    ~Lord