Fast charging is gone

Search This thread

TokedUp

Recognized Contributor
Dec 27, 2010
3,619
1,317
Hellz Kitchen, NYC
Anyone know what I have to do to get fast charging back? I have the option enabled in settings. The cord is good, my wife's phone fast charges just fine with it. I've soft reset the phone, cleared cache, and just about any other option I could find on the web. So weird cuz it was working fine not too long ago but just noticed now that I can't get it to work.
 

gruuvin

Senior Member
Nov 24, 2011
699
217
Atlanta
Anyone know what I have to do to get fast charging back? I have the option enabled in settings. The cord is good, my wife's phone fast charges just fine with it. I've soft reset the phone, cleared cache, and just about any other option I could find on the web. So weird cuz it was working fine not too long ago but just noticed now that I can't get it to work.
Is her phone the same model as your phone?
 

TokedUp

Recognized Contributor
Dec 27, 2010
3,619
1,317
Hellz Kitchen, NYC
No issues with any other stuff except fast charging. The phone charges fine but just say fast charging and takes forever. It's so weird cuz in my car my phone would barely charge when hooked up to USB in console, but then soon as I lost fast charging at home it started fast charging in the car. I just don't get it
 

Bober_is_a_troll

Senior Member
Aug 19, 2019
160
39
No issues with any other stuff except fast charging. The phone charges fine but just say fast charging and takes forever. It's so weird cuz in my car my phone would barely charge when hooked up to USB in console, but then soon as I lost fast charging at home it started fast charging in the car. I just don't get it

Well luckily normal charging and USB still works so it's not the worst. At least your battery will last a little longer now?
 

paul_59

Senior Member
Feb 6, 2011
524
148
My advice would be install an app like accubattery

https://play.google.com/store/apps/details?id=com.digibites.accubattery

It will show current when charging.

Fast charging being displayed by Android only seems to indicate fast charging is enabled rather than actually occurring.

I find when fast charging is occurring with standard Samsung charger, but not original cable it will show approximately 2800 mA.

It did seem to be below this rate a few months ago when ambient temperatures were higher and battery temp got above 36 °C

I also bought an unbranded charger cable that has an led that illuminates bright when high current charging and dimmer when charging at lower rates.
 

renehd2

Senior Member
Nov 2, 2010
1,295
148
Androidpolis
Ive had this problem with all my samsung phones since galaxy s8. I dont know why after some months the phone loses the ability to fast charge (it happened to my s8, note 8 and currently note 9)

Enviado desde mi SM-N960U mediante Tapatalk
 

amirfathi

Member
Jan 4, 2020
5
0
36
Hsinchu
I finally replaced the usb-c port

I had the issue that fast charging was gone and it charged very slow sometimes. I did many searches and did everything I could do. none changed anything. finally I went to Samsung and they replaced the port.