Development [FASTBOOT][ROM][UNOFFICIAL][OP9RT] OxygenOS A.04-A.08 for MT2110 devices

Search This thread

phtis

New member
Jun 23, 2022
3
0
nope, just reported to Oneplus officially, do you have the same issue as well?
I had the same issue. the rainbow colour display not only occurs on the 50MP camera mode but also while QR scanning.

The weird thing which I tried was to restart the phone, which then reverted my smallest width setting in Developer Options which is probably another bug. After I changed the smallest width setting back again (to 490dp), the problem went away.

Right now, 50MP camera mode is working properly and the QR code scanning on various apps is fine. however, the issue does appear intermittently again, but going across different apps, and toggling the 50MP mode on and off a few times seems to help with the issue.

I'm not sure if this method can fix your issues, but worth a try. at least till the bug is fixed.
 

loleepop

Member
Jun 23, 2022
6
1
I had the same issue. the rainbow colour display not only occurs on the 50MP camera mode but also while QR scanning.

The weird thing which I tried was to restart the phone, which then reverted my smallest width setting in Developer Options which is probably another bug. After I changed the smallest width setting back again (to 490dp), the problem went away.

Right now, 50MP camera mode is working properly and the QR code scanning on various apps is fine. however, the issue does appear intermittently again, but going across different apps, and toggling the 50MP mode on and off a few times seems to help with the issue.

I'm not sure if this method can fix your issues, but worth a try. at least till the bug is fixed.
I have this exact same issue and doing what you said didn't change anything - still need to go through the camera on/off dance to get it working (for one time).

Waiting for further info on this...
 

Cathair2906

Senior Member
Sep 2, 2012
114
115
I had the same issue. the rainbow colour display not only occurs on the 50MP camera mode but also while QR scanning.

The weird thing which I tried was to restart the phone, which then reverted my smallest width setting in Developer Options which is probably another bug. After I changed the smallest width setting back again (to 490dp), the problem went away.

Right now, 50MP camera mode is working properly and the QR code scanning on various apps is fine. however, the issue does appear intermittently again, but going across different apps, and toggling the 50MP mode on and off a few times seems to help with the issue.

I'm not sure if this method can fix your issues, but worth a try. at least till the bug is fixed.
I will try to change the smallest width as you said.

Btw, are you also converting it from COS to OOS?
 

phtis

New member
Jun 23, 2022
3
0
I bought a MT2110 but it was pre-installed with a "Lahaina with arm64" rom. I then updated via OTA to MT2111 A.08, I didn't have to do the installation as mentioned in this thread.

Smallest width doesn't really work, it was just something that I experienced and shared. Because right after I restarted, it messed up my smallest width setting, and when I set it back again, the QR code scanner seemed to work. However, that was short-lived.

The main temp fix seems to be going back into the camera and toggling 50MP mode on and off.
 

anbell

New member
Jun 24, 2022
2
0
After flashing, the display model is MT2111, and the 120Hz high refresh rate of the King of Glory cannot be turned on. Do you want to change the default model to MT2110?

刷完后显示型号为MT2111,无法开启王者荣耀的120Hz的高刷,是否更改默认的型号为MT2110
 

Cathair2906

Senior Member
Sep 2, 2012
114
115
I bought a MT2110 but it was pre-installed with a "Lahaina with arm64" rom. I then updated via OTA to MT2111 A.08, I didn't have to do the installation as mentioned in this thread.

Smallest width doesn't really work, it was just something that I experienced and shared. Because right after I restarted, it messed up my smallest width setting, and when I set it back again, the QR code scanner seemed to work. However, that was short-lived.

The main temp fix seems to be going back into the camera and toggling 50MP mode on and off.
It seems A10 has fixed the issue now
 

jordenng

New member
Jul 9, 2022
1
0
Thanks for the method! I was successfully migrated my MT2110 from color OS to Oxygen OS, After that I upgraded to Android 12 Beta and downgraded back to 11 with Oneplus forums packages. Currently version is A10 and I have downloaded appllications on it. So my question is can I relock bootloader for MT2110 device which using Oxygen os?
 

Active-Hawk

Member
Feb 3, 2020
13
2
Thanks so much for this release! I'm curious about one thing though. I'm a novice user and I'm concerned about security. Does the fact I can lock the bootloader mean that this release only contains completely unmodified data from OnePlus?
 

DimaX111

Member
Dec 22, 2014
10
0
OnePlus 9RT
Thanks for the method! I was successfully migrated my MT2110 from color OS to Oxygen OS, After that I upgraded to Android 12 Beta and downgraded back to 11 with Oneplus forums packages. Currently version is A10 and I have downloaded appllications on it. So my question is can I relock bootloader for MT2110 device which using Oxygen os?
Hi, the apk of System update can't find the open beta 1 .jar file for some reason. It feels similar to your issue.
I bought MT2110 from china but received it with the A08 "Oxygen OS Android 11.3" and for some reason, it writes "MT2111" in the settings.
Is this Oxygen OS or ColorOS?
Can I update to the open beta of Android 12?
 

DimaX111

Member
Dec 22, 2014
10
0
OnePlus 9RT
Hi, the apk of System update can't find the open beta 1 .jar file for some reason. It feels similar to your issue.
I bought MT2110 from china but received it with the A08 "Oxygen OS Android 11.3" and for some reason, it writes "MT2111" in the settings.
Is this Oxygen OS or ColorOS?
Can I update to the open beta of Android 12?
it turns out I needed to delete the .jar file suffix. :| now works.

Issues still exist on my phone also after from update:
1. I don't have 5g at all
2. People can't call me (the phone seems to them OFF)
3. When I call people it takes like 10 seconds to start calling (hearing any beeps)
4. Notifications often get not sent - many times I don't see any notification in apps but when I enter, I see stuff that should've gotten to me (i.e., the Taxi driver is near)
 

g96818

Senior Member
Dec 27, 2014
534
154

Top Liked Posts