Fermata Media Player - audio and video player for Android Auto

Search This thread
I can never make Fermata 1.8.11 to work. It always says "Fermata Control seems not to be working"

Are there any clear instructions how to install?

- Should I install both Fermata and Fermata Control, both by KingInstaller, or how?

- Should I patch both of them in AA AIO Tweaker, or only Fermata or how?

For the matter of fact Fermata 1.8.10 (it came without that Fermata Control - whatever that Control is) worked seamlessly!
Install with King and test.
 

zgfg

Senior Member
Oct 10, 2016
7,391
4,783
Install with King and test.
Yes I did install with KingInstaller and it doesn't work: always Fermata Control seems not to be working

Again, can you please give clear answers how exactly you did to get it working:

1) Should I install both Fermata and Fermata Control by King (I did so, no luck)?

2) Should I patch in Tweaker only Fermata (as I do) or also Control?

Both are installed but when I go to Settings, Apps, it says that Control was never started?!
It means that Fermata doesn't even start Control (instead it writes: Fermata Control seems not to be working)
 
Yes I did install with KingInstaller and it doesn't work: always Fermata Control seems not to be working

Again, can you please give clear answers how exactly you did to get it working:

1) Should I install both Fermata and Fermata Control by King (I did so, no luck)?

2) Should I patch in Tweaker only Fermata (as I do) or also Control?

Both are installed but when I go to Settings, Apps, it says that Control was never started?!
It means that Fermata doesn't even start Control (instead it writes: Fermata Control seems not to be working)
Try to change your AA i use one recently version
 

zgfg

Senior Member
Oct 10, 2016
7,391
4,783
Try to change your AA i use one recently version
I was testing with the latest AA.
Thank you but I still don't understand while are you avoiding to answer the precise questions?!

Anyway - I have returned back to Fermata 1.8.10 - and my advice is: Use that version and disable in Fermata, Settings, Other, Check for the newer versions
 

darix96

Senior Member
Mar 8, 2013
84
15
italy
I've no idea how to have this work without root
I've tried with
king installer
Adb
Aaad
Downgrade Android auto to 6.9
I'm on realme gt neo2 with android 11
The app install successful but on android auto didn't appear why?
Is 2 months that I can't use anything in android auto?
Someone can help me?
 

CHARLY_A 1961

Member
Aug 4, 2015
15
3
No tengo idea de cómo hacer que esto funcione sin root
he probado con
rey instalador
Anuncio
Aaaa
Rebajar Android Auto a 6.9
Estoy en realme gt neo2 con android 11
La instalación de la aplicación fue exitosa pero en Android Auto no apareció, ¿por qué?
¿Son 2 meses que no puedo usar nada en android auto?
¿Puede ayudarme alguien?
Hello I have Realme gt master edition, i have your problem. Is impossible appear custom apk in AA because i not encounter the reason of this problem, i use all metod you describ not have result the only final chosee is flash another rom stock more old please wend you have solution for this problem. Writeme
 

lalapa

Member
Mar 8, 2014
12
1
App is working but i cant use it because some car brands like Mazda and BMW dont allow us to use touchscreen we can only control from joystick but app not support our joystick so we cant choose anything from youtube we can only scrol the page :/
 

Sjhingan

Senior Member
Jul 24, 2018
106
4
Google Pixel 6
Hi all, I have a op3t rooted with Magisk, running AA 7.1 . I used titanium to freeze the play store and GPS so no apps auto update and i am not forced to update the AA version to newer versiopns, in case it causes a problem. To my surprise AA is still forcing me to update to the latest version. What do i need to do so that i'm not forced to update to the latest AA version ever. Someone suggested destroying all market links but im not sure if that a viable option. Any suggestions would be appreciated.
 

abhi0502

Senior Member
Dec 3, 2013
915
487
Mumbai
OnePlus 7 Pro
is fermata auto working with android auto in android 12 AOSP ROM? I tried by installing kingsinstaller or by AA AIO tweaker app, but still Fermata Auto is not showing in android auto. By enabling developer option i can see fermata auto control but still not Fermato auto? Is there any solution?
On Android 11 AOSP ROM fermata auto works with kingsinstaller in Android Auto
 

Hole_12

Member
May 6, 2021
9
0
Hello everyone

I had on the Moto G5 Fermata1.7.7, Auto and Control, AA 6.3.61 on A 8.1.0 running without root installed with ADB

Now with AA 7.3.62 download AAAD 1.4.3 and install Fermata Auto 1.8.11 (F. Control I don't have it), on the mobile all OK but on the

AA screen of the car does not appear Fermata. Do I need Fermata control? In AAAD it does not appear. What am I doing wrong?

Can any of you help me?

Thanks
 

20ducks

New member
Jan 1, 2022
1
0
I have no idea if I am asking the right question in the right forum etc. but, here goes: I downloaded off a popular site dozen's of music videos. I play them through AAAD/Fermata and have no issues whatsoever. I would like, however, to be able to skip through some of the tracks (genre's are many) to a track I want to hear. When it circles back to tracks that I have skipped through it will only resume at that point I went to a new track. Do I make any sense? Anyway, I am trying to find out how to "reset" these mp4' so they will start from the beginning. I use a Samsung S21 Ultra non-rooted.
If I am at the wrong spot on the interweb to ask them please direct me where I should go for help. Thank you for your help.
 

markinhosmrk

Member
Apr 25, 2012
25
12
Hi guys,

For those who have root, I think I found a way to avoid Android Auto removing apps:

1. Clear app data for AA and set up it on your car the way you like it
2. Use a terminal to change permission for AA shared_prefs directory under /data/data/com.google.android.projection.gearhead (I used root shell, not sure if it would work without it)

chmod -R 551 /data/data/com.google.android.projection.gearhead/shared_prefs

It has been working fine for a couple days but I guess you won't be able to change any setting.
 
  • Like
Reactions: tiho5 and sosimple

SOFO888

Senior Member
Jan 28, 2013
271
44
Can you please explain this permission?
What happens exactly when you change this permission?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi guys!
    Just an update, I've been using the procedure below for about two months and still working fine.
    I've just updated from 7.5 to latest 7.8 beta and those permissions were kept, didn't have to make any change, and I still see Fermata listed.

    Thanks,
    Marcos

    Hi guys!

    Doing more tests... it seemed that only working with shared_prefs eventually did not work. I made further changes and so far (~ 3 days and multiple force closes/reboots) everything still working fine.

    1. I noticed some files being created under phenotype/shared dir. This one specifically, com.google.android.libraries.consentverifier#com.google.android.projection.gearhead.pb, is not present right after clear data but gets downloaded later on.

    I emptied it with "echo "" > com.google.android.libraries.consentverifier#com.google.android.projection.gearhead.pb" - if it does not exist you can use touch to create an empty file - and also changed ownership of the entire shared/ dir to root and set permissions to 400 (only root user can read them). So far everything working.

    I also saw that on the shared_prefs when I made them read only AA created new files. Maybe we can let them with default permissions and settings can be changed - I left them since I set it up the way I like it and don't think will need to change anything later.
    My AA release is 7.5.121304, a beta from APKmirror.

    Commands to test, right after clear data:

    chown -R root:root /data/data/com.google.android.projection.gearhead/files/phenotype/shared touch /data/data/com.google.android.projection.gearhead/files/phenotype/shared/com.google.android.libraries.consentverifier#com.google.android.projection.gearhead.pb chmod -R 400 /data/data/com.google.android.projection.gearhead/files/phenotype/shared/* chmod 600 /data/data/com.google.android.projection.gearhead/files/phenotype/shared

    Let me know how it goes for you, I think I might be on the right track here!

    Thanks,
    Marcos
  • 23
    Fermata Media Player is a free, open source audio, video and TV player with a simple and intuitive interface. It is focused on playing media files organized in folders and playlists.

    Supported features:

    ⚫ Play media files organized in folders
    ⚫ IPTV addon with support for EPG and archives
    ⚫ Youtube and web browser addons
    ⚫ Support for network folders: SFTP, SMB (CIFS), Google drive
    ⚫ Remembers the last played track and position for each folder
    ⚫ Support for favorites and playlists
    ⚫ Support for CUE and M3U playlists
    ⚫ Support for M3U playlist URLs
    ⚫ Support for bookmarks
    ⚫ Shuffle and repeat functions
    ⚫ Playback timer
    ⚫ Audio effects: Equalizer, Bass Boost and Virtualizer
    ⚫ Configure audio effects for individual tracks and folders
    ⚫ Configure playback speed for individual tracks and folders
    ⚫ Sort tracks by name, file name, date or randomly
    ⚫ Customizable titles and subtitles
    ⚫ Support for Android Auto
    ⚫ Pluggable media engines: MediaPlayer, ExoPlayer and VLC
    ⚫ Video player with support for subtitles (VLC Engine only)

    There are two version of the player:

    1. The first one has support for Android Auto as a media service. This version is available on Google Play - https://play.google.com/store/apps/details?id=me.aap.fermata
    2. The second one provides the same functionality, but can be launched as an Android Auto application, i.e. with its own interface:


    IMG-20191227-211919.jpg

    IMG-20191227-211944.jpg



    To install this version, you may either use the Android Auto Apps Downloader (recommended) or, for manual installation, follow the instructions below. Before the installation, make sure that the "Unknown sources" option is enabled in the Android Auto settings. To enable this option, open AA settings on your phone and go to the "Developer Settings" section.

    Manual installation
    Installing with KingInstaller (attached):
    • Download and install the attached apk.
    • Open KingInstaller.
    • Select Fermata-auto.apk, downloaded from Github.
    • Press the install button.
    Installing from PC (adb utility is required, does not work for Android 11+):
    • Install adb - https://www.xda-developers.com/install-adb-windows-macos-linux/
    • Connect device to USB
    • Open console and run the following commands:
    • adb push fermata-XXX-auto-universal-armXX.apk /data/local/tmp/fermata.apk
    • adb shell pm install -i "com.android.vending" -r /data/local/tmp/fermata.apk
    • adb shell rm /data/local/tmp/fermata.apk
    Installing from Android (ROOT is required):
    • Install the downloaded apk.
    • Download and install AIO Tweaker - https://github.com/shmykelsa/AA-Tweaker/tags .
    • Start the tweaker, open the apps list, select Fermata Auto in the list, return to the main screen and press the PATCH button. Reboot the device.
    Before connecting to Android Auto:
    • Install the fermata-auto-control apk. This application is only required if you need support for steering wheel media buttons.
    • Start the player, grant permissions and add folders.
    7
    Temporary solution with changed package name.
    5
    New in 1.7.0 Beta https://github.com/AndreyPavlenko/Fermata/releases/tag/v1.7.0b :
    Youtube web view.
    Basic web browser with support for bookmarks and full screen.
    Gestures support by video and control panel view:
    - Vertical scroll - volume up/down
    - Horizontal scroll:
    1 finger - emulates rw/ff button click (skip 5 seconds by default)
    2 fingers - long click on rw/ff button (skip 20 seconds)
    3 fingers - long click prev/next button (skip 5%)
    Swipe left/right - play prev/next track
    Swipe up/down - play prev/next folder
    Double click - play/pause
    3
    Fermata stop working on 7.0 too were I use few day ago. I think Google blacklisted it, maybe try to rename package name can be a workaround
    Seems like that :( Package renaming works, but I don't think it's a good solution. Google has many ways to block any app.
    3
    Unfortunately, for both situations (checked or not) netflix gives only sound no picture 😔
    I'll update webkit in the next version. Perhaps, it will help.