Finally CWM Recovery 5.0.2.7-nAa-r2 for Stock Xperia Neo/Neo v [With Lock Bootloader]

Search This thread

sujithar37

Senior Member
Jan 15, 2014
71
62
Trivandrum, Kerala
Using a custom kernel...

Sent from my Xperia Neo V using Tapatalk 2

Once you unlocked bootloader you are totally free from Sony security

From my experience with custom rom, I would say custom kernel is the best one compare with the stock kernel.

Lot of custom kernels are available in neo v threads or rom threads. You can simply flash the kernel via fastboot mode. Always remember you have to unlock the bootloader inorder to do the same. Else your phone will brick. Once you flashed custom kernel then you don't need to worry about the cwm installation. Most of the custom kernel has cwm by default...

So my suggestion is unlock bootloader and have fun with your neo v...I am using custom rom since 3 years now..totally I forget about Sony.....thanks to xda and shame to Sony update.;) ;)

Sent from my Xperia Neo V using xda app-developers app. Hit thanks if it helped ;)
Donate me if you can :cool:
 

blu3m3

Member
Oct 14, 2010
38
0
Bootloader locked, installed via conversion to recovery .img file. I know that cm7 NEEDS bl open and custom kernel. Made it for curiosity.

Enviado desde Xperia Neo con Tapatalk

Hello, i need to install Cyanogen on Xperia Arc S,
So ...
1. I rooted my phone useing Eroot
2. I installed SuperSu
3. With CWM_Installer-v5.apk i install CWM recovery

I have the same problem with all custom roms, when i try to flash them i receive status 7 error.
I checked on youtube and google for fixing this.
I deleted the Asserts from META-INF/com/google/android/updater-script”.

And i still same error
Some recomanded to update to phillz recovery or twrp
I tried to flash Twrp but the phone skips to enter recovery mode after flashing twrp

My phone has bootloader locked and i could not unlock bootloader.
I checked on sony website for
Unlock the boot loader
i typed
*#*#7378423#*#*
App Service info > Configuration > Rooting Status. Bootloader unlock allowed says NO
I asked for my code
fastboot -i 0x0fce oem unlock 0x90F9F5C0082C32F3
i started ADB, when i type adb devices is shows the phone , but when i type fastboot devices, i receive no response

So my question is:
How can i change CWM with Phillz or TWRP? and where can i find and working Phillz recovery for xperia arc S
 

Top Liked Posts

  • There are no posts matching your filters.
  • 84
    Hey guys......Finally its here...Install latest CWM Recovery without unlocking u r Boot loader.....


    New method: Just install the apk ane follow the steps... *Root Requiered.Thanks to emannxperia ;-)
    APK:

    https://play.google.com/store/apps/details?id=com.pvy.CWMinstaler

    APK SUPPORT PAGE:
    http://forum.xda-developers.com/showthread.php?t=1437840

    For reporting bugs abt the app and for thanking the developer plz visit the above thread


    ClockWorkMod Recovery 5.0.2.6 Easy installation for Xperia NEO/NEO V *Requires Root


    #UPDATE: This method wrks perfectly on ICS. Tried on my own and also tested by othrs :D
    #Also Works on All 2011 Xperia Devices on Stock 2.3 ROM
    #Also Works on NEO SE.TWEAKED V0.7..........Thanks for thx84 for the info
    ;)

    1.Run install-cwm?.cmd
    install-cwm1.cmd for Xperia Arc / Neo / Neo V
    install-cwm2.cmd for Xperia Mini / MiniPro / Active / Live With Walkman
    2.Enable USB Debugging on device
    3.Connect your device using usb data cable
    4.Follow on screen instruction

    CWM install Download UPDATED*
    Update : support Xperia Arc / Neo
    Updated to CWM-5.0.2.7-nAa-r2

    ADB Driver Download UPDATED

    ADB Driver tested on :
    - Xperia Arc
    - Xperia Neo
    - Live With Walkman
    - Xperia Mini Pro

    The Above one is the Easier Method and below is the old copying method using Root Explorer :


    Installation *Requires Root
    Download CWM From here and extract its contents.

    Using Root explorer: copy ALL the contents of the system folder (system/bin and system/xbin) to /system (system/bin and system/xbin respectively), then give 755 permissions to those files, especially to /system/bin/chargemon, or you'll get bootloop. Double check everything before rebooting.


    attachment.php





    Usage

    When booting your phone and when the 'Sony Ericsson' logo appear, press and release continuously the volume down button.
    Once you are in the CWM recovery, use the volume keys to navigate upwards / downwards, the 'home' key to select, the 'back' key to go back.


    Notes to everyone:

    Do NOT use this recovery if you are not in Stock 2.3 firmware.




    This is not my own Thread and All Credits Goes to nobodyAtall



    Credits:

    • draco_ag for his effordless testing and debugging :)
    • koushd for writing the piece of software the first place
    • Cyanogen for the obvious reasons...
    • pvyparts for the awsm app




    ##This is not made by me,i just posted it.Its made by the Devs over here in XDA.So Don't worry of Bricking Your device. Its tested completely. Even though, Myself or anyother Dev is not responsible for Damaged Device ;)

    Original Thread
    5
    IT WORKED Its all good looking with cyan color

    for those who r are unable to enter recovery , try this

    1. switch off your phone
    2. press the power button & quickly start pressing the VOLUME DOWN button untill RECOVERY appears
    ( i started pressing volume button way before i saw SONY ERICSSON logo )

    BUTTON BEHAVIOR ON NEO V

    back button : back
    home button : select option
    menu button : scroll down
    volume up/down : scroll up/down
    2
    2
    when i want to go into recovery mode! It gets stuck in Sony Logo!

    I'm pretty sure you're doing some mistake in installing as I was able to use it perfectly when I was on stock ICS(I now moved to MIUIv4)....do one thing try once again with script method because I mostly used to install with it....before connecting your phone with computer make sure u've:
    (1) installed adb drivers for ur device using Android SDK
    (2) enable "USB DEBUGGING" from (Menu\Settings\Developer Options\Development)
    (3) enable "UNKNOWN SOURCES" from (Menu\Settings\Security)
    (4) [OPTIONAL] increase screen timeout to 10 minutes
    (5) connect USB cable to PHONE in MTP mode and then connect to PC
    (6) skip "PC Companion Software" prompt on device

    if unluckily above method don't work then you need to have do it manually by copy-pasting files using any file manager with root permission I use ES file explorer....from options mount root as writable....then copy "chargemon1" "chargemon2" "cwm-rec" "recovery.tar" in /system/bin and "su" in /system/xbin and change ALL file permission to 755 like screenshot given on first page.....

    Hope now you'll be able to install....
    1
    It gets deleted after flashing the stock .ftf file, how to install CWM permanently?

    If you are using stock firmware then you don't have cwm,root by default.
    So you have to root your device first then you have to install Cwm on your device. Because root permission is needed for installing cwm. This is the step by step method.

    For rooting stock firmware, refer below the links
    http://forum.xda-developers.com/showthread.php?t=2220568

    For installing cwm permanently, refer below the link
    http://forum.xda-developers.com/showthread.php?t=2220568


    Sent from my Xperia Neo V using xda app-developers app. Hit thanks if it helped ;)
    Donate me if you can :cool: