Finally got the Android 11 update on my 5 II

Nezorflame

Senior Member
Sep 7, 2009
914
2,554
138
Moscow
nezorfla.me
So we in RU were the last ones to receive the December security patch 2 days ago... and now we're the first ones to receive the Android 11 update for the XQ-AS52 model: XperiCheck.com - Xperia 5 II (XQ-AS52) - Customized RU
What a time to be alive.

Anyways, the update is live on the XperiFirm. I've updated without the userdata to preserve my data.
Everything works, they've even fixed the refresh rate bug (screen was stuck on 60hz for some time after the reboot for me).

WARNING: The only thing that doesn't work for me right now is Magisk - flashing the patched boot.img resulted in a bootloop.
Will try to grab logcat later to see if it has anything of value.
For now I don't know if it's caused by some of my modules from the A10 install, may have to clean flash later to confirm, but just in case, be prepared that the same might happen to you.

If you have any additional questions about the update, fire away.
 

Attachments

Jayram2000

Senior Member
Sep 14, 2015
85
19
38
Tampa
So we in RU were the last ones to receive the December security patch 2 days ago... and now we're the first ones to receive the Android 11 update for the XQ-AS52 model: XperiCheck.com - Xperia 5 II (XQ-AS52) - Customized RU
What a time to be alive.

Anyways, the update is live on the XperiFirm. I've updated without the userdata to preserve my data.
Everything works, they've even fixed the refresh rate bug (screen was stuck on 60hz for some time after the reboot for me).

WARNING: The only thing that doesn't work for me right now is Magisk - flashing the patched boot.img resulted in a bootloop.
Will try to grab logcat later to see if it has anything of value.
For now I don't know if it's caused by some of my modules from the A10 install, may have to clean flash later to confirm, but just in case, be prepared that the same might happen to you.

If you have any additional questions about the update, fire away.
Nice!

My XQ-AS72 has gotten it too, but not my specific regional model. The SEA model has it, but my HK model hasn't gotten it yet. I'm tempted to try it over the HK rom, idk if that would have any negative effects.
 

CazeW

Senior Member
Nov 14, 2008
862
452
83
As many users have complained about the camera (personally I have no problems with it), have you noticed any changes to it?
 

141ptkelly

Member
Nov 3, 2020
25
2
3
I got my XQ-AS72 yesterday. I live in Oaxaca, Mexico, my phone came from Seattle, Washington, in the U.S. and I'm guessing from the charger it originated somewhere in Europe. Two significant updates were waiting. I think one was a December security update and the other was Android 11.
 

kattara

Senior Member
May 2, 2011
299
26
58
Vancouver
WARNING: The only thing that doesn't work for me right now is Magisk - flashing the patched boot.img resulted in a bootloop.
Will try to grab logcat later to see if it has anything of value.
For now I don't know if it's caused by some of my modules from the A10 install, may have to clean flash later to confirm, but just in case, be prepared that the same might happen to you.

If you have any additional questions about the update, fire away.
Did you do the clean flash?