Question Fingerprint Scanner gone

Search This thread


Senior Member
May 30, 2013
Sony Xperia 5 III
Out of the blue yesterday my fingerprint scanner just stopped working. I dint pay much attention to it because i was busy and thought it was a dirty sensor. But today after cleaning it it's still not working. It seems the entire setting is missing, I can't find the fingerprint manager in Settings -> Security!

What gives!? I think this the last Sony smartphone for me. Too many silly issues .

Anyone had this issue with a 5III? and has a fix? I saw in the xperia 1 forums some ppl had the issue but no definite fix, neither rebooting nor reflashing the OS has worked.


Feb 15, 2018
Yeap. If you read my recently opened thread I got exactly the same problem. I sent the phone for service and not only have they created new problems (disabling updates somehow) but the fingerprint sensor failed again within a day!
Sony did almost two weeks to react to my new complaints and even though I was trying to convince them to just give me a new device and get done with it they tell me to send it again for service. A month is past overall.

P.S. I bet it is some cabling issue because I also reflashed the software when the problem appeared using the Xperia companion and no luck. Sony service changed the chipset and the button (but I assume not the cable?) And as I said it failed again. And after I got the phone back updates don't work and Xperia companion does not work. Don't they even test it??? Saying that I am pissed is an understatement.
Last edited:


Senior Member
Apr 23, 2012
Ahh seeing your post here, it seems more of hardware issue than software. Checking in with Sony (if it's still under Warranty) should be the best bet for both. Please do try to share your experience here on how the whole process goes. Understandable it's a pain at the moment. :(