Fingerprint sensor - discussion

Search This thread

googam

New member
Nov 15, 2019
1
1
Hello,

I’m using the Xperia 5 since this Wednesday (for two days).
My overall experience with phone is mostly good (for most parts of using even perfect). Unfortunately, these nice words do not apply for the fingerprint sensor.
It usually takes 2-5 tries to unlock the phone, sometimes I can’t even open the phone with the fingerprint scanner at all. (The error messages are: Not recognized; could not process fingerprint, please try again. Sometimes it says something with "partial fingerprint").
I tried rebooting recalibrating the fingerprint with the wizard then rebooting again. Nothing seems to help. I know this doesn’t have to be eventually a defect or something. Fyi, my thumb is not moist or oily, same thing applies for the reader. Maybe my thumb is just too wide, I don’t know.

What’s your overall experience?

Jakub
 
  • Like
Reactions: pierro78

HellRoot

Senior Member
Feb 12, 2012
1,484
300
Hello,

I’m using the Xperia 5 since this Wednesday (for two days).
My overall experience with phone is mostly good (for most parts of using even perfect). Unfortunately, these nice words do not apply for the fingerprint sensor.
It usually takes 2-5 tries to unlock the phone, sometimes I can’t even open the phone with the fingerprint scanner at all. (The error messages are: Not recognized; could not process fingerprint, please try again. Sometimes it says something with "partial fingerprint").
I tried rebooting recalibrating the fingerprint with the wizard then rebooting again. Nothing seems to help. I know this doesn’t have to be eventually a defect or something. Fyi, my thumb is not moist or oily, same thing applies for the reader. Maybe my thumb is just too wide, I don’t know.

What’s your overall experience?

Jakub
I got it working but putting my finger along the side of it and not by using the thumb having the finger pointing out from the phone.
Mine works almost every time now.

But it is indeed not the best scanner.

Sent from my [device_name] using XDA-Developers Legacy app
 

yekollu

Senior Member
Mar 19, 2013
188
23
Berlin
I have the same issue as well, as do many others evident from Sony Forums however the FPS works fine Banking apps, website logins etc
 

japkoslav

Member
Apr 15, 2015
9
1
So, you didn't use Z5 series. That was the worst fingerprint sensor. Fingerprint sensor didn't work more than it worked. This one on 5 is better but not good. Sometimes it doesn't work at all.

I didn't use a Sony phone with fingerprint sensor before :)
I am kinda used to finger print sensor being 99,99% accurate and reliable (iPad, Meizu, Nokia, LG, Samsung, Asus, Xiaomi etc.) so that's why I am surprised it can implemented so poorly. :silly:
 

Tricky547

Member
Mar 8, 2008
27
3
Honestly after 2 weeks with this phone, I'm beginning to question whether it has a fingerprint scanner at all. Feel like I may as well just remove my fingerprints and forget it exists.
 

Dioser

Senior Member
Oct 20, 2010
1,566
426
Honestly after 2 weeks with this phone, I'm beginning to question whether it has a fingerprint scanner at all. Feel like I may as well just remove my fingerprints and forget it exists.
I sold mine last week, of same reasons. Useless fp, might as well be non existent.
 

thsieh

Member
Mar 17, 2011
5
2
I had to retrain myself with how to use the finger print scanner. With other phones, I'm used to using the tip of my finger, but that doesn't work with this scanner. As HellRoot describes above, I now lay the flat part of my finger against the scanner so that my finger is parallel to the phone (not pointing at an angle). Now I can get it to work very reliably.
 
  • Like
Reactions: pierro78

japkoslav

Member
Apr 15, 2015
9
1
I had to retrain myself with how to use the finger print scanner. With other phones, I'm used to using the tip of my finger, but that doesn't work with this scanner. As HellRoot describes above, I now lay the flat part of my finger against the scanner so that my finger is parallel to the phone (not pointing at an angle). Now I can get it to work very reliably.

Sadly not working for me at all.
Not to mention I encountered "flip case" bug when the phone is refusing to accept touch screen input to take a call.
This "Sony experience" is much more frustrating than I ever expected and that comes from a guy that used LG V30 for 2 years.
If they do not fix software issues with Android 10 update, I will seriously give it to my mom or wife and buy a propper phone.
 
  • Like
Reactions: Dioser

vlad_kfv

New member
Dec 19, 2019
4
1
My FP sensor worked perfectly for two weeks, I did not get a single "Partial FP detected" and was wondering what's with the bad press.

Then, gradually over the course of a day, it's started playing up. Now I'm in line with everyone else, frustrating experience at less than 20% hit rate. Android 9 or 10 doesn't seem to make a difference, tried factory resetting etc.

Checking the Service Menu (*#*#7378423#*#* from the Dialler --> Service Tests --> Fingerprint Test) returns the following:
Fingerprint Sensor Status:
Sensor not OK
Sensor HWID:
0x0603

I can't seem to find more information on this error code, contacting Sony has returned the typical "Are you running the latest software?" and "Have you tried restarting your device?" :(
 
My FP sensor worked perfectly for two weeks, I did not get a single "Partial FP detected" and was wondering what's with the bad press.

Then, gradually over the course of a day, it's started playing up. Now I'm in line with everyone else, frustrating experience at less than 20% hit rate. Android 9 or 10 doesn't seem to make a difference, tried factory resetting etc.

Checking the Service Menu (*#*#7378423#*#* from the Dialler --> Service Tests --> Fingerprint Test) returns the following:
Fingerprint Sensor Status:
Sensor not OK
Sensor HWID:
0x0603

I can't seem to find more information on this error code, contacting Sony has returned the typical "Are you running the latest software?" and "Have you tried restarting your device?" :(

Right you are! Mine says the same. Has this been posted on the Sony forums?
 
  • Like
Reactions: vlad_kfv

palkia171993

Senior Member
Aug 3, 2011
371
119
Hồ Chí Minh City
My FP sensor worked perfectly for two weeks, I did not get a single "Partial FP detected" and was wondering what's with the bad press.

Then, gradually over the course of a day, it's started playing up. Now I'm in line with everyone else, frustrating experience at less than 20% hit rate. Android 9 or 10 doesn't seem to make a difference, tried factory resetting etc.

Checking the Service Menu (*#*#7378423#*#* from the Dialler --> Service Tests --> Fingerprint Test) returns the following:
Fingerprint Sensor Status:
Sensor not OK
Sensor HWID:
0x0603

I can't seem to find more information on this error code, contacting Sony has returned the typical "Are you running the latest software?" and "Have you tried restarting your device?" :(

I just got mine yesterday, pretty much everything work perfectly except for the fingerprint, and mine also show the same Service Tests info as yours.

When I scan my finger, it usually register only at certain angle, and usually only at my 2nd press on the scanner, which is quite frustrating

I really wonder if this is a software bug or hardware problem so I can have the store replace a new one.
 
Last edited:

yekollu

Senior Member
Mar 19, 2013
188
23
Berlin
I just got mine yesterday, pretty much everything work perfectly except for the fingerprint, and mine also show the same Service Tests info as yours.

When I scan my finger, it usually register only at certain angle, and usually only at my 2nd press on the scanner, which is quite frustrating

I really wonder if this is a software bug or hardware problem so I can have the store replace a new one.

It appears to be Software. I have issues only with unlocking the screen. The Banking apps seem to work fine (for now)
 

palkia171993

Senior Member
Aug 3, 2011
371
119
Hồ Chí Minh City
It appears to be Software. I have issues only with unlocking the screen. The Banking apps seem to work fine (for now)

That's good to hear. I suspect so too because the service tests show everything was fine when I first bought the phone (it was running Pie at the time) and I started upgrading to Q soon afterward. And it was the 2nd day after I upgraded to Q that I notice the service test "Not OK" info.

Hope it can be fixed in the near future update and off topic: hope that update will also include patch for third party launcher to work with Q's Gesture (my most annoyed thing about Q)

Edit: After a few days using it, I realize it recognize the finger really well at certain angles. It never scans well with full finger but almost never miss when I use my finger tip or side. So I guess I can live with it for now. But still hope for improvement soon.
 
Last edited:
  • Like
Reactions: pierro78

palkia171993

Senior Member
Aug 3, 2011
371
119
Hồ Chí Minh City
Well, other Xperias like XZ2, XZ3, XZP just got updated to 10 recently. And, all I've seen so far are complaints about 2 things: no swipe gesture (because the stock launcher hasn't been updated, which is rather stupid) and fingerprint on those devices all become less responsive. It took many times pressing to work, which sounds just like our problem.
So I guess this is a software based problem from Sony's side. Maybe some bad fingerprint driver I guess. Anyway, hope Sony is aware of this and get it fix soon with December security update (also hope for third party launcher patch too)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello,

    I’m using the Xperia 5 since this Wednesday (for two days).
    My overall experience with phone is mostly good (for most parts of using even perfect). Unfortunately, these nice words do not apply for the fingerprint sensor.
    It usually takes 2-5 tries to unlock the phone, sometimes I can’t even open the phone with the fingerprint scanner at all. (The error messages are: Not recognized; could not process fingerprint, please try again. Sometimes it says something with "partial fingerprint").
    I tried rebooting recalibrating the fingerprint with the wizard then rebooting again. Nothing seems to help. I know this doesn’t have to be eventually a defect or something. Fyi, my thumb is not moist or oily, same thing applies for the reader. Maybe my thumb is just too wide, I don’t know.

    What’s your overall experience?

    Jakub
    1
    I had to retrain myself with how to use the finger print scanner. With other phones, I'm used to using the tip of my finger, but that doesn't work with this scanner. As HellRoot describes above, I now lay the flat part of my finger against the scanner so that my finger is parallel to the phone (not pointing at an angle). Now I can get it to work very reliably.
    1
    I had to retrain myself with how to use the finger print scanner. With other phones, I'm used to using the tip of my finger, but that doesn't work with this scanner. As HellRoot describes above, I now lay the flat part of my finger against the scanner so that my finger is parallel to the phone (not pointing at an angle). Now I can get it to work very reliably.

    Sadly not working for me at all.
    Not to mention I encountered "flip case" bug when the phone is refusing to accept touch screen input to take a call.
    This "Sony experience" is much more frustrating than I ever expected and that comes from a guy that used LG V30 for 2 years.
    If they do not fix software issues with Android 10 update, I will seriously give it to my mom or wife and buy a propper phone.
    1
    My FP sensor worked perfectly for two weeks, I did not get a single "Partial FP detected" and was wondering what's with the bad press.

    Then, gradually over the course of a day, it's started playing up. Now I'm in line with everyone else, frustrating experience at less than 20% hit rate. Android 9 or 10 doesn't seem to make a difference, tried factory resetting etc.

    Checking the Service Menu (*#*#7378423#*#* from the Dialler --> Service Tests --> Fingerprint Test) returns the following:
    Fingerprint Sensor Status:
    Sensor not OK
    Sensor HWID:
    0x0603

    I can't seem to find more information on this error code, contacting Sony has returned the typical "Are you running the latest software?" and "Have you tried restarting your device?" :(

    Right you are! Mine says the same. Has this been posted on the Sony forums?
    1
    It appears to be Software. I have issues only with unlocking the screen. The Banking apps seem to work fine (for now)

    That's good to hear. I suspect so too because the service tests show everything was fine when I first bought the phone (it was running Pie at the time) and I started upgrading to Q soon afterward. And it was the 2nd day after I upgraded to Q that I notice the service test "Not OK" info.

    Hope it can be fixed in the near future update and off topic: hope that update will also include patch for third party launcher to work with Q's Gesture (my most annoyed thing about Q)

    Edit: After a few days using it, I realize it recognize the finger really well at certain angles. It never scans well with full finger but almost never miss when I use my finger tip or side. So I guess I can live with it for now. But still hope for improvement soon.