Fire TV HDCP Blank Screen Issues...Any Fix?

jim16127

Senior Member
Jul 18, 2015
58
2
28
Does anyone know how a rooted fire TV could fix this problem? With a xposed framework mod? Or manipulating a system file? I have yet to see a fix other than downgrading. Any ideas?

Here's Elias Saba's article from AFTVNews about this topic. http://www.aftvnews.com/recent-fire-tv-software-updates-causing-blank-screen-issues-related-to-hdcp/

Since update 51.1.6.3 this issue is resolved...here's @rbox prerooted stock roms for the FireTV...
http://forum.xda-developers.com/fire-tv/development/prerooted-stock-images-t2882337
And @AFTVnews.com roms download page...
http://www.aftvnews.com/roms/
 
Last edited:

doctorjei

Member
Oct 25, 2015
9
3
23
Does anyone know how a rooted fire TV could fix this problem? With a xposed framework mod? Or manipulating a system file? I have yet to see a fix other than downgrading. Any ideas?

Here's Elias Saba's article from AFTVNews about this topic. http://www.aftvnews.com/recent-fire-tv-software-updates-causing-blank-screen-issues-related-to-hdcp/

Since update 51.1.6.3 this issue is resolved...here's @rbox prerooted stock roms for the FireTV...
http://forum.xda-developers.com/fire-tv/development/prerooted-stock-images-t2882337
And @AFTVnews.com roms download page...
http://www.aftvnews.com/roms/
This is not yet entirely resolved even in 51.1.6.3, unfortunately. I am using an Onkyo receiver and could only get things working again by reverting to 51.1.6.0. For me, at least, going to 1.6.0 did the trick.
 
I have just spent half a day figuring out why retroarch goes black when trying to play a game. The reason is this hdcp protection that is still present in 5.2.1.1.
I had my aftv connected to a dvi monitor with a hdmi -> dvi connector. Everything worked fine, except retroarch to play games. By chance I plugged it into another monitor with a propper hdmi port, then everything works.
 

Y314K

Senior Member
Dec 29, 2008
1,489
487
0
I have just spent half a day figuring out why retroarch goes black when trying to play a game. The reason is this hdcp protection that is still present in 5.2.1.1.
I had my aftv connected to a dvi monitor with a hdmi -> dvi connector. Everything worked fine, except retroarch to play games. By chance I plugged it into another monitor with a propper hdmi port, then everything works.
Not sure if this option will help. Should be part of the newest update that began to rollout this week.

http://www.aftvnews.com/amazon-fire...able-hdmi-cec-in-new-5-2-4-0-software-update/

Also, maybe there is a system app or service that handles this that you might be able to disable.
 
Last edited: