Fire TV Stick 2 (tank) Prerooted Stock Images [5.2.7.3_r1]

Search This thread

vprasinos

Senior Member
So here's the logcat, after reboot and after debloating. It's significantly less now (only 220kb) and here are the relevant lines, while I perform a pairing process:

D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Discovery has stalled. Assuming discovery did actually start.
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
W/ControllerProvider( 2106): Bluetooth didn't seem to come up. Skip reconciling device list
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Waiting for discovery to begin
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Discovery still hasn't started... trying again
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Discovery still hasn't started... trying again
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Discovery still hasn't started... trying again
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Discovery still hasn't started... trying again
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
W/ControllerProvider( 2106): Bluetooth didn't seem to come up. Skip reconciling device list
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Waiting for discovery to begin
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Discovery still hasn't started... trying again
D/BluetoothAdapter( 2106): 279818164: getState() : mService = null. Returning STATE_OFF
(multiple times)
D/BluetoothUtility( 2106): Discovery has stalled. Assuming discovery did actually start.

and the previous messages repeat over time. Is the bluetooth module dead? Is that why the bluetooth icon appears at the top bar of the wolf launcher and then dissapears just after boot time?
 

vprasinos

Senior Member
I took another logcat some mintues after completely different output. Here it is.

The style of this logcat is like
I/Vitals ( 244): performance:cool_activity_launch_time:KDMv3_Data=[['com.amazon.tv.settings.v2'!574.000000!574.000000!574.000000!1.000000!com.amazon.tv.settings.v2/.tv.controllers_bluetooth_devices.ControllersAndBluetoothActivity!{"d"#{"app_version"#"613035210"}$"m"#{"context"#"S1T0A1D0I0L1E0M0"$"prev"#"com.markus.firetools/.A4Activity"}}!{"d"#{"software_version"#"288.6.4.8_user_648595120"}}]!['com.wolf.firelauncher'!3331.000000!1632.000000!1699.000000!2.000000!com.wolf.firelauncher/.screens.launcher.LauncherActivity!{"d"#{"app_version"#"11723945"}$"m"#{"context"#"S1T0A1D0I0L1E0M99"$"prev"#"null"}}!{"d"#{"software_version"#"288.6.4.8_user_648595120"}}]];DV;1,KDMv3_Unit=ms;DV;1:HI
 

Sus_i

Senior Member
Apr 9, 2013
1,572
666
No it didn't. No combo works for me. How did you find out that my stick tries to pair via wifi?

Only a guess based on your log mate

Code:
I/WifiControllerService( 1057): Group should be active because this ships with a WiFi remote and we've started discovering

D/WifiControllerService( 1057): Waiting for discovery to begin

I/WifiP2pService( 1057): DISCOVER_PEERS peerType =1

I/wpa_supplicant( 1392): P2P: Successfully set hidden SSID to 0 for interface p2p-wlan0-0

E/WifiP2pService( 1057): applyAutoGOHiddenSSIDState: remote_discovery_on=true wps_pbc_on=false wfd_on=false hiddenSSID=false

D/WifiControllerService( 1057): Start Wifi P2P Discovery succeeded

D/WifiControllerService( 1057): Discovery started
 

MiaXiao

Member
Aug 7, 2018
15
0
than
Ok you can try it, but one hint.
My script deletes very much Amazon Apps,
only way back is to reflash Stock rom.
i just want to ask one question like i wanted to downgrade my tank stick to 5.2.6.8 i have done it via trrp but when it starts for the very first time after asking for wi-fi connection it auto download new version and go in recovery and update by itself.Is there anyway to bypass start-up setup after remote connection setup?
 

MiaXiao

Member
Aug 7, 2018
15
0
or somehow if we can disable an APK installation though out system i want to disable any auto APK install after first run any app for that?
 

WoOzGaME

Member
Jul 18, 2017
14
0
Hello, it's possible to install this version on a most recent version of Fire TV OS ? (I have the last version)
 

jbvid

Member
Aug 2, 2017
31
6
Hi
By the 'most recent version' do you mean the Firestick 4k?
You need to be sure which version you have, FireStick 2 (2nd Gen), Fire tv 2, Firestick 4k. then look at the relevant thread about unlocking and root.
jb
 

saurabhshri

Member
Jun 5, 2018
8
0
After installing any of these images (`adb shell twrp install <img.zip`), and doing `adb shell reboot`, generally how long do you have to wait for stick to start. I have tried flashing multiple times, it appears to finish successfully but I do not seem to be able to move past 'FireTV Stick' logo screen. I am not sure if it's the waiting period or I am in a bootloop.

I have created another thread with all the details and logs : https://forum.xda-developers.com/t/...tuck-on-logo-unlocked-twrp-available.4288487/ if you guys can take a look?

Thanks!
 

nitinsawant

Member
May 1, 2011
26
1
how to disable the updates immediately after flashing this rom?
whenever I install this rom and connecting to internet
it is updating to latest version of fire os.
how do i disable the updates from twrp or something like that?
 

aiamuzz

Senior Member
Dec 24, 2011
487
46
@rbox ...

FYI ... I tried to flash the latest Prerooted Stock ROM from the OP ... but I just couldn't log into the amazon prime account on it ... which means i couldn't get past the setup wizard.

STRANGELY though ... I tried logging in with 3 different Amazon Prime accounts ... All 3 accounts returned with Username/Password error ...

HOWEVER WHEN I TRIED TO LOGIN WITH A NON PRIME ACCOUNT, I COULD GET PAST THE PASSWORD SCREEN ONTO THE OTP SCREEN BUT THERE I FAILED IN SPITE OF ENTERING MORE THAN 10 OTP'S AMAZON KEPT MESSAGING ME WITH !!!

I WONDER WHY A NON-PRIME ACCOUNT COULD GO ALL THE WAY TILL THE OTP SCREEN BUT 3 DIFFERENT PRIME ACCOUNTS FAILED RIGHT AT THE USERNAME PASSWORD AUTHENTICATION !!!
 

Top Liked Posts