FireTV Stick 4K cannot find updates or register

Search This thread
Sep 16, 2010
49
5
Bought an older stick from some guy and it couldn't get updates or register (even entering amazon user/pass showed error saying credentials are not correct).

It had TWRP so I thought maybe just needs to be restocked. I first updated the firmware to 6.2.8.9 (still wouldn't work, still same issues) so I decided to get rid of TWRP as well and flashed the boot image. OK TWRP is gone but the issues are still there even after multiple factory resets.

Have I messed it up for good? Any chance to fix it? I since got another 4K stick, brand new, and that one worked like a charm, of course; also my older Fire Cube works fine. So it's not some issue with my network.
 

anphabvn

Member
May 13, 2022
27
2
Bought an older stick from some guy and it couldn't get updates or register (even entering amazon user/pass showed error saying credentials are not correct).

It had TWRP so I thought maybe just needs to be restocked. I first updated the firmware to 6.2.8.9 (still wouldn't work, still same issues) so I decided to get rid of TWRP as well and flashed the boot image. OK TWRP is gone but the issues are still there even after multiple factory resets.

Have I messed it up for good? Any chance to fix it? I since got another 4K stick, brand new, and that one worked like a charm, of course; also my older Fire Cube works fine. So it's not some issue with my network.
you should not remove twrp. Your Firestick is soft bricked
 

Sus_i

Senior Member
Apr 9, 2013
1,602
689
Bought an older stick from some guy and it couldn't get updates or register (even entering amazon user/pass showed error saying credentials are not correct).

It had TWRP so I thought maybe just needs to be restocked. I first updated the firmware to 6.2.8.9 (still wouldn't work, still same issues) so I decided to get rid of TWRP as well and flashed the boot image. OK TWRP is gone but the issues are still there even after multiple factory resets.

Have I messed it up for good? Any chance to fix it? I since got another 4K stick, brand new, and that one worked like a charm, of course; also my older Fire Cube works fine. So it's not some issue with my network.
The stick is most likely blacklisted, common reason is if the device gets reported as stolen... lost on shipping or something like that.

You can still use the unlocked stick, somewhere in the forums is a posting about this. If I recall right, you would need to disable OOBE, set the props for adb enabled, device registered / setup completed. Then the stick boots straight into the fireOS launcher, now you can install a custom launcher...
 

anphabvn

Member
May 13, 2022
27
2
The stick is most likely blacklisted, common reason is if the device gets reported as stolen... lost on shipping or something like that.

You can still use the unlocked stick, somewhere in the forums is a posting about this. If I recall right, you would need to disable OOBE, set the props for adb enabled, device registered / setup completed. Then the stick boots straight into the fireOS launcher, now you can install a custom launcher...
he removed twrp and he have 6.2.8.9. He cant install jailbreak now
 
  • Like
Reactions: Sus_i

Sus_i

Senior Member
Apr 9, 2013
1,602
689
he removed twrp and he have 6.2.8.9. He cant install jailbreak now
That is not true. ;)

He installed 6.2.8.9 via TWRP and a boot.img, so the efuse for shorting may be gone (if he flashed a TZ image update at some point too, which we don't know).

Anyways. TWRP will block flashing preloader/LK and TZ images from the stock rom, so the old vulnerable preloader is still on his stick installed, therefore he CAN install the jailbreak again, that's for sure :)

In order to block the expoit, he need to do at least one update with the stock recovery (which will flash the new preloader). Only that will block the latest kamakiri 2.0.1.
 
  • Like
Reactions: anphabvn

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    The stick is most likely blacklisted, common reason is if the device gets reported as stolen... lost on shipping or something like that.

    You can still use the unlocked stick, somewhere in the forums is a posting about this. If I recall right, you would need to disable OOBE, set the props for adb enabled, device registered / setup completed. Then the stick boots straight into the fireOS launcher, now you can install a custom launcher...
    he removed twrp and he have 6.2.8.9. He cant install jailbreak now
    1
    he removed twrp and he have 6.2.8.9. He cant install jailbreak now
    That is not true. ;)

    He installed 6.2.8.9 via TWRP and a boot.img, so the efuse for shorting may be gone (if he flashed a TZ image update at some point too, which we don't know).

    Anyways. TWRP will block flashing preloader/LK and TZ images from the stock rom, so the old vulnerable preloader is still on his stick installed, therefore he CAN install the jailbreak again, that's for sure :)

    In order to block the expoit, he need to do at least one update with the stock recovery (which will flash the new preloader). Only that will block the latest kamakiri 2.0.1.