Firmware for Carplay AI Boxes (Qualcomm/Rockchip/Allwinner) Android 7/9

Search This thread

JPN_friday

Member
Apr 30, 2022
10
3
Hello everyone,
I received my new CP-308 device yesterday, and after testing it i were really disappointed, there are so many issues which i hope you guys have some information on how to solve them biggest issues are:
1. Its very slow and flickery and buggy! it takes long time to load the maps and videos
2. while running the screen becomes black and stops responding, i had to restart it many times
3. when i connect my phone using Android Auto the resolution is low and blury and big audio lag from connected mobile
4. When i play music the audio quality is very bad, its mono, its being played on the car as if it was a phone call not media

i think all those issues are software fixable so if they can be fixed! specially number 3, 4

More details:
Car: MG RX8 2021
Mobile: Oneplus 10 Pro
Unit firmware version:
22.05.16.1027.X-JMA.V5.5.9
20220516.222905
Unit model: https://www.aliexpress.com/item/1005003913043015.html?spm=a2g0o.order_list.0.0.21ef1802vtmWbB
I ordered this yesterday. On Android 11, SDM450, 4G network, memory is 4GB and 64GB.
 

magikweis

Member
May 7, 2010
16
0
Europe
I do have a QCM6125 device (Xyingly, linked in FAQ on page #1) running the HCTBox software linked here:


I noticed that whatever newer fimrware I try to install (by putting the firmware as update.zip on an SD, update is detected and device reboots to start the actual update), the update process never actually installs the never firmware. After a couple minutes, when I unplug and replug the device it still runs the firmware I had installed before.


Is there a way to work around this? Do I need to downgrade to a certain version?

I read in the Telegram channel that several people had the same behavior but never read about how to fix it.
 

magikweis

Member
May 7, 2010
16
0
Europe
try this firmware
Thanks. What makes you think this firmware might solve the problem I described?
This zip you linked includes the same firmware with identical hash, but the ZIP from the the firmware I have installed includes an additional directory with a QQ-102649259.txt file - thats the only difference.
 

Attachments

  • 2022-06-10 12_26_10-Clipboard.jpg
    2022-06-10 12_26_10-Clipboard.jpg
    206.4 KB · Views: 46

nthydro

Member
Nov 7, 2011
6
0
I do have a QCM6125 device (Xyingly, linked in FAQ on page #1) running the HCTBox software linked here:


I noticed that whatever newer fimrware I try to install (by putting the firmware as update.zip on an SD, update is detected and device reboots to start the actual update), the update process never actually installs the never firmware. After a couple minutes, when I unplug and replug the device it still runs the firmware I had installed before.


Is there a way to work around this? Do I need to downgrade to a certain version?

I read in the Telegram channel that several people had the same behavior but never read about how to fix it.
I had the exact same issue and tried multiple firmware versions until I found one that worked. If you look under 'Build Number' in Settings it should tell you at the end which region your current firmware is (NA, EU, ect). Mine is NA. I was able to find one that specified it was the NA version thanks to the links on the first page. I'm guessing the previous ones I tried that failed were for other regions.
 

karkoura

Member
Jun 19, 2006
29
0
I had the exact same issue and tried multiple firmware versions until I found one that worked. If you look under 'Build Number' in Settings it should tell you at the end which region your current firmware is (NA, EU, ect). Mine is NA. I was able to find one that specified it was the NA version thanks to the links on the first page. I'm guessing the previous ones I tried that failed were for other regions.
i have tried this one, and it worked fine
 

txminh

Member
Jan 11, 2022
7
1
I do have a QCM6125 device (Xyingly, linked in FAQ on page #1) running the HCTBox software linked here:


I noticed that whatever newer fimrware I try to install (by putting the firmware as update.zip on an SD, update is detected and device reboots to start the actual update), the update process never actually installs the never firmware. After a couple minutes, when I unplug and replug the device it still runs the firmware I had installed before.


Is there a way to work around this? Do I need to downgrade to a certain version?

I read in the Telegram channel that several people had the same behavior but never read about how to fix it.
HCTbox firmware or carlinkit is illegally for QCM6125. I tried to upgrade but could not completely. Pls try Cartizan.
 

txminh

Member
Jan 11, 2022
7
1
Hello, I recently purchased a U2 Plus from Ottocast (https://www.ottocast.com/products/picasou-ai-box-ottocast). I used the Android AI box functionality to try to simultaneously play music from my phone, and also use a mapping software, such as Google Maps or Waze, to tell me directions. Playing music is fine...until the mapping software tries to tell me directions. The music will stop playing through all the speakers (I'm guessing it starts playing through all 11 speakers of my 2022 RAV4 Hybrid XSE, and then only plays through 4 of them), and then plays the direction, then it will "reset" and the music will play through all of the speakers in my car.

I'm guessing that this may be an issue that may be resolved with a firmware update? I tried emailing the manufacturer but haven't received a response. This is a PICASOU box with the following information:
Device name: X7
Model: X7-NA-00-00
Android version: 9
Build number: X7-NA-00-00

Does anyone know where to verify if I have the latest firmware version, and if I have an outdated firmware version, where to find an updated firmware version for Ottocast U2 Plus?

Alternatively, has anyone encountered this issue before and purchased a different Android AI Box that does not have this issue? (I'm within the return period for this unit)
have to setup navigation on setting function. belong to your device, you should find this function on setting >> ottocast setting... You must chose GG maps or Waze is navigation apps.
 
Last edited:

bliznik

New member
Apr 5, 2016
4
0
have to setup navigation on setting function. belong to your device, you should find this function on setting >> ottocast setting... You must chose GG maps or Waze is navigation apps.
Oh, I actually resolved this. It's a weird setting in Google Maps and in Waze on these devices. I'm unsure why it works this way.

In Waze, the default setting is Settings->Voice & Sound->Play sound to phone speaker. With these boxes, if this flag is turned on, the box will pipe any sound playing through your speakers through a different, filtered mode, and then will output the navigation instruction, and then will pipe the sound playing through your speakers through the normal mode.

If you turn off Settings->Voice & Sound->Play sound to phone speaker, the device won't do that anymore.

In Google Maps, the default setting is Settings->Navigation Settings->Google Assistant settings->Hey Google->While driving is turned on by default. The same behavior will occur when this flag is turned on. If you turn this flag off, then the device won't do that anymore.

Strangely, this doesn't occur in all cars, only in some cars. It must be an issue with the way the device communicates with the car via Apple Carplay. Very weird behavior.
 

mrbogusbaxter

Senior Member
May 26, 2006
104
68
Is there any way to prevent the Carlinkit AI Box Mini (CPC200) from automatically showing up in the car's infotainment screen? I simply want it to boot normally upon starting the car, but not being shown on-screen until I select Carplay from my cars main menus.

Thanks
Yes, you can. Go into settings and look for boot-up option/startup option. You should see an option names for your head unit or car entertainment system.
 

magikweis

Member
May 7, 2010
16
0
Europe
HCTbox firmware or carlinkit is illegally for QCM6125. I tried to upgrade but could not completely. Pls try Cartizan.
I tried the Cartizan firmware from AFH and was able to upgrade.
Unfortunately that changed the navbar from the side to the top which I´m not sure I really like.
THanks for the advice though!
 

txminh

Member
Jan 11, 2022
7
1
I have one Carplay AI box PLC-S21 (as link). I tried to upgrade CPC200 carlinkit firmware and t-box but could not completely. This firmware is the exclusive software of CarlinKit TBox that lock something

1. Installed OTA.apk

2. CPC200 carlinkit firmware: system said that illegal manufacturers (fault).

3. T-box firmware: system said that image is erro.

Just wait Cartizan firmware. I wrote email to Cartizan but nobody reply.

My device is PLC-S21:
 

karkoura

Member
Jun 19, 2006
29
0
-----------------------------------------------
The seller from Aliexpress sent me the newest firmware file (Attached), after the successful upgrade everything is ok so far, still testing. The attached firmware for PLC-S21 box version with Snapdragon QCM6125.
what is the firmware version date ? android 10 ? can u take a shot?
 

Top Liked Posts