• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Firmware] Unbrick & restore Galaxy Tab 3 7in SM-T210R

Search This thread

gian20

Senior Member
Apr 19, 2013
91
7
Manila
my SM-T210 is hard bricked it was I think fully drained. THen the device wont boot anymore, no downlloadmode, odin, recovery no LIFE. It only shows this if plugged in a Windows machine:
dm.jpg

On a Linux PC:

Code:
$ dmesg
[ 8587.060023] usb 1-1: new full-speed USB device number 19 using uhci_hcd
[ 8587.227045] usb 1-1: New USB device found, idVendor=1286, idProduct=8164
[ 8587.227054] usb 1-1: New USB device strings: Mfr=3, Product=2, SerialNumber=0
[ 8587.227059] usb 1-1: Product: EMEI
[ 8587.227063] usb 1-1: Manufacturer: MARVELL
$lsusb
Bus 001 Device 019: ID 1286:8164 Marvell Semiconductor, Inc.

any idea on how to fix this. what is the resistor setup?

Anybody can help me here? can someone post a bootloader that can be burned to a microSD for this device? SM-T210
ref : https://forum.xda-developers.com/att-galaxy-s6/help/create-debrick-img-stock-rom-t3367325

so i have made my own USB jig (I tested it on my SM-T285 and it went to FACTORY DOWNLOAD MODE) but the SM-T210 is still dead (black screen) still being detected as Marvell EMEI device
 
Last edited:

xdausernl

Member
Feb 22, 2019
44
4
Amersfoort
mkservices.nl
Same problems here while trying to Flash SM-T210

Scrap that, I was able to get it into download mode! What threw me off was there are no pictures! From powered off state I press and hold Home+VolDown+Power, and if I watch really closely the backlight comes on but the screen is empty and black. If I press Vol Up from there I get the download mode with the white text at the top left corner saying "ODIN MODE" etc., but still no picture. Strange!

Anyway next issue: I connect it to Odin 3.09, COM port connects fine, I pick my firmware file linked in the first post, Auto Reboot and F.Reset Time ticked, Re-Partition NOT ticked -- and I get this:
Code:
<ID:0/004> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> T210RUEU0CNI1_T210RXAC0CNI1_HOME.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/004> Odin v.3 engine (ID:4)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> SingleDownload.
<ID:0/004> PBL.bin
<ID:0/004> NAND Write Start!! 
<ID:0/004> FAIL!
<ID:0/004> 
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
Does it mean the NAND is broken? Will I have to throw it away? :eek:

I also tried older versions of Odin v1.87, that gave me the exact same problem as v3.09 with NAND write failure and v1.3 stock at PBL.bin
Yet my Tab3 7.0 8GB has WiFi only, so the chipset would differ from the ones with WiFi and 3G/LTE.
So I was wondering if there's a seperate stock ROM for those tablets with WiFi only, which in that case may explain the cause of trouble, right?
There's also this problem with PIT ... 'get PIT for mapping', is that in any way related to the failures during flashing?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 32
    [Firmware] Galaxy Tab 3 7in SM-T210R

    How to restore your Samsung Galaxy Tab 3 7in wifi tablet with odin and the stock firmware. Unbrick your device

    Directions [NOTE] make sure your battery is fully charged before starting this process.
    Download files listed to your computer
    UPDATED LINK WITH ALL Firmware in one easy spot HERE
    1. http://www.sammobile.com/firmwares/1/?model=SM-T210R&pcode=0#firmware or MK1 Firmware to fix screen flicker
    2. ODIN 3.07.ZIP
    3. Samsung drivers
    extract the drivers and install.
    extract odin 3.07 program to desktop
    extract firmware to desktop
    Enter download mode / odin mode on the tablet from a powered off state.
    Press and hold power, home, and volume down. you will see a warning screen then press volume up to continue
    Now the device is in download mode. plug in usb cable to computer and device and let the drivers install give it 3 minutes
    run odin 3.07 and wait to see the com port connect.
    Click on pda button in odin and find the firmware file you extracted to your desktop and select it
    press start and wait for device to finish the flash and reboot.
    Thats it you just restored the firmware on your device.

    Link to samsung mobile firmware
    http://www.sammobile.com/firmwares/1/?model=SM-T210R&pcode=0#firmware

    How to video linked here VIDEO
    3
    Hey guys. Downloading the firmware now and when's it's done I'll put it on my Dropbox account for you guys to download from there.

    Sent from my SM-T210R using Tapatalk

    OP has been update with the new firmware to fix the flickering screens :)
    Either firmware can be found here
    http://rootjunkysdl.com/?device=Galaxy Tab 3 7in&folder=Firmware
    sent from my Galaxy Note 3 running HyperDrive.
    2
    It's the "program will install the drivers for your device" part that I can't get past. How? Thank you for attempting to help me!
    It's okay. files that will leave here, is all I can give you, download the executable file and install it on your computer, "NOTE" is not necessary to connect the device to your computer, the program will install the drivers for the device, after finish installing drivers, download and run odin, now put your tablet into download mode then press the start button, vol -, and power, when the warning message appears, press vol +, now connect the device to your computer, odin should detect your device, the rest I guess you already know to do, right ?.
    2
    Make sure you get the new firmware

    Here is the link to the new firmware that will fix the screen flicker problems
    MK1 Firmware

    Sent from my SM-N900V using Tapatalk
    1
    Question, does this remove cwm?

    Sent from my Galaxy Nexus using XDA Premium 4 mobile app

    It should restore the entire device even stock recovery