• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Fix] [7.0] Samsung Account Login Password Loop and SHealth after Rooting on Nougat

Search This thread

x7nofate

Senior Member
Apr 12, 2011
433
25
Samsung Galaxy Note 9
Beacuse Samsung pass is not working on rooted devices did anyone check does other autofill services work with on rooted devices? Samsung pass is very useful feature and it could be great if we could replace Samsung Pass with other autofill app.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    Hi all
    As you know Samsung Recently released android 7.0 Nougat update for Galaxy S6 And Galaxy Note 5
    Those who have updated to 7.0 and after that managed to get Root access, must face a problem, i.e when they tried to login to their samsung account, it never happened, samsung account page keep requiring password again and again falling in a loop even entered and giving error session expired.
    I figured out it and now presenting you the solution.
    Simply install 2 attached APKs and reboot the device.
    1: Samsung Pass
    2: Samsung Account
    after reboot, open samsung account (e.g galaxy apps, themes), select sign in,after entering details only once a Toast will appear and you will see you have successfully logged in..voila
    Screenshot_20170319-135631.png
    Note: If you are unrooted and have same problem it'll also work for you (Tested)

    If you still face the issue then You need to reset the data of Samsung account for example using Titanium Backup along the path Backup/Restore/Samsung account/Wipe data (Thanks @VIP1961 for tip)
    10
    [Fix] [7.0] S Health App Compromised Error on Nougat:
    1) Flash TWRP using odin,
    2) Flash supersu using TWRP (Dr Ketan Script)
    3) Edit system/build.prop, set ro.config.tima to 0 save and reboot
    4) Open SHealth at least once makes sure knox error is gone.
    10
    Please help me, do you have any other solution?
    You need to reset the data of Samsung account for example using Titanium Backup along the path Backup/Restore/Samsung account/Wipe data
    2
    The Samsung account apk don't install. When I install say the apk is damaged.

    Enviado de meu SM-G920I usando Tapatalk
    1
    Worked for Samsung Account, but not worked the same for Samsung Pass :/

    In my case the Samsung Account app from the first post showed to be invalid but I downloaded this version (newer) ( i can't post links so delete the space before a dot:
    apkmirror . com/apk/samsung-electronics-co-ltd/samsung-account/samsung-account-2-2-03-71-release/samsung-account-2-2-03-71-android-apk-download/
    then cleared cache from samsung pass just for safety and restarted device.

    It still didn't work fully, (in settings i was logged in but it wasn't syncing and when i tried to download new mods for camera app i was asked to login, so i did, it passed but immidately pushed me back to login window so it was still stuck), but i found out i had blocked Shealth and Svoice apps so i enabled them again, went to camera app, logged in without an issue and was able to download stuff.

    Hope it helps

    I have installed the Noble ROM and I can't sync my Samsung account, could I fix this problem with this two APK? Keep in mind that I can access the Galaxy Apps and download apps and so for the other samsung app. The only things I can't do is syncing the account

    :(Yeah same happened with me...:D but there is a workaround for that.... just install es file explorer then open it then allow root then go to system/priv-app/SamsungAccount_Dream/ then delete the apk present there.... Rename the apk you downloaded from this thread to "SamsungAccount_Dream.apk" and copy paste it to folder system/priv-app/SamsungAccount_Dream/ then set the permission to rw-r-r... then Reboot...........

    then just install the downloaded apk normally it will install this time without any error... it worked for me :good:
    it is for the samsung account apk as i faced error when installing that only... same procedure may work for samsung pass apk too.... just look in system/priv-apps /SamsungPass_1.1 and do the same as above

    Not working for me. It says package corrupt. Tried wiping days with titanium, but no go.

    Make sure to update these apps through Galaxy Apps and then when Session has Expired appears just use Titanium Backup and delete Data of Samsung Account. Sign in again and no more session expired.