[Fix added] [HOW TO] [UPDATED] Install Android apps on Windows 10 Mobile

Not open for further replies.
Search This thread


Senior Member
Dec 31, 2009
Wow, I see that in time WP will resurface if not publicly but from devs here in XDA!!! This has potential imagine google apps boy I'd switch to windows anytime!!!. It just reminds me of that HD2 thread...


Nov 15, 2009
I really hope someone figures out how to get Play Services running. I tried pulling the apps out of the gapps package, and installing the important ones, but no go. I'm assuming every app is sandboxed individually, so it probably isn't possible.


Senior Member
Mar 13, 2012
allready got es file explorer , but how to copy from windows to android , push thru adb? or something else possible?

Create a folder using file explorer (for example Android) then search it . when you find it in search results click on it .
ok now on the top of app you can see MainOS(c:) . tap on this and navigate this address :
Data\Users\DefApps\APPDATA\Local\Aow\mnt\shell\em ulated\0
here is the android apps directory .
also you can see Android\obb here for apps data .
I tried to install Clash of clans on my l920 but I can see only my troops and ground .
buildings are hidden . any way to figure it out ?


Senior Member
Sep 26, 2012
Cincinnati, OH
I tested a few apps, I'll post the status of their usability here.

Icom's RS-MS1A - App requires google services for the maps, unable to select an image from onedrive (Phone complains that this feature is not yet implemented.) App complains about "Your device does not have Bluetooth implemented."

Echolink - I can sign into the app, but I can't connect to *ECHOTEST*. Doesn't matter which setting I pick for connection in the app, it won't connect.

APRSdroid w/ OpenStreetMap - Application works perfectly over TCP mode. Switch over to AFSK mode. Transmission occurs via speaker, but selecting the "start tracking" feature, it displays errors in the log about the microphone.

Sling TV - App gets stuck loading.

Testing more as I install them.


Senior Member
Just installed four apps: Instagram, Swarm, Snapchat and Casper (=Snapchat alternative). I couldn't get Facebook to be installed...

- Instagram works well, but hangs when trying to add a filter on a previously saved photo (no cam support). But it is fun to have the real "Instagram feel" back in your hand...
- Swarm: works, checks in, can see mayorships, but there's a UI bug.
- Snapchat: stuck on "verifying device" and thus unusable
- Casper: loads snaps correctly, but can't post any because it's not supported yet (confirmed by Casper developer).


Dec 21, 2008
So I got a few apps deployed, now adb just seems to hang when attempting to deploy. Anyone else experience this?

Edit: I had to unpair, repair, unpair, repair and now it works. I think one of the APKs I downloaded caused this.
Last edited:


Senior Member
Jun 11, 2012
Guide to fix error 14:

Hard reset.
DO NOT put the account microsoft (for now).
Open settings> security update> for developers; click on the "Developer mode" and confirm.
Head on Windows Update and searches. It should say "No updates available".
Head on the Store;
Download Windows Insider;
It tells you to put a Microsoft account, do it.
Click on, on and on and is expected to start the download. (after the hard reset will be downloaded about 32 apps, cancels all but Microsoft Visual C ++ and Windows Insider).
Open Windows Insider and select the ring fast. Confirm it.
Go to Windows Update and to search. It should pick you out "Developer Enhancements".

this is interesting.. will this enable devices not on the initial supported list?
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 71
    Before you start, keep in mind that this may damage your device. I wouldn’t recommend trying this, but if you really want to, you can feel free to do so at your own risk.

    Here is the list of supported devices:
    •Nokia Lumia 920
    •Nokia Lumia 925
    •Nokia Lumia 929 (icon)
    •Nokia Lumia 830
    •Nokia Lumia 930
    •Nokia Lumia 1520
    •Nokia Lumia 635 (1GB RAM variant)
    •Nokia Lumia 730
    •Nokia Lumia 820
    •Nokia Lumia 435
    •Nokia Lumia 928

    A. If you have one of the above devices, you are ready to go!​
    Method 1(older, harder, but still functional)
    1. Download both files from here.
    2. Unzip both of the files on the folder
    3. Open the folder wconnect, then install IpOverUsbInstaller.msi and vcredist_x86.exe
    4. Go to your Windows 10 Mobile’s Settings page, then head over to Update & Security > For Developers and enable Developers Mode, as well as Device Discovery
    5. Now go to the extracted wconnect folder, then open an elevated command prompt (Shift+right click > Open command window here)
    6. After that, you’ll need to connect to the phone — and there’s two way of doing that (USB method is recommended): ◦If you want to connect using USB, type "wconnect.exe usb" and hit enter
    6.1 And if you want to connect over Wi-Fi, type wconnect.exe 192.168.xxx.xxx (replace the xxx with your network’s IP)

    7. Then it’ll ask for the pairing code, just type the pairing code and hit enter
    8. After that, navigate to the extracted adb folder and open an elevated command prompt
    9. To make sure that your device is connected, type adb devices and hit enter to show the list of devices that are connected
    10. Lastly, place the APK file that you want to install on the same directory (adb folder) and type in adb install APKNAME.apk (replace APKNAME with the APK file’s name)
    11. Just wait for it to do its thing and you should be able to install the Android app on your Windows 10 device

    Method 2 (new, noob-proof)
    1. Download the files here and extract them anywhere
    2. Install "IpOverUsbInstaller" and "vcredist_x86"
    2. Run "APKDeployment.exe"
    3. On your phone go to "Settings/Update & Security/For developers" and enable "Developer mode" and "Device discovery" then press "Pair"
    4. Connect your phone to USB, insert the code you got earlier from your phone, into APKDeployment app, then press pair. Your phone should appear as "emulator_555x on USB"
    5. Now that you're paired, you can simply drag .apk's into the application then choose to deploy all.

    Method 3 (even simpler)
    1. Download the package from here and install it.
    2. Follow app instructions.

    Method 4
    Install APKtoWin10m
    Download Windows Bridge
    On your pc go to "C:\Users\USERNAME\AppData\Roaming\APKTOW10M\connect" then extract the "Windows bridge" contents there. When asked, replace all files.
    That's it, the tool should be fixed.
    Credits go to @alb3530.

    1. Do not disconnect the device while an apk is installing.

    2. Do not reboot while your phone has Developer Mode Activated

    C. Errors you might encounter and how to fix them.
    1. Status 9 - connection problem
    If this happens, unregister you device using "Windows Phone Developper Registration 8.1", tool provided alongside Windows Phone 8.1 SDK, or download the lite version from here.Afterwards you will be able to access Developer settings again. Or Hard reset, your choice.
    If the method above did not help, another fix is to go to device manager and uninstall these drivers [(coresponding to your device) also delete them if asked] then refresh, and let Windows reinstall them.

    2. Status 14 - device not supported
    Either your device is unsupported or you haven't installed "Developer Enhacements" update
    To install Developer enhacements update, install Windows Insider from Store and Enroll, then check phone updates. It should show up there.

    3. Developer menu crashes, wconnect app hangs
    If this happens, unregister you device using "Windows Phone Developper Registration 8.1", tool provided alongside Windows Phone 8.1 SDK, or download the lite version from here.Afterwards you will be able to access Developer settings again. Or Hard reset, your choice.

    4. Notification toggles flashing
    Just reboot, but remember to disable Developer Mode first.

    This is for newest build!

    1. After wconnect open CMD and
     adb push FILENAME /data/local/tmp
     adb shell
     chmod 644 /data/local/tmp/FILENAME if file is .apk (chmod 755 if this is busybox file, and 6755 if this is su file)
    (Ofc replace "APKNAME" too file name that you want to copy to system partition)
    2. After this go to phone file explorer, press search button and type "c" and open "Documents".
    3. Press arrow in right top for back to "C:".
    4. Now go to C:\Data\Users\DefApps\APPDATA\Local\Aow\Data\Local\Tmp and copy previously sideloaded files to
    a) C:\Data\Users\DefApps\APPDATA\Local\Aow\RootFS\system\APP if you want install apk to system partition
    b) C:\Data\Users\DefApps\APPDATA\Local\Aow\RootFS\system\BIN if you want install binares
    4. Reboot phone.

    Sorry for my bad english. I just want to help
    Use this tool to patch apps with google play services and install them on your phone........ Have Fun

    If you can edit build.prop, GPS can run smoothly. I tried, but nothing :/ It's impossible for now.

    Ok, i have working Google Play Services and obv Google Play Store too :)
    Guys, this project is dead. The OP hasn't been online for 3 months, and Microsoft have pulled Astoria from the latest Win 10 builds..

    I shall close this thread to avoid any confusion or causing issues with devices. OP can contact me if he wants it opened again :)