[FIX] AdHoc Wifi support on the NC!

Search This thread

cicada

Senior Member
Nov 7, 2009
173
153
Denver, CO
Great news everyone! </farnsworth>

ADHOC Wifi Support for Nook Color (stock)!

[EDIT] There appears to be an issue reconnecting when wifi sleeps and comes back on. Researching a permanent fix, in the meantime go to settings -> Wireless and toggle wifi off/on to correct it


This fix will allow you to connect to ADHOC wireless networks ( such as to a laptop or with wifi-tether on an android phone )

Like most other fixes, this requires your nook to be rooted and usb adb working, please follow the guides here and/or at the nook dev wiki first!:

Rooting: http://nookdevs.com/NookColor_Rooting
USB-ADB: http://nookdevs.com/NookColor_USB_ADB



HOWTO enable ADHOC tethering:

1. Download and unzip the attached zip file below, this should give you a wpa_supplicant-adhocfix file

2. *DISABLE WIFI ON YOUR NC*

3. Make a backup of your current wpa_supplicant:
Code:
adb pull /system/bin/wpa_supplicant  wpa_supplicant.backup


4. Remount the /system partition RW:
Code:
adb shell mount -o remount,rw /dev/block/mmcblk0p5 /system

5. Push the new wpa_supplicant:
Code:
adb push wpa_supplicant.adhocfix /system/bin/wpa_supplicant

6. Fix permissions:
Code:
adb shell chmod 755 /system/bin/wpa_supplicant

7. Remount the /system partition RO:
Code:
adb shell mount -o remount,ro /dev/block/mmcblk0p5 /system

8. Enable WIFI on your NC, you should now be able to see ADHOC networks in the list! ( they'll be displayed with a (*) prefix )


[edit] Credit where credit's due, this was taken from a wpa_supplicant IBSS patch I found via a Google search, if anyone knows the party responsible, let me know so I can credit them properly!

http://szym.net/android/


This is compiled against TI's Omapedia Eclair sources ( http://omappedia.org ) - since this is a different framework than the B&N stock build, I can't guarantee this will work, won't brick your device, etc. Use at your own risk!

If you encounter any problems, please use this thread to let us all know.


That's all there is to it, enjoy!
 

Attachments

  • wpa_supplicant-ncadhoc.zip
    132.8 KB · Views: 7,313
Last edited:

Bimboy

Senior Member
Dec 5, 2006
493
97
Cool you figured this out! For some reason, I've been able to use the adhoc network on my Androidized HTC Leo (HD2) since the first time I tried, even before rooting.
 

edison

Senior Member
Jul 21, 2007
70
10
Confirmed working with Mobile Wi-Fi Router on my VZW Touch Pro2.

Many thanks! Another big step!
 
Last edited:

karmastorm

Member
Dec 3, 2010
6
0
My NC is stuck at trying to obtain an IP address from my Droid 1. I'm using Barnacle.

Any ideas?

*edit*

It took several attempts but it finally connected. Being able to get connected anywhere is awesome. Thanks for posting this!
 
Last edited:

tokyomonster

Senior Member
Feb 20, 2009
400
18
Houston
Working great from my epic 4g.

Pro Tip: If you want a quick way to toggle wifi (and a few other settings) tap the clock in the nook's notification bar for a quick settings dialog.
 

cicada

Senior Member
Nov 7, 2009
173
153
Denver, CO
Thanks for this. I can now use my nook at work tethered to my phone. You may want to edit the typo in step 7 as we all caught it but someone may not.

Thanks for noticing, corrected the extra 'o' :)

As noted in the OP, this is based on TI's omap eclair reference sources, and there *is* a pretty glaring bug.

Basically, if your screen goes to sleep, waking it back up triggers a wifi-reconnect which fails to reinitialize the network properly. Your wifi settings will show 'Connected, no internet' when this happens.

Toggle Wifi off/on to fix this, I'm working on a permanent fix right now and will update when it's working.

Thanks everyone for testing and boosting the ol' ego a little ;)
 
  • Like
Reactions: Spookymonster

lintmail

Member
Sep 1, 2010
28
2
Some random tips so folks don't repeat the same mistakes I made while doing installing the ad hoc feature.

Don't choose to "forget" a wireless access point because then it doesn't appear again even if the device sees it. You'll have to manually enter the SSID, encryption type, and password to get it to work properly.

While mounting and remounting using adb, if you get a device busy error, disconnect the nook from the computer and come back to it later. Then reconnect and try again. For good measure I also powered down the nook. Not sure what happens if you leave the system folder mounted as RW, but I suspect bad things could happen.

Oh and the fix works like a charm. This is one really nice device.
 

rogerdugans

Senior Member
Dec 8, 2010
134
12
Nice work, and thank you. Working fine with another rooted droid (running CM6.1).

I had the "device busy" error and went ahead and unplugged, then reset to ro with Root Explorer- no problems.

This reminds me of when the Droid first got rooted- took a little while to make progress but every few days that would be another BIG, popular advance.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 33
    Great news everyone! </farnsworth>

    ADHOC Wifi Support for Nook Color (stock)!

    [EDIT] There appears to be an issue reconnecting when wifi sleeps and comes back on. Researching a permanent fix, in the meantime go to settings -> Wireless and toggle wifi off/on to correct it


    This fix will allow you to connect to ADHOC wireless networks ( such as to a laptop or with wifi-tether on an android phone )

    Like most other fixes, this requires your nook to be rooted and usb adb working, please follow the guides here and/or at the nook dev wiki first!:

    Rooting: http://nookdevs.com/NookColor_Rooting
    USB-ADB: http://nookdevs.com/NookColor_USB_ADB



    HOWTO enable ADHOC tethering:

    1. Download and unzip the attached zip file below, this should give you a wpa_supplicant-adhocfix file

    2. *DISABLE WIFI ON YOUR NC*

    3. Make a backup of your current wpa_supplicant:
    Code:
    adb pull /system/bin/wpa_supplicant  wpa_supplicant.backup


    4. Remount the /system partition RW:
    Code:
    adb shell mount -o remount,rw /dev/block/mmcblk0p5 /system

    5. Push the new wpa_supplicant:
    Code:
    adb push wpa_supplicant.adhocfix /system/bin/wpa_supplicant

    6. Fix permissions:
    Code:
    adb shell chmod 755 /system/bin/wpa_supplicant

    7. Remount the /system partition RO:
    Code:
    adb shell mount -o remount,ro /dev/block/mmcblk0p5 /system

    8. Enable WIFI on your NC, you should now be able to see ADHOC networks in the list! ( they'll be displayed with a (*) prefix )


    [edit] Credit where credit's due, this was taken from a wpa_supplicant IBSS patch I found via a Google search, if anyone knows the party responsible, let me know so I can credit them properly!

    http://szym.net/android/


    This is compiled against TI's Omapedia Eclair sources ( http://omappedia.org ) - since this is a different framework than the B&N stock build, I can't guarantee this will work, won't brick your device, etc. Use at your own risk!

    If you encounter any problems, please use this thread to let us all know.


    That's all there is to it, enjoy!
    4
    Lets try this again... Maybe I can attach a zip file...

    If this works, there will be two zip files...

    I have found that the Adhoc enabled wpa_supplicant file didn't play nice with respect to wifi sleep policy.

    View attachment wpa_supplicant.backup.zip is the original Nook Color wpa_supplicant file.

    View attachment switch-adhoc.zip contains the original wpa_supplicant, the adhoc enabled wpa_supplicant and two scripts, adhoc and infrastructure.

    Instructions for using the second:

    unzip the file to a work directory on your computer.

    adb shell mount -o remount rw /system
    adb push wpa_supplicant.infrastructure /system/bin
    adb push wpa_supplicant.adhoc /system/bin
    adb push adhoc /system/bin
    adb push infrastructure /system/bin
    adb shell chmod 755 /system/bin/wpa_supplicant.infrastructure
    adb shell chmod 755 /system/bin/wpa_supplicant.adhoc
    adb shell chmod 755 /system/bin/adhoc
    adb shell chmod 755 /system/bin/infrastructure
    adb shell mount -o remount,ro /dev/block/mmcblk0p5 /system

    After this is done, you can switch back and forth between the original and the adhoc enabled wpa_supplicant by starting a shell on the Nook Color and running the following commands:

    To switch to adhoc mode:
    su
    adhoc


    To switch to infrastructure mode:
    su
    infrastructure

    Hope this helps people out.
    3
    Sorry for the long absence- family drama a couple of hours away.
    While witing around in the midst of it I was able to get the adhoc/infrastrure scripts installed and partially tested completely on the nook using Root Explorer and terminal.

    I downloaded the files on my droid, pulled the microsd out and put it in the nook. Copied them to My Files and pulled the card back out (mount/unmount properly of course.)

    I unzipped the scripts and used Root Explorer to make /system/bin rw.
    Copied the files into /system/bin
    Started a terminal session and typed su and then went to that directory-

    su
    cd /system/bin
    ls

    (ls to make sure the files are there.)

    and then
    chmod 755 /system/bin/wpa_supplicant.adhoc
    chmod 755 /system/bin/wpa_supplicant.infrastructure
    chmod 755 /system/bin/adhoc
    chmod 755 /system/bin/infrastructure

    Used Root Explorer to make /system/bin ro again.

    For good measure I rebooted the nook- in the terminal: reboot

    After the reboot I opened terminal and did
    su
    adhoc

    and I was able to connect to the wireless tether on my Droid. :)

    Unfortunately I did continue to have problems with dropping the connection- finally told the screen to not time out for an hour and that seemed to take care of that. I was able to download 2 books into the Android Kindle software over the tether.

    I just got home and have not yet checked infrastructure mode.

    ETA:

    I just spent a couple of minutes in infrastructure and I'm still having issues- connect and in about 30 seconds I get lost signal- connected, no internet.
    rebooted, switched wifi on and off a few times and reran the infrastructure script a few times- no change.
    1
    Thanks for this. I can now use my nook at work tethered to my phone. You may want to edit the typo in step 7 as we all caught it but someone may not.

    Thanks for noticing, corrected the extra 'o' :)

    As noted in the OP, this is based on TI's omap eclair reference sources, and there *is* a pretty glaring bug.

    Basically, if your screen goes to sleep, waking it back up triggers a wifi-reconnect which fails to reinitialize the network properly. Your wifi settings will show 'Connected, no internet' when this happens.

    Toggle Wifi off/on to fix this, I'm working on a permanent fix right now and will update when it's working.

    Thanks everyone for testing and boosting the ol' ego a little ;)
    1
    Original nook wpa_supplicant

    Here ya go...

    OK. Maybe I can't upload files.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone