[FIX]BootLoop while Offline[Switched-Off] Charging Xperia MiNi Pro [Rooted ICS]

Search This thread

mohdaqib17

Senior Member
May 31, 2012
91
46
Lucknow
Hi,

Are You experiencing bootloop [on-off] every time when you plug-in your phone to the charge when it is switched-off... ??
This problem may have occurred after rooting your Mini Pro on Ice Cream Sandwich ?

Solution to this problem :

[1] Download and extract the Charger.zip file in the attachments.
[2] Copy the extracted charger file to your phone SD card.
[3] Use X-Plore or Root explorer to copy the charger file on SD card to system\bin\ [Just Replace It] on phone memory.
[4] Done ! No Need to reboot..

This Method has been tested on my Xperia Mini Pro and its working !! :)

Attachments:
View attachment charger.zip
 
Last edited by a moderator:

DragonClawsAreSharp

Senior Member
Nov 1, 2011
587
1,129
Hi,

Are You experiencing bootloop [on-off] every time when you plug-in your phone to the charge when it is switched-off... ??
This problem may have occurred after rooting your Mini Pro on Ice Cream Sandwich ?

Solution to this problem :

[1] Download and extract the Charger.zip file in the attachments.
[2] Copy the extracted charger file to your phone SD card.
[3] Use X-Plore or Root explorer to copy the charger file on SD card to system\bin\ [Just Replace It] on phone memory.
[4] Done ! No Need to reboot..

This Method has been tested on my Xperia Mini Pro and its working !! :)

View attachment 1115131

What? Rooting will not cause that I suppose. It might be CWM which is disabling offline charging. That is possible. I will test soon and report back.

Edit:
Okay. I just now checked. It's true. Offline Charging is not working with ICS when CWM is installed at /system as in nAa's method. Will ask some more users to test.

Thanks,
Rick

Sent from my SK17i using XDA
 
Last edited:
  • Like
Reactions: NullUser

paulo13pdm

Senior Member
Mar 30, 2012
137
31
that problem also persists in my rooted LWW, hope this works.

EDIT: Charging while phone-off now works! Don't forget to change the permissions.
 
Last edited:

android addicts

Senior Member
Jan 8, 2012
1,051
96
I root my Sony Live With Walkman phone, when I received ICS update. That mean two or one months ago. So for no issue. Today I installed CWM recovery using SE Extreme Tweak toolkit. After that I wipe battery stats. Now I face this issue. I think its CWM issue, not rooting.

Yes, this method fix it. Thanks friend.

Sent from Tapatalk. Please excuse my brevity.
 
Last edited:

madhouses

Senior Member
Apr 25, 2012
169
21
Is for sure cwm issue. I installed cwm via market and even w/o wipe battery stats this happend.
And ofc this works nice

Sent from my ST15i using xda app-developers app
 
Last edited:

botski

Senior Member
May 12, 2010
1,687
97
offline charging usb i think its not working.
Oopps, I think the problem within my kernel. :D
 
Last edited:

sugabagus

New member
Apr 11, 2013
2
0
offline charging

heloo, i just install Revolution ICS "http://forum.xda-developers.com/showthread.php?t=2139252"at my Minipro SK17i, and offline charging not work, and with your problem solving it didn't work too, because when i accsess the system/bin, there is no "charge" file.can you help me with my problem?

thank you
 

sshivampp

Senior Member
Sep 18, 2012
223
165
New Delhi
heloo, i just install Revolution ICS "http://forum.xda-developers.com/showthread.php?t=2139252"at my Minipro SK17i, and offline charging not work, and with your problem solving it didn't work too, because when i accsess the system/bin, there is no "charge" file.can you help me with my problem?

thank you

If you are on stock ICS kernel, just install cwm from xparts. It works fine for me on lww ICS rooted and ofcourse offline charging is working fine. And nAl's recovery is also working fine with working offline charging. Maybe the problem is the custom kernel you flashed !!
 

sugabagus

New member
Apr 11, 2013
2
0
If you are on stock ICS kernel, just install cwm from xparts. It works fine for me on lww ICS rooted and ofcourse offline charging is working fine. And nAl's recovery is also working fine with working offline charging. Maybe the problem is the custom kernel you flashed !!

i use Lupus Kernel and tried Kappa Kernel, and it have same problem.hmm, okay i think i'll install cwm from xparts,or change the kernel
 

kratosbala

New member
Mar 20, 2013
2
0
Xperia Mini not charging

My ST15 not charging via both AC and USB :(:(:(
no response while connecting to PC but charging only while playing music:(:(
Please help!!!
 

hadriellimah

New member
Aug 10, 2012
3
0
LwW doesn't charge

I installed cwm on my LwW by the xparts app. And it worked. I used the phone for like one hour, and the battery was about 50%. I puted it on charger for a whole night, the phone was on. But it turned off somehow, and now my battery is completely drained. I try to put the charger and turn it on, but when gets to homescreen, it turn off. Without the charger, the led blinks red and doesn't turn on. What should I try?

-Edit
I tried to charge the battery with an universal charger, and it is now with 55%, and I copied the file to the directory, and now it appears to be charging while phone is off, but not increase the percentage. And when its on, the thunder under the battery is there, but the led isnt orange, nor the system shows that's charging. Do you know what it could be?
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    Hi,

    Are You experiencing bootloop [on-off] every time when you plug-in your phone to the charge when it is switched-off... ??
    This problem may have occurred after rooting your Mini Pro on Ice Cream Sandwich ?

    Solution to this problem :

    [1] Download and extract the Charger.zip file in the attachments.
    [2] Copy the extracted charger file to your phone SD card.
    [3] Use X-Plore or Root explorer to copy the charger file on SD card to system\bin\ [Just Replace It] on phone memory.
    [4] Done ! No Need to reboot..

    This Method has been tested on my Xperia Mini Pro and its working !! :)

    Attachments:
    View attachment charger.zip
    1
    Hi,

    Are You experiencing bootloop [on-off] every time when you plug-in your phone to the charge when it is switched-off... ??
    This problem may have occurred after rooting your Mini Pro on Ice Cream Sandwich ?

    Solution to this problem :

    [1] Download and extract the Charger.zip file in the attachments.
    [2] Copy the extracted charger file to your phone SD card.
    [3] Use X-Plore or Root explorer to copy the charger file on SD card to system\bin\ [Just Replace It] on phone memory.
    [4] Done ! No Need to reboot..

    This Method has been tested on my Xperia Mini Pro and its working !! :)

    View attachment 1115131

    What? Rooting will not cause that I suppose. It might be CWM which is disabling offline charging. That is possible. I will test soon and report back.

    Edit:
    Okay. I just now checked. It's true. Offline Charging is not working with ICS when CWM is installed at /system as in nAa's method. Will ask some more users to test.

    Thanks,
    Rick

    Sent from my SK17i using XDA
    1
    Is this method supposed to be device-independent? I'm facing the same issue on my Android Galaxy Player.

    No as far as I know it's not device independent and it will only work on our 2011 xperia mdpi devices :)