[FIX] for Nand USB Init Failed

Search This thread

ntatschner

Member
Jan 16, 2010
15
32
Hello Guys/Girls,

As I was struggling with this I though I would share the info to help people get NAND Android installed.

Firstly if you are getting the below message you are most likely missing a couple of file's in the same directory called EnterBootloader and rapitool (which I have included in this post)

"Error Description: USB init failed
Info: .\RSPL\RSPL.cpp (723)"

Simply place those file in the same Directory as the DAF.exe file and vola it should now start the flashing from the DAF.exe file.

I hope this helps.

***
If you are running XP Go to control panel and then active sync while connected in MAGLDR while it states Wait USB...USB and un-check Allow USB then right click the DAF.exe and run as Admin, that should allow you to install.

***
Nigel
 
Last edited:

Dam4rusxp

Senior Member
Aug 27, 2010
101
64
Oh yeah I understand. That seems to be a bug of the DAF installer. These files normaly get removed after the RUU has run. And they also do in the DAF installer.
THANK YOU!
 

monyozt

Senior Member
Mar 18, 2008
1,416
101
kudus
still not working
72798390.png
 

vensterbank

Senior Member
Nov 21, 2010
328
49
Baarn
this aint working for me, its like my pc aint fiding my phone. or the bug fix doesnt help.
however i can use diskdrive mode and htcsync works. so i dont get it.

im just trying to get the new kernel on my stock desire nand.
plz help,
 
  • Like
Reactions: sai2000

nbhadusia

Senior Member
Dec 13, 2009
396
53
London
I was getting the same error. I took these three steps, and all is now working - im not sure if all three 3 steps contributed to success, or any one of them - but taking these measures definately worked for me (im running Windows XP by the way)
The phone should be connected to the PC at all times during these steps.



1) Install MAGLDR using admin rights. This was done by right clicking the Magldr.exe and selecting 'run as', then clicking 2nd option, signing in as a user with admin rights.

2) Open ACTIVESYNC, 'File', then 'Connection Settings' - UNCHECK 'Allow USB connections' Reboot phone

3) Right clicking 'DAF.EXE' file and running with admin rights (like it was done in Step 1 above). Click Next, next untill its searching for USB connection

4) On phone, select option 4.

hopefully, it should all now work

Hope this helps.
 

mojacho

New member
Mar 19, 2009
4
0
try your method....
but still error msg come out..
[Error happen
Read below for more information

Error Description: send partition data failed
Info: .\RSPL\RSPL.cpp (802)

Error Description:
Info: .\RSPL\RSPL.cpp (545)

it only process till half way..
using windows xp..
 

slbenz

Senior Member
Mar 9, 2009
616
70
Silicon Valley
Getting same error here even with the suggested fixes. Ran as administrator, added the missing files and still the same USB init error. I am using the correct HSPL and radio files. Could it be the Windows XP laptop that I am using? Will try my other laptop running Vista and report back.
 

Prinz069

Senior Member
Jul 19, 2008
3,201
1,210
FUNK-Furt
www.xda-zone.de
This may could be a solution for a couple of us flashers:

After flashing the NAND Android rom to the Leo I deleted the WinMo device Center which includes all the drivers for the device.

Now I installed the device center again and was able to flash ! :)
 
  • Like
Reactions: opeter

Petegonz

New member
Jul 22, 2010
2
4
I know a solution, on the little Active Sync Menu, after MAGDLR recognizes that it's connected, I mean when you get on the phone screen: USB...USB

Go to file, connection settings and uncheck allow USB connections. After this run the DAF.exe, it should work normally. (xp users)
 
Last edited:

lonewolf1972

Senior Member
May 29, 2010
215
4
Brooklyn Ny
I have vista, and I had the same problem, but when you read the dft 1st screen, READ ALL INFO TILL YOU GET TO THE BOTTOM OF THE PAGE, THEN CLICK NEXT. THIS WORKED FOR ME AND ALSO OPEN EVERYTHING IN ADMIN MODE!!!
 

dbrown8099

Member
Apr 14, 2010
10
0
I was having the same issue. I downloaded the NAND version from the DFT and the NAND from CMN 6.1 v.1.01. I replaced all the files from CMN with with the files from DFT so that I didn't use DAF. The problem is DAF. Just load Android with another Launcher.
 

theglenman

Member
Feb 22, 2010
13
0
loading nand

Restart Phone hold down power button and when you get to MAGLDR menu use Vol. down and choose option 4 by pressing Red button(bottom right). Then goto computer and right click DAF.exe and run as administrator and this sould work.
 

slbenz

Senior Member
Mar 9, 2009
616
70
Silicon Valley
Well, I used my Vista computer instead of my XP computer to redo the install. Saw on another thread that a person used the ANDR_INSTALL execution file from the NAND CM6.1_1.02 build to replace the DAF execution file of the current NAND build they were trying to upload. In my case it was Cmylxgo's NAND build. Started from scratch and now I was able to load Cmylxgo's NAND build properly. Not sure if it was not using an XP computer or replacing the DAF file with the ANDR_INSTALL file from another build but it worked for me. Now to see what the battery drain and use is vs. the JNF WM ROM, MDJ Froyo 4.6 build with Hastarin 8.6 kernel that I have been using.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 30
    Hello Guys/Girls,

    As I was struggling with this I though I would share the info to help people get NAND Android installed.

    Firstly if you are getting the below message you are most likely missing a couple of file's in the same directory called EnterBootloader and rapitool (which I have included in this post)

    "Error Description: USB init failed
    Info: .\RSPL\RSPL.cpp (723)"

    Simply place those file in the same Directory as the DAF.exe file and vola it should now start the flashing from the DAF.exe file.

    I hope this helps.

    ***
    If you are running XP Go to control panel and then active sync while connected in MAGLDR while it states Wait USB...USB and un-check Allow USB then right click the DAF.exe and run as Admin, that should allow you to install.

    ***
    Nigel
    4
    I know a solution, on the little Active Sync Menu, after MAGDLR recognizes that it's connected, I mean when you get on the phone screen: USB...USB

    Go to file, connection settings and uncheck allow USB connections. After this run the DAF.exe, it should work normally. (xp users)
    3
    Hi there.
    For those who are under Windows7, whatever it is x86 or 64, it does not matter.
    Just right click on the program DAF.exe, and select "Compatibility Mode", then select it to work with Windows XP SP2/SP3, and then, apply the changes.
    Restart the program, it then should work (it did for me :) )

    For those who are on Windows Vista, it should be the same :)
    3
    xp users...try the below installer instead od DAF...delete DAF and place this file and start install as normal..

    http://www.mediafire.com/?qgmxgu6gacq0vvi
    2
    I was getting the same error. I took these three steps, and all is now working - im not sure if all three 3 steps contributed to success, or any one of them - but taking these measures definately worked for me (im running Windows XP by the way)
    The phone should be connected to the PC at all times during these steps.



    1) Install MAGLDR using admin rights. This was done by right clicking the Magldr.exe and selecting 'run as', then clicking 2nd option, signing in as a user with admin rights.

    2) Open ACTIVESYNC, 'File', then 'Connection Settings' - UNCHECK 'Allow USB connections' Reboot phone

    3) Right clicking 'DAF.EXE' file and running with admin rights (like it was done in Step 1 above). Click Next, next untill its searching for USB connection

    4) On phone, select option 4.

    hopefully, it should all now work

    Hope this helps.