[FIX] Google Play Services Idle Battery Drain Issue Solved

Search This thread

venky716

Senior Member
Sep 9, 2011
989
722
Disable these two services using Disable Service App. That's it, nothing more!



bfcf2280094132ad3076977deac39060.jpg




GoogleLocationManagerService

GoogleLocationService




Full Service Name:

com.google.android.location.internal.GoogleLocationManagerService
com.google.android.location.internal.server.GoogleLocationService


My Idle drain which was around 20-30 even with Wifi Data etc off was down to single digits with Wifi and data ON.


3071104baed83d58ff85d4a39873c4c8.jpg




Other things I've tried and failed :



Deny Wake Up and Keep Awake permissions to GPS.

Greenify GPS , this only works for a short while but as soon as GPS is back online battery drain also comes back.

Get servicely to kill GPS.

Uninstall and reinstall GPS from play store.

Clear GPS data.

And a few more that I can't remember.




WARNING :

THIS WILL ESSENTIALLY BREAK LOCATION SERVICES.
If you don't use location, well and good.

If you do, you'll have to re enable these two services every time you want to use Maps or any app that uses location.
I use Tasker to re enable them whenever the app launches.

I've attached two apps for enabling and disabling these two services, you can use them as shortcuts whenever you want to enable or disable the two services.

Also attached xml files of the tasks that you can import into tasker. Profile condition should be whatever apps that use location when launched. Use Enable service task as enter task and disable task as exit task.

Minor bug I noticed with Google Maps, enable the two services and turn on Location then launch app, but it won't show you your location sometimes, exit app clear it from recents launch again to get it working.
 

Attachments

  • LocationManagerOff.2.apk
    1.9 MB · Views: 7,636
  • LocationManagerOn.2.apk
    1.9 MB · Views: 5,947
  • tasks.zip
    1.1 KB · Views: 4,442
Last edited:

on&off

Member
Sep 3, 2012
21
25
Thank You and Queries

This has helped the most of all the "Fixes" I have tried. Makes a very drastic difference. It's appalling that Google or it's Dependants would wan't to know your Location at such great cost to battery-life. It would have been great if switching the Location On and Off switch in Settings automatically Enabled and Disabled these services for the user.

Any particular reason why your Application has to keep monitoring in the background? Both Enable and Disable keep running for me. Couldn't they exit after they are done?

Thank You in any case for your work.
 
  • Like
Reactions: mirbx

venky716

Senior Member
Sep 9, 2011
989
722
This has helped the most of all the "Fixes" I have tried. Makes a very drastic difference. It's appalling that Google or it's Dependants would wan't to know your Location at such great cost to battery-life. It would have been great if switching the Location On and Off switch in Settings automatically Enabled and Disabled these services for the user.

Any particular reason why your Application has to keep monitoring in the background? Both Enable and Disable keep running for me. Couldn't they exit after they are done?

Thank You in any case for your work.

It doesn't keep monitoring in the background, at most it'll get cached for a while.

There should be no side effects.
 

venky716

Senior Member
Sep 9, 2011
989
722
PSA: I recently disabled google location history and the drain seems to have lowered to 10mAh, without having to disable those two services.
Just thought others could try the same and see if it helps.

Enable location, then turn off location history.

Google settings - Personal info & privacy - Activity controls - Location history.

I kept location on for a day in battery saving mode then turned it off.
 

Sauronych

Senior Member
Dec 20, 2014
56
35
PSA: I recently disabled google location history and the drain seems to have lowered to 10mAh, without having to disable those two services.
Just thought others could try the same and see if it helps.

Enable location, then turn off location history.

Google settings - Personal info & privacy - Activity controls - Location history.

I kept location on for a day in battery saving mode then turned it off.
The drain was definitely there even with Location History off before I disabled the services. Perhaps they fixed the issue with a GPS update? Although everything I know about Google tells me that's highly unlikely.
 

venky716

Senior Member
Sep 9, 2011
989
722
The drain was definitely there even with Location History off before I disabled the services. Perhaps they fixed the issue with a GPS update? Although everything I know about Google tells me that's highly unlikely.

I don't know if Google has fixed it, but I saw lower drain recently.
Not as low as with the services disabled but still acceptable.
 

cr0wnest

Senior Member
Jun 29, 2010
1,010
164
Singapore
Have you ever used the privacy guard to deny these services ??

Sent from my A0001 using Tapatalk

I have and it doesn't work anymore with the recent play services update. What a shame, it used to be such an easy fix! I'll try the methods OP stated and see how it goes. Play services have been plaguing me for far too long!
 

Horizon2100

New member
Sep 28, 2015
2
2
@venky716

You are my hero!!!
After all the romours what actually cause the battery drain by google play service, thats the real reason!

With the privacy guard fix sometimes there was less battery drain, sometimes it was more, but with this fix my phone almost not losing battery in standby at all! And with Tasker its so easy and I don't have any problems with google maps or here maps.
Thanks alot!!! :cowboy:
 
  • Like
Reactions: venky716

Horizon2100

New member
Sep 28, 2015
2
2
Yeah, you should think it would be so easy ;)
Without turning off this services you will still have this battery drain. Maybe Google is still checking your location even if you turn it off or its just that play services wakes up the phone only to find out that there is no location to check. :eek:
 
  • Like
Reactions: venky716

venky716

Senior Member
Sep 9, 2011
989
722
Why not just turn off location until you need to use it? Isn't this just doing the same thing just a lot more clicks and time involved?



? Good Luck and GOD BLESS!! ?
I keep location disabled at all times but found that this service was still active all the time and disabling it immediately brought down the idle drain.
So if I want to use maps with gps, will this fix affect me?

Enviado desde mi Oneplus One
Yes it will, with the services disabled you won't be able to use maps.
In order to use maps you'll have to re-enable the service, either by tasker or desktop widget shortcuts provided in the OP, before using maps.
Read the OP again carefully [emoji14]
Especially the last part about maps.
 

elargento

Senior Member
Feb 10, 2011
113
18
I keep location disabled at all times but found that this service was still active all the time and disabling it immediately brought down the idle drain.

Yes it will, with the services disabled you won't be able to use maps.
In order to use maps you'll have to re-enable the service, either by tasker or desktop widget shortcuts provided in the OP, before using maps.
Read the OP again carefully [emoji14]
Especially the last part about maps.
Sorry I asked the wrong question. I meant if I use the phone's gps for offline navigation apps like Viago or navmii.

Enviado desde mi Oneplus One
 

Top Liked Posts

  • There are no posts matching your filters.
  • 47
    Disable these two services using Disable Service App. That's it, nothing more!



    bfcf2280094132ad3076977deac39060.jpg




    GoogleLocationManagerService

    GoogleLocationService




    Full Service Name:

    com.google.android.location.internal.GoogleLocationManagerService
    com.google.android.location.internal.server.GoogleLocationService


    My Idle drain which was around 20-30 even with Wifi Data etc off was down to single digits with Wifi and data ON.


    3071104baed83d58ff85d4a39873c4c8.jpg




    Other things I've tried and failed :



    Deny Wake Up and Keep Awake permissions to GPS.

    Greenify GPS , this only works for a short while but as soon as GPS is back online battery drain also comes back.

    Get servicely to kill GPS.

    Uninstall and reinstall GPS from play store.

    Clear GPS data.

    And a few more that I can't remember.




    WARNING :

    THIS WILL ESSENTIALLY BREAK LOCATION SERVICES.
    If you don't use location, well and good.

    If you do, you'll have to re enable these two services every time you want to use Maps or any app that uses location.
    I use Tasker to re enable them whenever the app launches.

    I've attached two apps for enabling and disabling these two services, you can use them as shortcuts whenever you want to enable or disable the two services.

    Also attached xml files of the tasks that you can import into tasker. Profile condition should be whatever apps that use location when launched. Use Enable service task as enter task and disable task as exit task.

    Minor bug I noticed with Google Maps, enable the two services and turn on Location then launch app, but it won't show you your location sometimes, exit app clear it from recents launch again to get it working.
    3
    Thank you for this fix, the issue was driving me nuts. Every other fix I've tried turned out to be only temporary, but after following your instructions the drain seems to be gone for good.
    3
    Well, I had a similar problem: with Google play services enabled my phone (SM-N9005) Note3 (Still on Android 4.3) never went to deep sleep.
    Yesterday I tried this: I disable the service, then deleted the contents of the directory /data/data/com.google.android.gms/ leaving just the directory, then I uninstalled google play services updates and reinstalled the latest version.
    Now my phone sleeps again.
    So I think this problem is due to some corruption that happens over time in that directory.
    I have now google play services ON, location services on, gps on. and battery drain is minimal.
    2
    Sorry haven't replied for so long, forgot this existed.

    Thank you for posting this solution. I have a Galaxy S7. Is there anyway to make the Tasker tasks work without root? I can't have root installed on my phone in order to use my corporate email app. When I try to run the tasks I receive an error message about root access.

    No, to disable services you need root.
    Disabling those two services just brings up a Google Play services has stopped working box after exiting out of Maps. One time it didn't show an OK button so had to force a restart. I'm on Marshmallow if that matters

    Yes that could happen, play services is updated constantly this method may break something in play services that was updated after my testings.

    Thanks for the solution! Brilliant!

    How did you know it was those two services/modules that were doing all the battery drain? That screenshot of the battery monitor widget attached doesn't show the module that is drawing the power. I want to do some poking about in the modules and see what other modules are drawing my power.

    Thanks.

    Installed a bare minimum rom with no apps and checked idle drain with screen off, then disabled the services and checked again. Immediately saw a significant change.
    I also did this multiple times over a few days, that being said i do not use this anymore because i don't have battery drain from google play services anymore.

    Other minor things you can do to reduce google play services drain are:
    1. Go into location settings, disable location history.
    2. Disable google now cards and its notification. I use google now too but it starts random wakelocks and alarms from time to time and haven't found a solution to it.
    3. Disable wifi scanning from location.

    Also stop stressing so much about battery life, I have.
    Anyways no matter what you do Pokemon Go will anyways suck your battery dry, so there's no point :D
    2
    PSA: I recently disabled google location history and the drain seems to have lowered to 10mAh, without having to disable those two services.
    Just thought others could try the same and see if it helps.

    Enable location, then turn off location history.

    Google settings - Personal info & privacy - Activity controls - Location history.

    I kept location on for a day in battery saving mode then turned it off.