• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Fix] Jelly Bean SMS Warning Dialog

Search This thread

jokesonme

Senior Member
Oct 21, 2012
211
63
Las Vegas
Thanks!

eris was referring to this:

http://forum.xda-developers.com/showpost.php?p=31608815&postcount=34

It shows it is there as of the 14th. We can't really support CM. You may want to ask a maintainer for them.

Thanks guys! Got it all figured out. After X number of years gave up Apple, iPhones and Jailbreaking (after returning the iPhone 5), and am now starting my Android journey. So quite the nooblet with all the new processes. This forum is definitely helpful and I look forward to be a contributing member!
 

InMyBedNow

Senior Member
Sep 10, 2011
115
13
I can't seem to get the flashable zip to work. I'm running CM10M2 and it doesn't show in the app drawer. When I use solid explorer, I can find the APK in /data/app but it doesn't show in the drawer. Installing it manually using the APK doesn't work either since Cm10 blocks it. Any ideas?
 

adrynalyne

Inactive Recognized Developer
Dec 13, 2008
10,950
6,471
I can't seem to get the flashable zip to work. I'm running CM10M2 and it doesn't show in the app drawer. When I use solid explorer, I can find the APK in /data/app but it doesn't show in the drawer. Installing it manually using the APK doesn't work either since Cm10 blocks it. Any ideas?

Once again, CM10 should have included this option already. See the post just above yours.
 

plitshec

Member
May 2, 2011
16
5
Edmonton
Where to find SMS message Limit setting...

I have checked throughout the build and can not find such setting. I am on the most recent nightly build from the 20th. Do you know where said setting is? I see lots of forum posts from other users with the same problem, this is just the only one with a solution sadly it does not work for me. Or can someone on CM10 confirm if this works for them or they get the Bamf App Icon after installing?

Has been in CM10 since the Oct 14 Nightly...

Look for this in Settings - > Security -> SMS messageLimit (last setting in the list)
 

pioneer5555

New member
Nov 4, 2012
2
0
Hi I really pretty much need unlimited sms. Could you make this app for unlimited sms too or could you please explain how to do it? I know the settings.db file must be changed but I am running BAMF paradigm on my Galaxy Nexus and the data/data/android.providers.settings folder only has settings.db-shm, settings.db-wal, and settings.db.temp and sqlite will not open them.
 

Weedalot

Senior Member
Apr 23, 2011
628
140
Edit settings.db. add the line that is highlighted and reboot.

View attachment 1281428

Sent from my Galaxy Nexus using Tapatalk 2

It's not a menu. You have to manually edit it using sqlite. It's located in data/data/com.android.providers.settings/databases

Sent from my Galaxy Nexus using Tapatalk 2

using sqlite i see system and secure in that database file. i dont have the "sms_outgoing_check_limit_max" value at all. ive installed the app and it added it to "secure" field under that database.
however how can that be that i had this popup msg without having the field as well. i am going to spam 100 msgs to see if it worked or i am still on 100 and report back. hope you can answer me how come i didnt have this value

anyways i am on slimbean 2.9 on SGS I

---------- Post added at 11:20 PM ---------- Previous post was at 11:16 PM ----------

using sqlite i see system and secure in that database file. i dont have the "sms_outgoing_check_limit_max" value at all. ive installed the app and it added it to "secure" field under that database.
however how can that be that i had this popup msg without having the field as well. i am going to spam 100 msgs to see if it worked or i am still on 100 and report back. hope you can answer me how come i didnt have this value

anyways i am on slimbean 2.9 on SGS I

ok didnt even have to spam 100 sms, i changed the value to 5 rebooted and it worked!!! now going to test 0, see if it will make it unlimited or ask from first one.

anyways than you very much!!!!!

---------- Post added at 11:24 PM ---------- Previous post was at 11:20 PM ----------

using sqlite i see system and secure in that database file. i dont have the "sms_outgoing_check_limit_max" value at all. ive installed the app and it added it to "secure" field under that database.
however how can that be that i had this popup msg without having the field as well. i am going to spam 100 msgs to see if it worked or i am still on 100 and report back. hope you can answer me how come i didnt have this value

anyways i am on slimbean 2.9 on SGS I

---------- Post added at 11:20 PM ---------- Previous post was at 11:16 PM ----------



ok didnt even have to spam 100 sms, i changed the value to 5 rebooted and it worked!!! now going to test 0, see if it will make it unlimited or ask from first one.

anyways than you very much!!!!!

ok dont do 0 :) just make it like gazilion and you are golden now i made it 9999999 and it works great.
 

htv

Member
Dec 21, 2007
10
0
Help Please: Samsung Galaxy S3 - How to disable this annoying sms warning?
Sometimes I am sending 3000 SMS in 30 minutes.
Could you walk me through the process?
I have rooted my phone so I can access any folder.
Is any way to modifying the quota? Where do I have to go?
Please help, need this desperately. Thank you. THV
 

Mailo85

Member
Apr 11, 2012
17
1
Has Google raised the limit now with 4.2? Because I don't have the issue after 30 SMS anymore. It doesn't prompt me. My bootloader is unlocked, but not rooted and with stock JB 4.2.1 yakju
 

BretonGirl

Senior Member
Jun 4, 2012
301
109
The Big Apple
Help Please: Samsung Galaxy S3 - How to disable this annoying sms warning?
Sometimes I am sending 3000 SMS in 30 minutes.
Could you walk me through the process?
I have rooted my phone so I can access any folder.
Is any way to modifying the quota? Where do I have to go?
Please help, need this desperately. Thank you. THV

First of all, you need to post in the correct section. This is the Galaxy Nexus section. Second, 3000 texts in half an hour? That's like 50 texts a minute. You're obviously using a bot. That reeks of spammer. People like you are probably why the security feature is in place to begin with. Stop being a text spammer and you won't get the warning.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 25
    Some of you may have noticed in Jelly Bean, that if you text a lot, it tells you to knock it off with an annoying little dialog. Although I applaud Google's efforts to alert us to possible unwanted behavior from a malicious app, they may have been a bit overzealous with their thresholds.

    JRO03H had a limit set of 100 messages in 30 minutes, which probably kept all but the most avid texters in the clear. However, when we merged to JRO03L last week, it had dropped to 30 in 30 minutes. Personally, I think it was a typo and should have been 300, but either way, it triggered on me so I set out to fix it.

    That being said, it is corrected in the next build of Paradigm and committed to our public source for any dev that needs to fix it for their own ROM. However, in the meantime, I made a nifty little app that will fix it. It very simply writes a new maximum value to the settings database upping the maximum to 500 messages. The fix is "permanent" until you clear data. After that, it would need to be applied again.

    There are two versions of the app, one signed with BAMF keys for our ROM, and the other signed with AOSP keys which should work fine on almost every other ROM. If not, have your favorite developer resign it with their keys and I'll add a link to the post. This fix should work on ANY Jelly Bean ROM for ANY device, but is completely untested outside of the Galaxy Nexus.

    Please note, you are essentially disabling a security feature put in by Google, and we CANNOT be held responsible for any adverse effects this may have on your device.


    Download for BAMF ROMs: http://www.teambamf.net/files/file/39-bamfsmsfix-bamf-keysapk/

    Download for AOSP ROMs: http://www.teambamf.net/files/file/40-bamfsmsfix-aosp-keysapk/

    Flashable zip for CM based ROMs that prevent install: http://www.teambamf.net/files/file/41-smsfixapkflasherzip/
    4
    How do you do this manually?

    Edit settings.db. add the line that is highlighted and reboot.

    uploadfromtaptalk1345873324090.jpg

    Sent from my Galaxy Nexus using Tapatalk 2
    2
    Updated here: http://forum.xda-developers.com/showthread.php?t=2039351 [APP][ROOT][4.0+] SMS Limit Tool

    Sent from my Galaxy Nexus using Tapatalk 2
    1
    Well I'm on the international gsm version using stock jb from that should that not be the same as aosp? Sorry I'm a little confused

    Thanks for this awesome fix in either case

    Sent from my Galaxy Nexus using xda premium

    It's the same, but if it's from the carrier, they use their own keys.

    Sent from my Galaxy Nexus using Tapatalk 2
    1
    SMS limit manual removal for 4.2.1

    Edit settings.db. add the line that is highlighted and reboot.

    View attachment 1281428

    Sent from my Galaxy Nexus using Tapatalk 2


    I tried to modify the table secure and have no effect.
    I triend to find the variables from the picture and found them in the global table instead of the secure one.
    So I added the values to the table global instead of the secure one and it works!
    I am using 4.2.1
    I hope this help some people.