[FIX][SOLVED]Status 7 Error with CWM or TWRP Recovery on Rooted Android!

How U like my 1st post?

  • Awesome

    Votes: 196 53.6%
  • Not bad

    Votes: 51 13.9%
  • Good

    Votes: 76 20.8%
  • Awful

    Votes: 43 11.7%

  • Total voters
    366
Search This thread

klebson.guerra

New member
Dec 3, 2020
1
0
Hi.

I had deleted the "assert" lines and error 7 continued for me.

It worked when I restarted the phone via REBOOT from the TWRP itself, clicking on the RECOVERY option. I did it after the WIPE.

The phone restarted, I chose the same file that was giving error before, and everything worked fine.

Hope this helps.
 
Last edited:
Oct 10, 2021
8
0
E1001: Failed to update system image.error: 1001

I had this error, and followed this guide, and then encountered a new error (well, two, actually). Below are the steps I followed to resolve them.

Code:
Invalid zip file format!
I was getting this error because I zipped the folder that was created when I unzipped the file. So, if I opened my newly-created zip file, the first thing I saw was a folder named "lineage-16.0-20200705-nightly-kltedv-signed" inside it, instead of the folders "install", "META-INF", "system", etc.

The "install", "META-INF", "system", etc. folders should be at the top level of the zip file.

I recreated the zip file by selecting all the files inside the "lineage-16.0-20200705-nightly-kltedv-signed" folder, rather than zipping the folder itself. This fixed the issue, getting me to the second error:

Code:
creating stash /cache/recovery/5a79362318d00cf4c316e86435b3ed38dd35082d/
script aborted: mkdir "/cache/recovery/5a79362318d00cf4c316e86435b3ed38dd35082d/" failed: No such file or directory
E1001: Failed to update system image.
mkdir "/cache/recovery/5a79362318d00cf4c316e86435b3ed38dd35082d/" failed: No such file or directory
E1001: Failed to update system image.error: 1001
cause: 101
[B][COLOR="Red"]Updater process ended with signal: 11
Error installing zip file '/external_sd/lineage-16.0-20200705-nightly-kltedv-signed.zip'[/COLOR][/B]

I was able to fix this issue by formatting the Data partition.
Although I had already done a wipe of the System, Dalvik, and Cache, I hadn't wiped the Data partition.
You can do this by selecting Wipe > Format Data and then typing "yes" to confirm.

Once the internal memory had been formatted, I was able to successfully install the new ROM.

Note: Doing this will wipe your files and data from the phone! Make sure you have a backup, first!
This helped, thanks
 

BazilALi2132

New member
May 29, 2022
1
0
I'm with a strange issue here.
I Can't change my recovery!

I'm on CWM 6.0.4.5 (updated of 5.8.0.4) and i'm trying to update but with no success.

First was showing the error 7 and with this tutorial and others posts it was solved.

Now the installation finishes but nothing happens. Rebooting recovery and continue with 6.0.4.5.
Even latest versions (which not have the error) is not installing. I mean, the installation finishes but no recovery is installed.

Someone has passed through this?
have you found any solution???
I am getting the same problem
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    When installing certain custom ROMs on rooted Android smartphones or tablets, you will encounter “Status 7″ error issues once in awhile with ClockworkMod (CWM) Recovery.

    Status 7 error is caused while the ROM’s updater script file checks to see if the phone model of your phone is compatible with the ROM you are installing, called “asserts”.

    “Asserts” is a safety mechanism so you don’t accidentally install another phone model ROM on your phone. E.g. You tried to install Galaxy S2 ROM on a Galaxy S3 and ending up hard-bricking your phone but you got Status 7 error which saved you.

    Now, this safety mechanism is great but there are times where even if you have the correct ROM for your phone, you will get Status 7 error.

    This is due to an error by the developer of the ROM in the updater script, causing havoc, making people install another custom recovery like TWRP recovery for no reason.

    You can fix the issue by installing TWRP recovery but if you need to restore your CWM backups later down the line, you will have to re-install CWM recovery, causing a big hassle.

    Also, if you update to the latest CWM Recovery using ROM Manager, usually this problem is fixed.

    But what if you did update to the latest CWM Recovery and still happens? And yes, it does happen even when you update your CWM recovery.

    If you simply don’t want to change your recovery (because if it ain’t broke, don’t fix it) or you still get Status 7 error after changing recovery, you can simply edit the updater script yourself to get rid of the asserts.

    All you need is a computer and a zipping program! (You might be able to even do it on your Android device with AndroZip and text editor but I haven’t tried yet.)
    MAKE SURE THE ROM YOU ARE INSTALLING IS COMPATIBLE WITH YOUR ANDROID DEVICE AS INSTALLING WRONG ROM CAN BRICK YOUR DEVICE!

    Before we begin, e.g. Make sure if you are installing a ROM on AT&T Galaxy S3, the ROM zip file you downloaded is for AT&T Galaxy S3 not for Verizon Galaxy S3.


    Step 1. Copy the ROM zip file to your computer and extract it using your favorite unzipping software.
    71.PNG


    72.PNG


    Step 2. Once unzipped, browse to the META-INF/com/google/android directory. You will find two files called “update-binary” and “updater-script”.
    73.PNG


    Step 3. Rename “updater-script” to “updater-script.txt” and open with your favorite text file editor.
    74.PNG


    Step 4. Get rid of the line starting with “assert” to next semi-colon. Usually this is the first line or one of the first lines at the top of the text file. Just delete them.
    5e70c76242c3.png


    Step 5. Save file.
    8c44068ac2f4.png


    Step 6. Rename “updater-script.txt” back to “updater-script”.
    200ad781582f.png


    Step 7. Rezip all the files you’ve unzipped.
    1859ac5f5f29.png


    bd453c44dcc8.png


    Step 8. Copy the new, edited zip file to your phone.
    c2fa6516847c.png


    Step 9. Try re-installing ROM, now it should install fine without Status 7 error.

    When I tried to rename it, it stayed as a text file. It didn't revert back to the original file.
    3
    When I tried to rename it, it stayed as a text file. It didn't revert back to the original file.

    Open up the txt file that you made. Then go to Save As and then for File Type select "All Files" and then for the File Name remove the .TXT so its just updater-script and not updater-script.txt then repack
    3
    Thank you very much for the reply!! However, that didn't work. When I removed what you suggested, and removed the .txt extension I'm getting another error as shown in the photo. Any other suggestions?

    Please check your zip file. The META-INF, system and boot.img file should be in the root of the zip and not in a folder

    The structure should be

    XXX.zip
    -> META-INF
    -> system
    ->boot.img
    ->other files and folder

    and not like this

    XXX.zip
    ->XXX
    ->META-INF
    ->system
    ->boot.img
    ->other files and folder
    3
    Hi, I did it, but now I get the error ,,Invalid zip file format!'', what to do?

    ---------- Post added at 11:21 PM ---------- Previous post was at 10:54 PM ----------

    I FOUND A SOLUTION FINALLY! For the ,,invalid zip''-problem!

    I've used 7zip.

    DO NOT unzip your ROM!!! Just fix the updater-script IN the zip. Dont unzip and zip it like in the tutorial
    Just open it in 7zip and:
    Instruction:
    Ge6Q3z0USEK8kBUVIQT3kg.png

    @androtix Please include this solution in to the thread, so that people can save their time!! :)
    3
    No assert found in rom

    I have tried 5 different roms and twrp and cwm and noting will install. Can't find assert in any of the row either.

    Dead phone and don't know what to do but have been trying to fix it for 6 hours.

    Please help!

    Thanks.