[FIX] Unknown USB device (Device Descriptor Request Failed) Fastboot Windows 10

BoBo Rich

New member
May 8, 2016
1
16
0
First of all, I have a HTC Droid DNA. I was searching for about a year. Finally I got a solution for my problem and I know some of you are still out there with no solution.

The Fail Code is: Unknown USB device (Device Descriptor Request Failed)
Windows has stopped this device because it has reported problems. (Code 43)

So I found a German solution where you have to go to regedit.

Step 1: You need to install the HTC drivers (Google, Samsung etc...) in the normal mode your PC will find your phone, but when you turn into Fastboot you get that error "Unknown USB device (Device Descriptor Request Failed) "

Step 2: Make sure you see that error in your Device Manager under USB - Controller

Step 3: Open "regedit"

Step 4: Navigate to : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags

Step 5: Create a new Key called

0BB40FF00100

Step 6: In that Key you create a Binary Value

Name: SkipBOSDescriptorQuery
Value: 01 00 00 00 (ignore the "0000" at the beginning)

Step 7: Reconnect the Phone and enjoy your FIX

I hope I helped you. I can just tell you that it worked for me. I m not sure if it works on all HTC devices.
 

Koehrsen

New member
Feb 4, 2017
1
0
0
Copenhagen
Had the solution for windows 8.1, from a blog on microsoft MSDN. (Sorry can't link to it. Since I'm new @ xda)
But as it turned out the Datatype for SkipBOSDescriptorQuery has changed from windows 8.1 to 10. Instead of a DWORD Value in Windows 8.1 it should be a Binary Value in Windows 10 ;).

So thanks :good: Now I can connect via fastboot to my HTC Incredible S.

Ps. Google this:
why-does-my-usb-device-work-on-windows-8-0-but-fail-on-windows-8-1-with-code-43
And blogpost will show as top result
 

maxsteel1947

New member
Feb 1, 2016
4
0
0
Thank you very much the regedit method worked for sure..

I spent 5 hours on my computer and laptop different usb cables different ports installing uninstalling drivers and ADB nothing

Thanks BoBo Rich:good:
 

ryanbruce

New member
Apr 14, 2009
4
0
0
Worked with the HTC Aria on Win10 x64!

Thanks a ton.

edit: Hrm. Seems to have cropped up again. Time to continue the battle *sigh*
edit 2: Got it! Thankfully I had a Win7 laptop that I was able to fire up. The HTC Aria's fastboot hardware ID is "USB\VID_0BB4&PID_0FFF&REV_0100" which means the vvvvpppprrrr is 0BB40FFF0100. So follow the instructions above but using the key of 0BB40FFF0100
 
Last edited:

rajah sulayman

Senior Member
Nov 21, 2006
115
3
0
Has anyone else gotten this to work?

My Pixel XL isn't recognized at all when plugged in while in system, but it shows up as unrecognized when plugged in while in fastboot. But despite installing the drivers, Windows still refuses to recognize the phone. I tried the various solutions in this thread, but none of them worked. Perhaps it's because my Pixel's fastboot hardware ID is different, but I can't seem to find out what it is.
 

o-l-a-v

Senior Member
Jan 6, 2012
641
513
123
Oslo
Thanks! I have this problem with my Shield TV Pro, will try this after work.
Here's some PowerShell code for doing the registry editing, if anyone is interested.

Code:
#Requires -RunAsAdministrator
[string] $Path = 'HKLM:\SYSTEM\CurrentControlSet\Control\usbflags\0BB40FF00100'
[string] $Name = 'SkipBOSDescriptorQuery'

if ($false) {
    # Create the path if not exist
    if (-not(Test-Path -Path $Path)){New-Item -Path $Path -ItemType 'Directory'}

    # Set "SkipBOSDescriptorQuery" to $true
    Set-ItemProperty -Path $Path -Name $Name -Value 1 -Type 'DWord'

    # Set "SkipBOSDescriptorQuery" to $false
    Set-ItemProperty -Path $Path -Name $Name -Value 0 -Type 'DWord'

    # Remove item
    Remove-ItemProperty -Path $Path -Name $Name

    # Remove path and item(s)
    Remove-Item -Path $Path -Recurse -Force
}
Edit: This did not work for my Shield TV 2015 Pro unfortunately..
 
Last edited:

timematcher

Member
Apr 14, 2008
31
4
28
The error changes to "Port Reset failed". Error code remains the same 43. In my case I am trying to connect an LG G3 D858HK. I have tried many different cabels but no solution. :(
 

Babis_Greece

Member
Jul 21, 2009
28
16
0
Thanks for the info mate !
The registry key worked just great in my Windows 10 x64 computer at home and at my work laptop.
I have a Huawei P9 mobile Device.
Had this issue and nothing i tried seemed to work.
Your key did.

Thanks again !!!:good::good:
 

Seven7hsi9n

New member
Oct 9, 2019
1
0
0
V20 Method prior to attempt....

@texas### whos still having trouble with a V20 stuck in the firmware screen ( like me) and I have a theory so I'm posting this prior to attempting it but someone please let me know if I have this wrong.
I read this post on the first page of the thread by someone whos name I've forgotten now (sorry) but they wrote....

--------------- edit: Hrm. Seems to have cropped up again. Time to continue the battle *sigh*
edit 2: Got it! Thankfully I had a Win7 laptop that I was able to fire up. The HTC Aria's fastboot hardware ID is "USB\VID_0BB4&PID_0FFF&REV_0100" which means the vvvvpppprrrr is 0BB40FFF0100. So follow the instructions above but using the key of 0BB40FFF0100 -----------------------

and based on this --- my V20 hardware ID reads "USB\VID_0000&PID_0002\5&2BF451F8&0&2" or rather the instance path does and using this I should be able to correct the value of the binary string to fit this corresponding ID for the VVVVPPPPRRRR correct? so value will be "0000000252BF451f02" ????
Im making the key and binary value now and I'll repost results later
I'm so invested in this phone both in time and sheer ignorance of what else I can do to get this damn thing out of the firmware screen.
* I've tried loading the "LG drivers from both LG composite device and VZW versions" to no avail.

*On a side note, tapping the power button brings up a "download mode" sub screen where is searches for wifi connections and after finding mine I went ahead and tried to connect 1- normally 2- removing my wifi password 3- using the WPS button to connect, all of which ended in "connection failed" so can someone explain the actual purpose of this option if there is no way to connect? or am I finding the wrong signal so to speak>?
Thanks
I'll gladly post all of my results or screen shots, (all failed so far) using ADB, uppercut, LGUP, odin, placing TOT files on the SD card, plus a few absolutely embarrassing methods but had to try something.
Please tell me someone knows a way out of this
 

Masutin

Member
Dec 18, 2011
7
0
0
Otherwise start a *.bat file containing
Code:
REG ADD HKLM\SYSTEM\CurrentControlSet\Control\UsbFlags\0BB40FF00100 /v SkipBOSDescriptorQuery /t REG_BINARY /d 01000000 /f
or use this in the Run window that you can call by pressing the Windows button and R, Win+R.
 

laurentiu.tns

New member
Feb 14, 2020
1
0
0
DEAD

Hi

Hope there's still anyone here that could help. I got the same error {The Fail Code is: Unknown USB device (Device Descriptor Request Failed) Windows has stopped this device because it has reported problems. (Code 43)} that appears on windows when watch is connected and i press the red button. I tried to get the identifier via device manager and microsoft message analyzer but it is not detected. What else can i do?

Thanks!