[FIX] USB Tethering lags/freezes on windows 8.1

Search This thread

mpjoe2000

Senior Member
May 11, 2011
172
123
Everytime i tried to use USB Tethering with my Xperia U on my Windows 8.1 (Bing's single language Edition [Genuine Licence]) have always lags or even freeze the taskbar and some other tool settings on my operating system. After some testing and googling a little bit i found a solution for this Microsoft Issue: Update your NDIS 5 Driver to NDIS 6.x.

Verify if your device is using RNDIS 5 driver (1):

  • Open Device Manager from Control Panel and expand “Network Adapters.”
  • Plug in your device and enable USB Tethering so that the device is detected as Remote NDIS based device.
  • This should now create a Network Adapter named as “ [Your Device Name] Remote NDIS based [internet Sharing/network] Device.”
  • Right-click the Adapter and select Properties.
  • Select the Driver tab and then click Driver Details.
  • You can see the driver files if the files are named usb8023x.sys and rndismpx.sys you are using RNDIS 5 Driver.


Updating your driver:
  • Option 1: Update your driver NDIS driver manually by selecting the driver's list option on windows wizard driver's update. Unselect show all compatible hardware option, you will get a Microsoft's driver list. You should seek for a RNDIS 6 USB device and click next. This should work on 32bits or 64bits edition.
  • Option 2 (64 bits only)(2): Just Download and update your NDIS driver from the attachment below. On Driver's Wizard installation must go through selecting the driver from a list.
Sources:
http://support.microsoft.com/kb/2923775 (1)
http://www.driverscape.com/download/remote-ndis-compatible-device (2)
https://msdn.microsoft.com/en-us/library/windows/hardware/dn449742%28v=vs.85%29.aspx. Microsoft says NDIS 6.4 is included on Windows 8.1, don't know why windows chooses RNDIS 5 over RNDIS 6 on my laptop.
 

Attachments

  • rndiscmp.inf_amd64_8cb932739fef737d.zip
    1.8 KB · Views: 37,622
Last edited:

MHP2013

Senior Member
Mar 6, 2013
138
81
Munich
Thanks for your great tutorial. I tried updating the drivers but stupid windows doesn't let me do it. If I try the first method to install and click the "RNDIS 6 Adapter" drivers in the "Microsoft" list, it shows an error that some "required line in the INF file could not be found" (translated from german).

Then if I try the manual method (downloading the zip), windows refuses to install and says "the latest drivers is already installed" (translated).

I also tried uninstalling the drivers but as soon as I plug in the device it installs the wrong drivers again manually. I cannot stop this also because of the extremely lag in the taskbar...

Thanks windows! :mad:

regards
 

mpjoe2000

Senior Member
May 11, 2011
172
123
Thanks for your great tutorial. I tried updating the drivers but stupid windows doesn't let me do it. If I try the first method to install and click the "RNDIS 6 Adapter" drivers in the "Microsoft" list, it shows an error that some "required line in the INF file could not be found" (translated from german).

Then if I try the manual method (downloading the zip), windows refuses to install and says "the latest drivers is already installed" (translated).

I also tried uninstalling the drivers but as soon as I plug in the device it installs the wrong drivers again manually. I cannot stop this also because of the extremely lag in the taskbar...

Thanks windows! :mad:

regards

Try this before installing the NDIS 6 driver:
http://www.tomshardware.com/faq/id-2165451/dont-windows-windows-automatically-download-device-drivers-icons.html

If above didn't work try to disable driver signature verification:
http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/
 

BRiANj64

Senior Member
Apr 28, 2012
347
90
Maassluis
Perfect, Thanks for this fix! Didn't need the driver as RNDIS6 driver is already included in Windows 8.1

NDIS Compatible works without huge driver lockups, but RNDIS6 USB Adapter also works like a charm. (Nexus 5)
 

AMKhatri

Senior Member
Jul 19, 2013
165
33
Dar es salaam, Tanzania
Facing the same problem, here.

Tried both options, still facing the same problem..

Any ideas?
 

Attachments

  • 2015-08-07_000247.png
    2015-08-07_000247.png
    9.5 KB · Views: 5,439

Ano59

Senior Member
Mar 13, 2010
129
45
Got this issue after upgrading Windows 10 (I was already on 10). This solved the problem perfectly. Thanks for fixing yet another fail from Microsoft.
 

DubleJayJ

Senior Member
Jan 10, 2012
849
92
Pittsburgh
Got this issue after upgrading Windows 10 (I was already on 10). This solved the problem perfectly. Thanks for fixing yet another fail from Microsoft.
I keep trying to update it on Windows 10 but it keeps telling me it's the most up to date driver(it definitely isn't). How did you go about doing it?
 

inkaine

Member
Apr 20, 2015
40
21
Windows 10 best solution: rename the RNDIS5 .inf file

The issue drove me nuts on Windows 10 as well. Selecting another driver as suggested did not work for me as well, since Windows kept jumping back to the RNDIS5 driver all the time.

But I found the solution: Just rename the .inf-file containing the RNDIS5 driver. That way Windows will automatically use the RNDIS6 driver.

  1. Go to C:\Windows\INF folder
  2. Find file wceisvista.inf
  3. Take ownership of that file and grant yourself permissions
  4. Rename the file extension to anything but .inf (for me I used .in_)
  5. Enjoy the RNDIS6 driver
 
  • Like
Reactions: tregate and buntoo

liott

Member
Nov 28, 2014
37
12
Paris
Something is not logical in this tutorial :
The content of the inf file in the attachment is rndiscmp.inf; but this file is already in Win8.1 system (C:\Windows\Inf). Hash are similar

This could explain why windows refuses to install it again and says "the last drivers is already installed"
Renaming extension of wceisvista.inf doesn't work for me in Win 8.1

Maybe you could tell us the name of driver files when using RNDIS 6 Driver ...
 

matbarni

Senior Member
Dec 30, 2010
56
9
You can use one of the below drivers from that list. One of them may work, try them all:
USB RNDIS Adapter
USB RNDIS6 Adapter
Remote NDIS based Internet Sharing Device
Remote NDIS Compatible Device > this was the one that worked for me
 

buntoo

Senior Member
Oct 20, 2010
257
13
Gujranwala
The issue drove me nuts on Windows 10 as well. Selecting another driver as suggested did not work for me as well, since Windows kept jumping back to the RNDIS5 driver all the time.

But I found the solution: Just rename the .inf-file containing the RNDIS5 driver. That way Windows will automatically use the RNDIS6 driver.

  1. Go to C:\Windows\INF folder
  2. Find file wceisvista.inf
  3. Take ownership of that file and grant yourself permissions
  4. Rename the file extension to anything but .inf (for me I used .in_)
  5. Enjoy the RNDIS6 driver

Thank You :) :good:
 

Raziorx

New member
Apr 23, 2016
1
0
Hi guys, i get some issues here where it looks like i have only NDIS 5 on my windows 10.
I tried manually select driver, but i can only see this one : Remote NDIS based Internet Sharing Device

i tried inkaine's method, usb8023x.sys is still there but rndismpx.sys is missing. So i think i'm still using this annoying NDIS 5.

I don't understand why it's so hard to update this driver.. :silly:
 

dave.sohan

New member
May 6, 2016
2
0
The issue drove me nuts on Windows 10 as well. Selecting another driver as suggested did not work for me as well, since Windows kept jumping back to the RNDIS5 driver all the time.

But I found the solution: Just rename the .inf-file containing the RNDIS5 driver. That way Windows will automatically use the RNDIS6 driver.

  1. Go to C:\Windows\INF folder
  2. Find file wceisvista.inf
  3. Take ownership of that file and grant yourself permissions
  4. Rename the file extension to anything but .inf (for me I used .in_)
  5. Enjoy the RNDIS6 driver

Thank you so much. This issue has been bothering me for years and your solution along with OP's solution helped me. Thanks
 

greyboss88

Member
Feb 27, 2015
19
3
Hey ive been having this issue for a while now and im using a htc one m8 to tether with but for me it wont let me manually update the drivers or modify the wceisvista.inf im using windows 10 pro as well.
 

dsouza.wilbur

Member
Sep 24, 2013
10
9
30
Windows 10 fix - Worked for me

Hello all,
None of the steps worked for me, however i followed one more set on steps that i found on the net (unable to post links yet :( )
anyways, the steps are
Open Device Manager (right click on Computer > Manage > on the left side, under System Tools choose Device Manager)
Choose the problematic device in Network Adapters (for me it's called HTC Remote NDIS based device)
Right click on it and choose Update Driver Software...
Click Browse my computer for driver software
Click Let me pick from a list of device drivers
Uncheck the box Show compatible hardware
For the manufacturer, choose Microsoft Corporation
Now you will have two options:
Remote NDIS based Internet Sharing Device
Remote NDIS Compatible Device
I chose the second one and it solved the problem, but if it doesn't work you could try the other one. In my case, the driver that was being used was neither of these, but a special driver from Android SDK ADT bundle.
Pick one and click Next.
If a dialog comes up, confirm by clicking Yes.
Wait a few seconds for the connection to restart. If it doesn't work, try disabling and reenabling USB tethering on the phone, or reconnect the USB cable.

PS: Microsoft Corporation or Microsoft Inc. or Microsoft might be present in manufacturer. search among the three
 

Top Liked Posts

  • There are no posts matching your filters.
  • 39
    Everytime i tried to use USB Tethering with my Xperia U on my Windows 8.1 (Bing's single language Edition [Genuine Licence]) have always lags or even freeze the taskbar and some other tool settings on my operating system. After some testing and googling a little bit i found a solution for this Microsoft Issue: Update your NDIS 5 Driver to NDIS 6.x.

    Verify if your device is using RNDIS 5 driver (1):

    • Open Device Manager from Control Panel and expand “Network Adapters.”
    • Plug in your device and enable USB Tethering so that the device is detected as Remote NDIS based device.
    • This should now create a Network Adapter named as “ [Your Device Name] Remote NDIS based [internet Sharing/network] Device.”
    • Right-click the Adapter and select Properties.
    • Select the Driver tab and then click Driver Details.
    • You can see the driver files if the files are named usb8023x.sys and rndismpx.sys you are using RNDIS 5 Driver.


    Updating your driver:
    • Option 1: Update your driver NDIS driver manually by selecting the driver's list option on windows wizard driver's update. Unselect show all compatible hardware option, you will get a Microsoft's driver list. You should seek for a RNDIS 6 USB device and click next. This should work on 32bits or 64bits edition.
    • Option 2 (64 bits only)(2): Just Download and update your NDIS driver from the attachment below. On Driver's Wizard installation must go through selecting the driver from a list.
    Sources:
    http://support.microsoft.com/kb/2923775 (1)
    http://www.driverscape.com/download/remote-ndis-compatible-device (2)
    https://msdn.microsoft.com/en-us/library/windows/hardware/dn449742%28v=vs.85%29.aspx. Microsoft says NDIS 6.4 is included on Windows 8.1, don't know why windows chooses RNDIS 5 over RNDIS 6 on my laptop.
    9
    Windows 10 fix - Worked for me

    Hello all,
    None of the steps worked for me, however i followed one more set on steps that i found on the net (unable to post links yet :( )
    anyways, the steps are
    Open Device Manager (right click on Computer > Manage > on the left side, under System Tools choose Device Manager)
    Choose the problematic device in Network Adapters (for me it's called HTC Remote NDIS based device)
    Right click on it and choose Update Driver Software...
    Click Browse my computer for driver software
    Click Let me pick from a list of device drivers
    Uncheck the box Show compatible hardware
    For the manufacturer, choose Microsoft Corporation
    Now you will have two options:
    Remote NDIS based Internet Sharing Device
    Remote NDIS Compatible Device
    I chose the second one and it solved the problem, but if it doesn't work you could try the other one. In my case, the driver that was being used was neither of these, but a special driver from Android SDK ADT bundle.
    Pick one and click Next.
    If a dialog comes up, confirm by clicking Yes.
    Wait a few seconds for the connection to restart. If it doesn't work, try disabling and reenabling USB tethering on the phone, or reconnect the USB cable.

    PS: Microsoft Corporation or Microsoft Inc. or Microsoft might be present in manufacturer. search among the three
    2
    Thanks for your great tutorial. I tried updating the drivers but stupid windows doesn't let me do it. If I try the first method to install and click the "RNDIS 6 Adapter" drivers in the "Microsoft" list, it shows an error that some "required line in the INF file could not be found" (translated from german).

    Then if I try the manual method (downloading the zip), windows refuses to install and says "the latest drivers is already installed" (translated).

    I also tried uninstalling the drivers but as soon as I plug in the device it installs the wrong drivers again manually. I cannot stop this also because of the extremely lag in the taskbar...

    Thanks windows! :mad:

    regards

    Try this before installing the NDIS 6 driver:
    http://www.tomshardware.com/faq/id-2165451/dont-windows-windows-automatically-download-device-drivers-icons.html

    If above didn't work try to disable driver signature verification:
    http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/
    2
    Windows 10 best solution: rename the RNDIS5 .inf file

    The issue drove me nuts on Windows 10 as well. Selecting another driver as suggested did not work for me as well, since Windows kept jumping back to the RNDIS5 driver all the time.

    But I found the solution: Just rename the .inf-file containing the RNDIS5 driver. That way Windows will automatically use the RNDIS6 driver.

    1. Go to C:\Windows\INF folder
    2. Find file wceisvista.inf
    3. Take ownership of that file and grant yourself permissions
    4. Rename the file extension to anything but .inf (for me I used .in_)
    5. Enjoy the RNDIS6 driver
    2
    You can use one of the below drivers from that list. One of them may work, try them all:
    USB RNDIS Adapter
    USB RNDIS6 Adapter
    Remote NDIS based Internet Sharing Device
    Remote NDIS Compatible Device > this was the one that worked for me
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone