[FIX] Volte Not Working in Custom Roms in Roaming

Was the fix useful?

  • Yes

    Votes: 33 42.3%
  • No

    Votes: 45 57.7%

  • Total voters
    78
Search This thread

raza_maestro

Senior Member
Jun 3, 2016
770
253
New Delhi
Xiaomi Poco F3
So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

The fix is quite simple and just needs to add two separate access points for jio sim.
Under access points delete all apns present and add these two new apns:

1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
Do not change other values. Save this profile and select it.

Reboot once. Your volte should work flawlessly.
Hope it helps.
 
Last edited:

vicky083_

Senior Member
Dec 7, 2016
84
19
Dude you are life saver for me... ??
Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
And should i need to repeat this process whenever i switch to new custom rom In future..?
 
  • Like
Reactions: vijayakrishnavk99hc

raza_maestro

Senior Member
Jun 3, 2016
770
253
New Delhi
Xiaomi Poco F3
Dude you are life saver for me... ??
Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
And should i need to repeat this process whenever i switch to new custom rom In future..?
Happy to help. ? Didn't sleep last night for this. ?
I am also wondering to why its happening to specific users. I think its happening to users having jio in roaming only.
If volte doesn't work on switching to new rom then you can repeat this process. I'll say its a one time investment. ?
 

vicky083_

Senior Member
Dec 7, 2016
84
19
Happy to help. Didn't sleep last night for this.
I am also wondering to why its happening to specific users. I think its happening to users having jio in roaming only.
If volte doesn't work on switching to new rom then you can repeat this process. I'll say its a one time investment.
Hahaha.. Really better than that annoying engineering mode n all... well, really appreciate your hardwork....??
 

sahir7860

Member
Sep 24, 2017
26
7
Then check the ims status from engineering mode. Dial *#*#4636#*#* and choose phone information and from 3 dot menu select ims status. What does it say?

No option to check ims status.
 

Attachments

  • Screenshot_2017-10-17-23-34-53-208_com.android.settings.png
    Screenshot_2017-10-17-23-34-53-208_com.android.settings.png
    94 KB · Views: 6,365

sahir7860

Member
Sep 24, 2017
26
7
Then check the ims status from engineering mode. Dial *#*#4636#*#* and choose phone information and from 3 dot menu select ims status. What does it say?
There was no ims status on mini 9, but in other custom ROM it has
Ims registration: not registered
Voice over LTE: unavailable
What should I do?
 

pramod_cet

Member
Jul 6, 2012
14
0
So, Many users of custom roms users reported to have broken volte suddenly out of nowhere and besides everything the volte wasn't working for them anymore. There was a workaround to turn off/on radio from engineering mode but it only lasted till the reboot.
After looking into the matter last night i found the feasible solution for it. It'll be little long so bear with me. :D

After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

The fix is quite simple and just needs to add two separate access points for jio sim.
Under access points delete all apns present and add these two new apns:

1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

2) Name- Jio Internet APN- Jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
Do not change other values. Save this profile and select it.

Your volte will work flawlessly like before.
Hope it helps.

Thank You.. It worked perfectly.. :laugh:
 

Top Liked Posts

  • There are no posts matching your filters.
  • 27
    So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
    There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
    After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

    After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

    The fix is quite simple and just needs to add two separate access points for jio sim.
    Under access points delete all apns present and add these two new apns:

    1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

    2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Do not change other values. Save this profile and select it.

    Reboot once. Your volte should work flawlessly.
    Hope it helps.
    5
    Dude you are life saver for me... ??
    Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
    And should i need to repeat this process whenever i switch to new custom rom In future..?
    Happy to help. ? Didn't sleep last night for this. ?
    I am also wondering to why its happening to specific users. I think its happening to users having jio in roaming only.
    If volte doesn't work on switching to new rom then you can repeat this process. I'll say its a one time investment. ?
    2
    Then check the ims status from engineering mode. Dial *#*#4636#*#* and choose phone information and from 3 dot menu select ims status. What does it say?

    No option to check ims status.
    1
    Dude you are life saver for me... ??
    Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
    And should i need to repeat this process whenever i switch to new custom rom In future..?
    1
    Hahaha.. Really better than that annoying engineering mode n all... well, really appreciate your hardwork....??
    Thanks dude. Enjoy.