[FIX] Volte Not Working in Custom Roms in Roaming

Was the fix useful?

  • Yes

    Votes: 33 42.3%
  • No

    Votes: 45 57.7%

  • Total voters
    78
Search This thread

mindthehee

Member
Jul 1, 2015
47
3

Attachments

  • Screenshot_20180402-182717.png
    Screenshot_20180402-182717.png
    100.5 KB · Views: 975

mindthehee

Member
Jul 1, 2015
47
3
Yes I'm Familiar but I don't know with this?? I'm Just stucked i know it can be solved by flashing stock rom but i don't want to do that.. So please help me if u can
 
Nov 6, 2012
5
2
I have this leeco x626 mediatek helio x20 on the official ROM jio 4g work but when I install any custom ROM . The phone shows network and 4g data also work but I cannot receive or make voice call :crying::crying::crying:

I have installed I think multiple custom ROM at least 10 times . I tried this method also but unable to fix this problem . i f I put any other sim I can get calls .

Any help
 

VijayGopal

New member
May 3, 2018
3
0
Ims not registered

So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

The fix is quite simple and just needs to add two separate access points for jio sim.
Under access points delete all apns present and add these two new apns:

1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
Do not change other values. Save this profile and select it.

Reboot once. Your volte should work flawlessly.
Hope it helps.

iItried the apn settings, it didnt work. My ims is not registered. Any fix ?

ims registration - not registered
voice over lte - unavailable
voice over wifi - unavailable
videocalling- unavailable
Ut interface - unavailable
i am using lineage os 15.1 on redmi note 5 pro
 

VijayGopal

New member
May 3, 2018
3
0
Make sure network type is set to global in settings.

i tried using global in network settings. Still doesn't work. I am using jio on roaming. Does it make any difference ? It worked for a day and then stopped working suddenly. I tried flashing the rom again but this time it doesn't work at all.
 

raza_maestro

Senior Member
Jun 3, 2016
770
253
New Delhi
Xiaomi Poco F3
i tried using global in network settings. Still doesn't work. I am using jio on roaming. Does it make any difference ? It worked for a day and then stopped working suddenly. I tried flashing the rom again but this time it doesn't work at all.
Yeah this issue is related to jio sim in roaming.
Have you enabled data roaming for jio? Also try clearing all the apns and then add those two apns again and choose network type as lte only.
 

VijayGopal

New member
May 3, 2018
3
0
Yeah this issue is related to jio sim in roaming.
Have you enabled data roaming for jio? Also try clearing all the apns and then add those two apns again and choose network type as lte only.

Thanks for the quick reply. I tried all the above steps and it is didnt work. Jio4gvoice is working but i absolutely hate that app.
thanks in advance

---------- Post added at 03:43 AM ---------- Previous post was at 03:42 AM ----------

Yeah this issue is related to jio sim in roaming.
Have you enabled data roaming for jio? Also try clearing all the apns and then add those two apns again and choose network type as lte only.

Thanks for the quick reply. I tried all the above steps and it didn't work. Jio4gvoice is working but i absolutely hate that app.
thanks in advance
 

ufenil

New member
May 6, 2018
3
0
VolTE Call not working

I did all these settings.. but still get call ended even though the data works. Tried installing many ROMS. No Success.
 

crazix

Senior Member
Aug 11, 2012
473
100
The trick really worked. I tried almost 20 times and finally when I was about to give up it worked. Just like magic.
 

Paco10

Senior Member
Oct 3, 2015
94
11
hello I have redmi note 4 I measure with andrpid 9 aosp .. I would like to know what point I should put the tilde of the two apns..jionet or ims.The network comes and goes and I do not have data thanks
 

Top Liked Posts

  • There are no posts matching your filters.
  • 27
    So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
    There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
    After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

    After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

    The fix is quite simple and just needs to add two separate access points for jio sim.
    Under access points delete all apns present and add these two new apns:

    1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

    2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Do not change other values. Save this profile and select it.

    Reboot once. Your volte should work flawlessly.
    Hope it helps.
    5
    Dude you are life saver for me... ??
    Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
    And should i need to repeat this process whenever i switch to new custom rom In future..?
    Happy to help. ? Didn't sleep last night for this. ?
    I am also wondering to why its happening to specific users. I think its happening to users having jio in roaming only.
    If volte doesn't work on switching to new rom then you can repeat this process. I'll say its a one time investment. ?
    2
    Then check the ims status from engineering mode. Dial *#*#4636#*#* and choose phone information and from 3 dot menu select ims status. What does it say?

    No option to check ims status.
    1
    Dude you are life saver for me... ??
    Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
    And should i need to repeat this process whenever i switch to new custom rom In future..?
    1
    Hahaha.. Really better than that annoying engineering mode n all... well, really appreciate your hardwork....??
    Thanks dude. Enjoy.