[FIX] Volte Not Working in Custom Roms in Roaming

Was the fix useful?

  • Yes

    Votes: 33 42.3%
  • No

    Votes: 45 57.7%

  • Total voters
    78
Search This thread

sksmi2002

Member
  • Nov 18, 2019
    9
    1
    I own a moto z2 force.. after flashing into a custom rom (dirty unicrons), my both the sim cards do have coverage (range).. i do receive incoming calls on both..... but i am unable to make calls with my secondary sim... a help would be appreciated!
    I am attaching a screenshot to support it..
    ae4f7b35-6745-4dcc-a33e-e928f34f434e.jpg
     

    x_berzerker

    Senior Member
    Dec 19, 2010
    103
    14
    My volte gone after flashing lineage os unofficial latest build with integrated firmware.
    I'm not able to make or receive calls
    After that I flashed miui 9 with fastboot and still no luck
    I also tried the fix posted in this thread still no volte
    Before all these I'm on aex with v025 firmware
    Anyone have any solution
    Volte is must for me :(
    Edit:
    Issue fixed

    HOW?
     

    greenmns

    Member
    Feb 19, 2020
    16
    1
    hi my friend
    i have nokia 1 plus i wanted use volte on my phone
    so i rooted nokia 1 plus and i edited /etc/apns-conf.xml for add ims apn and rebooted my phone.
    after that i saw file /system/build.prop that there was not any option of volte so i add this parameter:
    persist.dbg.ims_volte_enable=1
    persist.dbg.volte_avail_ovr=1
    persist.dbg.vt_avail_ovr=1
    persist.dbg.wfc_avail_ovr=1
    persist.radio.rat_on=combine
    persist.radio.data_ltd_sys_ind=1
    persist.radio.data_con_rprt=1
    persist.radio.calls.on.ims=1
    after i added this parameter ,i reboot my phone and i saw enhanced 4G LTE mode is active
    but when i dial *#*#4636#*#* i saw in ims status voice of LTE unavailble
    please help me what do to do ?
    photo_2020-03-04_10-33-03.jpg
     

    vinay durva

    Senior Member
    Dec 30, 2015
    59
    7
    Adilabad
    (I'm Not Redmi 4A user .)
    I flashed Pixel experience 10 Rom . in my Redmi 8a
    I have Volte issue . or What I don't understand
    Working : Incoming call & Sending Text
    Not working : outgoing Call & incoming text
    , im Jio User
    Will U please help me how To solve This In my phone
     

    Attachments

    • Screenshot_20200505-101414.png
      Screenshot_20200505-101414.png
      166.4 KB · Views: 199

    Portblair

    New member
    May 21, 2020
    1
    0
    Airtel Volte on moto g5s plus running pixel experience rom Android 10.

    Hello everyone , can I get airtel volte on Moto g5s plus running Android 10 pixel experience rom. Please help.

    Thanks
     

    Madhu44

    New member
    Jun 9, 2020
    1
    0
    I am using latest pixel experience rom i tried this but still volte for my jio is not working and I tried with jio calling app but it is not registering..please help me..
     
    Jan 11, 2015
    41
    7
    Moto G5S+ VoLTE

    Hello everyone , can I get airtel volte on Moto g5s plus running Android 10 pixel experience rom. Please help.

    Thanks

    For VoLTE on Moto G5S+
    - First Choose Network Type as LTE...... NOT GLOBAL. Be sure your APN is selected also.

    - Reboot Phone

    - IMS Will now Be registered after reboot.

    -After reboot and assuring your IMS is in fact registered then go to Engineering (Testing shows at top when in Engineering) with *#*#4636#*#*

    - Hit Phone Information

    - Flip VoLTE Provisioned Switch to ON position (to the right and Blue indicates ON)

    - Flip WiFi Calling Provisioned Switch to ON position

    HOLDS THROUGH REBOOTS
    WORKS ON MAGISK ROOTED
    THIS PHONE IS ON VERIZON WITH VERY OLD 4G LTE SIM
    THIS FIXED WIFI CALLING AS WELL

    Lip Lip Lip
     

    jparth78

    New member
    Sep 11, 2020
    3
    0
    Can you please tell me where and how to add apns ?

    So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
    There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
    After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

    After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.



    The fix is quite simple and just needs to add two separate access points for jio sim.
    Under access points delete all apns present and add these two new apns:

    1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

    2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Do not change other values. Save this profile and select it.

    Reboot once. Your volte should work flawlessly.
    Hope it helps.


    I tried doing it and indeed yes the ims status is un registered.
    But I don’t know how to add apns and where should I find the option to add apns
    Can you please tell me how to do it ?

    Thank you :)
     

    @[email protected]

    New member
    Oct 21, 2020
    3
    0
    So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
    There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
    After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

    After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

    The fix is quite simple and just needs to add two separate access points for jio sim.
    Under access points delete all apns present and add these two new apns:

    1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

    2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Do not change other values. Save this profile and select it.

    Reboot once. Your volte should work flawlessly.
    Hope it helps.
    Bro i love u. Bro before i don't know about what is a roll of ims in volte u save me but i have other valuable information for u i have airtel sim any body don't want jio sim i just. Play and try with my airtel apn settings with ims command and its working now volte flag come back after very long time i just change apn type. Ims only
     

    dypd

    New member
    Jul 7, 2015
    3
    0
    Rebooting the Note 3 Pro VOLTE option gets Hide.

    So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
    There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
    After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

    After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

    The fix is quite simple and just needs to add two separate access points for jio sim.
    Under access points delete all apns present and add these two new apns:

    1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

    2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
    Do not change other values. Save this profile and select it.

    Reboot once. Your volte should work flawlessly.
    Hope it helps.

    Hey guys just installed the rom day before yesterday. From today I am facing the issue for my Jio Sim. So i applied your fix but it did not resolve the issue. So I again flash the os. It solved the issue. But whenever I rebooting my phone after Successful flashing. The Volte option getting hidden from the menu & Calling gets ended. No incoming or outgoing. Please check this.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 27
      So, Many users of custom roms users reported to have broken volte or volte not working while on roaming.
      There was a workaround to turn off/on radio from engineering mode but it only lasted till a reboot.
      After looking into the matter last night i found the feasible permanent solution for it. It'll be little long so bear with me. :D

      After fiddling with every firmware and custom rom i found out the cause of volte breakdown was the IMS status being not registered for some reason. You guys can check in IMS status option in 3 dot menu inside the engineering mode(*#*#4636#*#*). IMS services are responsible for calling and sms services over lte network.

      The fix is quite simple and just needs to add two separate access points for jio sim.
      Under access points delete all apns present and add these two new apns:

      1) Name- ims APN- ims APN type- ims APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
      Save these settings ( this apn wont reflect in the list after saving, so dont worry if it doesnt show up)

      2) Name- Jio Internet APN- jionet APN type- default APN protocol- IPv4/v6 APN roaming protocol- IPv4/v6
      Do not change other values. Save this profile and select it.

      Reboot once. Your volte should work flawlessly.
      Hope it helps.
      5
      Dude you are life saver for me... ??
      Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
      And should i need to repeat this process whenever i switch to new custom rom In future..?
      Happy to help. ? Didn't sleep last night for this. ?
      I am also wondering to why its happening to specific users. I think its happening to users having jio in roaming only.
      If volte doesn't work on switching to new rom then you can repeat this process. I'll say its a one time investment. ?
      2
      Then check the ims status from engineering mode. Dial *#*#4636#*#* and choose phone information and from 3 dot menu select ims status. What does it say?

      No option to check ims status.
      1
      Dude you are life saver for me... ??
      Working flawlessly now... But one thing i wanna ask why this problem is specific to some devices what we have done wrong..? Not everyone have to try this method as thier volte is working fine...
      And should i need to repeat this process whenever i switch to new custom rom In future..?
      1
      Hahaha.. Really better than that annoying engineering mode n all... well, really appreciate your hardwork....??
      Thanks dude. Enjoy.
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone