[FIX] Wi-fi sleep for stock FRF91

Search This thread

mmastrac

Senior Member
Jun 11, 2010
87
11
Any of us still on stock FRF91 with mac addresses not starting with 00:* are dealing with the bug where wi-fi disconnects when the phone goes to sleep:

(sorry, my account is too new to properly link the bug thread)

google.com/support/forum/p/android/thread?tid=01a47ff5b0a92d52&hl=en&start=120

This is fixed in the latest CM6 nightly builds, but I don't think it's possible to get the .ko from that build to work on stock FRF91.

I backported the fix from git (android.git.kernel.org/?p=platform/system/wlan/broadcom.git;a=commitdiff;h=5a838529e6197475cbe8f5a4557fbd31f90586a6) to the earlier version of the driver.

I've been testing this for the last 30 minutes and haven't been kicked off wi-fi once after the screen went to sleep.

How to install:

  1. Make sure you're on FRF91 and have rooted yourself
  2. adb shell and get root via 'su'
  3. Copy your old driver to /data/local: cat /system/lib/modules/bcm4329.ko > /data/local/bcm4329.ko.old
  4. Check that the MD5 of the unzipped .ko is 959dda656228b4191f8e97b920482ae2
  5. From your system, adb push the attached bcm4329.ko (unzip it first) to /data/local/bcm4329.ko.new
  6. adb shell and get root via 'su' again
  7. Copy the driver over top of the old one: cat /data/local/bcm4329.ko.new > /system/lib/modules/bcm4329.ko
  8. Reboot

You'll probably screw up future OTA updates if you manually patch this, but it's easy enough to undo (just flash the stock FRF91 or replace the old driver). Also, it worked fine for me, but you'll be doing this at your own risk, etc, etc etc.

---

mmastrac, unrevoked
 

Attachments

  • bcm4329.ko.zip
    103.1 KB · Views: 359

Devastatin

Senior Member
Feb 15, 2010
185
6
Does this work?

I'm at work without access to a usb cable and wonder if this is worth looking at later today.
 

kindiboy

Senior Member
Dec 14, 2009
274
42
Pittsburgh
nevermind that, I thought it's something different than normal push pull stuff.

Can do this through Root Explorer very easy and less hectic.
 

FormelLMS

Retired Recognized Developer
Oct 28, 2009
2,647
376
I don't have the problems that my nexus logged of the wifi network while screen is off.
But when I make a ping to nexus one everything is fine when screen is on, but it become very unresponsable with screen off and has connection time out.
Is this the patch for that problem?
 

mmastrac

Senior Member
Jun 11, 2010
87
11
This doesn't work on CM 6RC1. get a wireless error can't start wireless.

CM6 ships with a different kernel, so this .ko won't work for those builds. This is only for those on the stock FRF91 build who can't use the updated driver from the latest tree.

For CM6 users, it should be fixed in the latest nightlies here:

hxxp://mirror.kanged.net/cm/nightly/passion/
 
Last edited:

mmastrac

Senior Member
Jun 11, 2010
87
11
I don't have the problems that my nexus logged of the wifi network while screen is off.
But when I make a ping to nexus one everything is fine when screen is on, but it become very unresponsable with screen off and has connection time out.
Is this the patch for that problem?

This patch should fix this issue. The broadcom driver in stock FRF91 filters out traffic to the device when the screen is off due to a bug in the implementation that was supposed to filter out traffic to other devices instead.

I can ping my device even while the screen is off with this patch in place. You may also have to change your wi-fi sleep policy to get the best results.
 

hbkmog

Senior Member
Jul 6, 2010
455
36
New York City
This patch should fix this issue. The broadcom driver in stock FRF91 filters out traffic to the device when the screen is off due to a bug in the implementation that was supposed to filter out traffic to other devices instead.

I can ping my device even while the screen is off with this patch in place. You may also have to change your wi-fi sleep policy to get the best results.
Hi man, maybe you can check out the my thread about this issue here:
http://forum.xda-developers.com/showthread.php?t=731395

I hear there are people with the latest nightly build still finding the problem exists. And their MAC address starts with actually 00?

How about your case? Did your phone have this problem before and its MAC address, I suppose, begins with 38?
 

mmastrac

Senior Member
Jun 11, 2010
87
11
Hi man, maybe you can check out the my thread about this issue here:

I hear there are people with the latest nightly build still finding the problem exists. And their MAC address starts with actually 00?

How about your case? Did your phone have this problem before and its MAC address, I suppose, begins with 38?

My n1 has a 38:* MAC address, so I was seeing wifi disconnect almost as soon as the screen went off (and getting disabled in some cases).

There are other wifi issues on the n1 phones. This patch just fixes the worst one.
 

FormelLMS

Retired Recognized Developer
Oct 28, 2009
2,647
376
Yes, and my NexusOne has a MAC starting with 00.
WiFi doesn't disconnect, but I can't hear stream audio....

I try this fix here now.
But, what I wanna know:
Kernel updates includes this bcm***.ko, too.
Can you share your fixes, that the kernel devs can use them, too?
 

fjromcar

New member
Sep 12, 2010
2
0
Hi guys

someone can upload a modified stock (FRF91 or FRG33) with the fix?

i don't know how to fix it and i will be very grateful :)

thank you!!