[FIXED][Any Solution] Viper not working after emui update

Search This thread

venugopalu007

Senior Member
Jun 9, 2017
3,398
594
rajahmundry
Viper is my favorite audio mod, i love to use it,
In previous version of my buid, it worked perfectly.
But after another update , the viper is not working:crying:, it says "I\O error " driver not install something..

Any guide or trick to work it back:(
 
Last edited:

venugopalu007

Senior Member
Jun 9, 2017
3,398
594
rajahmundry
I always use Viper4Android and I don't have any problem, I find steps which I wrote somewhere before

---------- Post added at 12:31 ---------- Previous post was at 12:29 ----------

I got same problem, solutions for my was:

1. install BusyBox by Meefik ( Google play)
2. install Kernel Adiutor ( https://github.com/yoinx/kernel_adiu...pp-release.apk ) ( Kernel Adiutor from Google play dont work)
3. opem BusyBox tap Install
4. open Kernel Adiutor and go to Misc Controls, change Current SELinux Status: Permissive (after reboot SELinux stay premissive )
5. flash Viper4 via TWRP
6. go to folder: root/vendor/etc and rename file from audio_effects.conf to audio_effects.conf.bak
7. open Viper4
8. Install driver (thats can take 1-3 min)
9. reboot - done

this I do always

i will try this and report you ,:)
 

venugopalu007

Senior Member
Jun 9, 2017
3,398
594
rajahmundry
still issue
 

Attachments

  • Screenshot_20170708-224400.png
    Screenshot_20170708-224400.png
    179.3 KB · Views: 107

venugopalu007

Senior Member
Jun 9, 2017
3,398
594
rajahmundry
U don't have error message during installation driver? For me this order always works

---------- Post added at 07:07 PM ---------- Previous post was at 07:05 PM ----------

Later I can uninstall Viper, I'll make another guide, maybe clearly explain steps. Anyway I send couple times to another members and installation was successful. U do all restarts?

so many times tried :(
 

[email protected]

Senior Member
Feb 17, 2014
89
30
maybe you should check selinux status..
go to terminal:
getenforce

If it restore to 'enforcing' while reboot.
you should edit init.rc and add command:

setenforce 0
 
Last edited:

[email protected]

Senior Member
Feb 17, 2014
89
30
can you explain steps wise ,i can understand easily

I means that android will restore selinux status to 'enforcing' after doing a reboot.
So need add a command in boot-script to set selinux status to 'permissive' .

Look at the attaching PNG, after reboot it back to 'enforcing'

sorry ,my English is bad..
 

Attachments

  • Screenshot_2017-07-09-16-23-03.png
    Screenshot_2017-07-09-16-23-03.png
    136.2 KB · Views: 66
  • Screenshot_2017-07-09-16-23-58.png
    Screenshot_2017-07-09-16-23-58.png
    106.2 KB · Views: 60
Last edited:

Top Liked Posts