• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question [FIXED] fastbootd "<Waiting for any device>" Fastboot Driver issue?

Search This thread
I think my PC doesn't have the proper Fastboot Drivers. Can someone lead me to them?

My problem is, every Custom ROM with a Fastboot ROM doesn't work. Their Install&Format.bat scripts don't work properly.

Their script would do its tasks, until "fastboot reboot fastboot". It would hang at "Waiting for any device", because my PC doesn't detect Fastbootd devices, I'm highly sure.

Code:
D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
Sending 'boot_a' (196608 KB)                       OKAY [  4.674s]
Writing 'boot_a'                                   OKAY [  0.259s]
Finished. Total time: 5.818s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
Sending 'vendor_boot_a' (98304 KB)                 OKAY [  2.399s]
Writing 'vendor_boot_a'                            OKAY [  0.125s]
Finished. Total time: 2.536s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
Setting current slot to 'a'                        OKAY [  0.003s]
Finished. Total time: 0.007s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
Rebooting into fastboot                            OKAY [  0.003s]
< waiting for any device >


Edit: Shortly after making this post, I solved my problem. I was correct. The problem was indeed a missing or failing Fastboot driver in Windows.

I followed that website, and disabled Driver Signature Enforcement, enabled Test Signing & downloaded the linked driver & installed it. Now Fastbootd works :)
 
Last edited:

lolo9393

Senior Member
Dec 28, 2011
1,026
274
Chau Doc Vietnam
I think my PC doesn't have the proper Fastboot Drivers. Can someone lead me to them?

My problem is, every Custom ROM with a Fastboot ROM doesn't work. Their Install&Format.bat scripts don't work properly.

Their script would do its tasks, until "fastboot reboot fastboot". It would hang at "Waiting for any device", because my PC doesn't detect Fastbootd devices, I'm highly sure.

Code:
D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
Sending 'boot_a' (196608 KB)                       OKAY [  4.674s]
Writing 'boot_a'                                   OKAY [  0.259s]
Finished. Total time: 5.818s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
Sending 'vendor_boot_a' (98304 KB)                 OKAY [  2.399s]
Writing 'vendor_boot_a'                            OKAY [  0.125s]
Finished. Total time: 2.536s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
Setting current slot to 'a'                        OKAY [  0.003s]
Finished. Total time: 0.007s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
Rebooting into fastboot                            OKAY [  0.003s]
< waiting for any device >
Try to reset using MIUNLOCK application.
There is a tool to set first time fastboot setting .
 

jackscagnetti

Senior Member
Jul 31, 2015
50
8
Boston
I think my PC doesn't have the proper Fastboot Drivers. Can someone lead me to them?

My problem is, every Custom ROM with a Fastboot ROM doesn't work. Their Install&Format.bat scripts don't work properly.

Their script would do its tasks, until "fastboot reboot fastboot". It would hang at "Waiting for any device", because my PC doesn't detect Fastbootd devices, I'm highly sure.

Code:
D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
Sending 'boot_a' (196608 KB)                       OKAY [  4.674s]
Writing 'boot_a'                                   OKAY [  0.259s]
Finished. Total time: 5.818s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
Sending 'vendor_boot_a' (98304 KB)                 OKAY [  2.399s]
Writing 'vendor_boot_a'                            OKAY [  0.125s]
Finished. Total time: 2.536s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
Setting current slot to 'a'                        OKAY [  0.003s]
Finished. Total time: 0.007s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
Rebooting into fastboot                            OKAY [  0.003s]
< waiting for any device >


Edit: Shortly after making this post, I solved my problem. I was correct. The problem was indeed a missing or failing Fastboot driver in Windows.

I followed that website, and disabled Driver Signature Enforcement, enabled Test Signing & downloaded the linked driver & installed it. Now Fastbootd works :)
I think this is exactly my problem. I have tried many roms but was only able to get the roms that had fastboot installation to work.i was thinking of trying arrowos next. Why didn't you like it?

Edit this was not my problem i had to assign drive letter in-order to install twrp.
 
Last edited:
  • Like
Reactions: Robert314
I think this is exactly my problem. I have tried many roms but was only able to get the roms that had fastboot installation to work.i was thinking of trying arrowos next. Why didn't you like it?

Edit this was not my problem i had to assign drive letter in-order to install twrp.
"Was only able to get Fastboot ROMs to work" So they worked for you? Or typo?

I did try out ArrowOS, it's really nice and simple. I saw that it has Blur effects in the UI compared to the other ROMs which don't. But it doesn't have many other features, it doesn't have *any* Sound effects at all, unfortunately.

I tried out Xiaomi.eu, ArrowOS, Havoc OS and Syberia OS. Lastly I'll try out crDroid.
I think of going back to Xiaomi.eu which is my daily driver. I don't like MIUI, but I really like all the Camera features, the Dolby Atmos Sound (important for me), and the Font thiccness setting
 
Last edited:

RollDload

Senior Member
Mar 7, 2018
64
31
Samsung Galaxy S5
Huawei P9 Lite
Penso che il mio PC non disponga dei driver Fastboot corretti. Qualcuno può portarmi da loro?

Il mio problema è che ogni ROM personalizzata con una ROM Fastboot non funziona. I loro script Install&Format.bat non funzionano correttamente.

Il loro script farebbe i suoi compiti, fino a "fastboot reboot fastboot". Si bloccherebbe su " In attesa di qualsiasi dispositivo ", perché il mio PC non rileva i dispositivi Fastbootd, ne sono molto sicuro.

Code:
D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
Invio 'boot_a' (196608 KB) OKAY [ 4.674s]
Scrivendo 'boot_a' OKAY [ 0.259s]
Finito. Tempo totale: 5.818s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
Invio di 'vendor_boot_a' (98304 KB) OKAY [2.399s]
Scrivendo 'vendor_boot_a' OKAY [0.125s]
Finito. Tempo totale: 2.536s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
Impostazione dello slot corrente su 'a' OKAY [ 0.003s]
Finito. Tempo totale: 0.007s

D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
Riavvio in fastboot OKAY [0.003s]
< in attesa di qualsiasi dispositivo >
[/CODICE]


[B]Modifica: [/B] poco dopo aver pubblicato questo post, ho risolto il mio problema. avevo ragione. Il problema era infatti un driver Fastboot mancante o guasto in Windows.

[URL unfurl="true"]https://c.mi.com/oc/thread-3312019-1-0.html[/URL]
[B]Ho seguito quel sito Web e disabilitato l'applicazione della firma del driver, abilitato la firma di prova, scaricato il driver collegato e installato. Ora Fastbootd funziona[/B] :)
[/QUOTE]
GRAZIE! Ho usato il metodo che hai usato tu. Funziona! ora win10 riconosce il mio poco f3 in fastboot e fastbootd. grazie per averlo condiviso! grande!

[ATTACH type="full" alt="Icona di Verificata con community"]5399187[/ATTACH]
THANK YOU! I used the method you used. it works! now win10 recognize my poco f3 in fastboot and fastbootd. thanks for sharing it! big up!
 
  • Love
Reactions: dreamytom

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Penso che il mio PC non disponga dei driver Fastboot corretti. Qualcuno può portarmi da loro?

    Il mio problema è che ogni ROM personalizzata con una ROM Fastboot non funziona. I loro script Install&Format.bat non funzionano correttamente.

    Il loro script farebbe i suoi compiti, fino a "fastboot reboot fastboot". Si bloccherebbe su " In attesa di qualsiasi dispositivo ", perché il mio PC non rileva i dispositivi Fastbootd, ne sono molto sicuro.

    Code:
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
    Invio 'boot_a' (196608 KB) OKAY [ 4.674s]
    Scrivendo 'boot_a' OKAY [ 0.259s]
    Finito. Tempo totale: 5.818s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
    Invio di 'vendor_boot_a' (98304 KB) OKAY [2.399s]
    Scrivendo 'vendor_boot_a' OKAY [0.125s]
    Finito. Tempo totale: 2.536s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
    Impostazione dello slot corrente su 'a' OKAY [ 0.003s]
    Finito. Tempo totale: 0.007s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
    Riavvio in fastboot OKAY [0.003s]
    < in attesa di qualsiasi dispositivo >
    [/CODICE]
    
    
    [B]Modifica: [/B] poco dopo aver pubblicato questo post, ho risolto il mio problema. avevo ragione. Il problema era infatti un driver Fastboot mancante o guasto in Windows.
    
    [URL unfurl="true"]https://c.mi.com/oc/thread-3312019-1-0.html[/URL]
    [B]Ho seguito quel sito Web e disabilitato l'applicazione della firma del driver, abilitato la firma di prova, scaricato il driver collegato e installato. Ora Fastbootd funziona[/B] :)
    [/QUOTE]
    GRAZIE! Ho usato il metodo che hai usato tu. Funziona! ora win10 riconosce il mio poco f3 in fastboot e fastbootd. grazie per averlo condiviso! grande!
    
    [ATTACH type="full" alt="Icona di Verificata con community"]5399187[/ATTACH]
    THANK YOU! I used the method you used. it works! now win10 recognize my poco f3 in fastboot and fastbootd. thanks for sharing it! big up!
  • 3
    I think my PC doesn't have the proper Fastboot Drivers. Can someone lead me to them?

    My problem is, every Custom ROM with a Fastboot ROM doesn't work. Their Install&Format.bat scripts don't work properly.

    Their script would do its tasks, until "fastboot reboot fastboot". It would hang at "Waiting for any device", because my PC doesn't detect Fastbootd devices, I'm highly sure.

    Code:
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
    Sending 'boot_a' (196608 KB)                       OKAY [  4.674s]
    Writing 'boot_a'                                   OKAY [  0.259s]
    Finished. Total time: 5.818s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
    Sending 'vendor_boot_a' (98304 KB)                 OKAY [  2.399s]
    Writing 'vendor_boot_a'                            OKAY [  0.125s]
    Finished. Total time: 2.536s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
    Setting current slot to 'a'                        OKAY [  0.003s]
    Finished. Total time: 0.007s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
    Rebooting into fastboot                            OKAY [  0.003s]
    < waiting for any device >


    Edit: Shortly after making this post, I solved my problem. I was correct. The problem was indeed a missing or failing Fastboot driver in Windows.

    I followed that website, and disabled Driver Signature Enforcement, enabled Test Signing & downloaded the linked driver & installed it. Now Fastbootd works :)
    1
    I think my PC doesn't have the proper Fastboot Drivers. Can someone lead me to them?

    My problem is, every Custom ROM with a Fastboot ROM doesn't work. Their Install&Format.bat scripts don't work properly.

    Their script would do its tasks, until "fastboot reboot fastboot". It would hang at "Waiting for any device", because my PC doesn't detect Fastbootd devices, I'm highly sure.

    Code:
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
    Sending 'boot_a' (196608 KB)                       OKAY [  4.674s]
    Writing 'boot_a'                                   OKAY [  0.259s]
    Finished. Total time: 5.818s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
    Sending 'vendor_boot_a' (98304 KB)                 OKAY [  2.399s]
    Writing 'vendor_boot_a'                            OKAY [  0.125s]
    Finished. Total time: 2.536s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
    Setting current slot to 'a'                        OKAY [  0.003s]
    Finished. Total time: 0.007s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
    Rebooting into fastboot                            OKAY [  0.003s]
    < waiting for any device >


    Edit: Shortly after making this post, I solved my problem. I was correct. The problem was indeed a missing or failing Fastboot driver in Windows.

    I followed that website, and disabled Driver Signature Enforcement, enabled Test Signing & downloaded the linked driver & installed it. Now Fastbootd works :)
    I think this is exactly my problem. I have tried many roms but was only able to get the roms that had fastboot installation to work.i was thinking of trying arrowos next. Why didn't you like it?

    Edit this was not my problem i had to assign drive letter in-order to install twrp.
    1
    your thread helped me a ton. wasn't able to flash fastboot roms before
    thx a ton!
    1
    your thread helped me a ton. wasn't able to flash fastboot roms before
    thx a ton!
    Awesome! I'm glad it helped you!
    1
    Penso che il mio PC non disponga dei driver Fastboot corretti. Qualcuno può portarmi da loro?

    Il mio problema è che ogni ROM personalizzata con una ROM Fastboot non funziona. I loro script Install&Format.bat non funzionano correttamente.

    Il loro script farebbe i suoi compiti, fino a "fastboot reboot fastboot". Si bloccherebbe su " In attesa di qualsiasi dispositivo ", perché il mio PC non rileva i dispositivi Fastbootd, ne sono molto sicuro.

    Code:
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash boot_a Images/boot.img
    Invio 'boot_a' (196608 KB) OKAY [ 4.674s]
    Scrivendo 'boot_a' OKAY [ 0.259s]
    Finito. Tempo totale: 5.818s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot flash vendor_boot_a Images/vendor_boot.img
    Invio di 'vendor_boot_a' (98304 KB) OKAY [2.399s]
    Scrivendo 'vendor_boot_a' OKAY [0.125s]
    Finito. Tempo totale: 2.536s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot --set-active=a
    Impostazione dello slot corrente su 'a' OKAY [ 0.003s]
    Finito. Tempo totale: 0.007s
    
    D:\Library\Software\Android\Poco F3\Custom ROMs\Havoc-4.6-official-alioth-Gapps-fastboot>.\platform-tools-windows\fastboot reboot fastboot
    Riavvio in fastboot OKAY [0.003s]
    < in attesa di qualsiasi dispositivo >
    [/CODICE]
    
    
    [B]Modifica: [/B] poco dopo aver pubblicato questo post, ho risolto il mio problema. avevo ragione. Il problema era infatti un driver Fastboot mancante o guasto in Windows.
    
    [URL unfurl="true"]https://c.mi.com/oc/thread-3312019-1-0.html[/URL]
    [B]Ho seguito quel sito Web e disabilitato l'applicazione della firma del driver, abilitato la firma di prova, scaricato il driver collegato e installato. Ora Fastbootd funziona[/B] :)
    [/QUOTE]
    GRAZIE! Ho usato il metodo che hai usato tu. Funziona! ora win10 riconosce il mio poco f3 in fastboot e fastbootd. grazie per averlo condiviso! grande!
    
    [ATTACH type="full" alt="Icona di Verificata con community"]5399187[/ATTACH]
    THANK YOU! I used the method you used. it works! now win10 recognize my poco f3 in fastboot and fastbootd. thanks for sharing it! big up!