Fixing a Gear S3 - Bezel Rotation sensor not working

Search This thread

barywsf

Member
Jul 31, 2018
39
8
San Francisco
All - My S3 got wet and went into a bootloop. I sent it to Samsung and they sent it back without fixing it claiming that it was too expensive to fix. It is up to me to fix it myself.

I managed to resolve the bootloop problem by opening it up and letting it air out. (see other thread for details)

Question - the only problem I have now is that when I rotate the bezel, it doesn't register anything on the watch. The connector/ sensor seems to be dead.

Anyone know how I could fix this? Do I need a new entire display unit (Samsung Gear S3 frontier (SM-R760) Display unit complete grey GH97-19658A) or is there something else I should try? A part to replace?

I did take off the bezel and I cleaned it. (did it very carefully as there are pieces that can be easily lost)

The watch works well and I can do almost everything without the bezel working but would like to get it working to 100%.

Thanks for any ideas people may have.
 

barywsf

Member
Jul 31, 2018
39
8
San Francisco
same problem on my Galaxy Watch. Any update on how to fix?

I took mine apart again hoping I could get the bezel to work but no luck.

I assume the sensor connects to the top part of the watch. There are two connecters that attach to the main part of the watch, a big one and a much smaller one. Perhaps the smaller connector is the problem.

Not a super big deal but I would love to get my watch working at 100%.

Any Samsung techs with an idea?
 

redbeard07

Member
Jan 23, 2010
30
2
I figured out that my problem was just that I was wearing a watch band with a magnetic clasp. If the magnet was too close to the watch, but bezel wouldn't work. If I switched bands everything was fine.
 
  • Like
Reactions: Dileep.Koppu

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I figured out that my problem was just that I was wearing a watch band with a magnetic clasp. If the magnet was too close to the watch, but bezel wouldn't work. If I switched bands everything was fine.